Upgrading from 1709 to 1803 via USB Solved

Page 2 of 2 FirstFirst 12

  1. Posts : 1,153
    Windows 10 Home x64 and Pro x86
       10 May 2018 #11

    bobsagetfullhou said: View Post
    Just tried to do the upgrade via USB. After I hit upgrade it says this option is not available and I have to install from within windows. Oh well, back to troubleshooting the error.
    I am a bit confused about which procedure you are following.

    To achieve what you want you can use the USB or the ISO but in both cases, you must boot to Windows normally and then run them from within it.

    This method of updating is called a Repair install or an InPlace upgrade. It is explained in the tutorial Repair Install - TenForums

    Just to avoid any possibility of doubt,
    If you boot from the USB you are going to install Windows.
    If you boot to Windows normally then use the Repair install procedure, you are going to update Windows and that is what you have said you want to do.

      My ComputerSystem Spec

  2. AddRAM's Avatar
    Posts : 2,307
    Windows 7 Pro x64 Windows 10 Pro x64
       10 May 2018 #12

    He has tried mounting the Iso and using the usb stick from within windows, both times he had problems.

    I think he should download the Iso again and try again.
    Last edited by AddRAM; 10 May 2018 at 12:34. Reason: Spelled within wrong, Dolt !!
      My ComputersSystem Spec

  3. Posts : 1,153
    Windows 10 Home x64 and Pro x86
       10 May 2018 #13

    AddRAM - Neither of those accounts for, "After I hit upgrade". Denis
      My ComputerSystem Spec

  4.    10 May 2018 #14

    To clarify, I was unsure if I would be able to boot to a USB with my win 10 ISO on it and upgrade windows to RS4. It turns out this is not a possibility and MS wants you to do an upgrade within windows. I only tried the upgrade via USB option because I was having issues running the installer from within windows. I may next try to do a repair install like suggested with my currently installed RS3. And from there try and upgrade to RS4. Thanks.
      My ComputerSystem Spec

  5. Posts : 1,153
    Windows 10 Home x64 and Pro x86
       10 May 2018 #15


    So where did you see "upgrade"? ["After I hit upgrade"]

    Yes, the update is done by booting into Windows normally first and then using the Repair install procedure.
    - But you do the Repair install with the ISO [or USB made from the ISO] of the version you are trying to update to.
    - Running a Repair install with the ISO [or USB made from the ISO] of the version you already have installed will merely be a repair procedure not an update procedure. It will not do any harm though if your purpose is just to prove that the computer is working well enough to be able to cope with it. You can help things along by disconnecting everything that is not essential [network, any other external drives, ...] and by rejecting the offer you will see during the procedure to get updates {you can worry about them afterwards}.

      My ComputerSystem Spec

  6. AddRAM's Avatar
    Posts : 2,307
    Windows 7 Pro x64 Windows 10 Pro x64
       10 May 2018 #16

    I said ALL of this in my 1st reply :)
      My ComputersSystem Spec

  7.    15 May 2018 #17

    Just want to update that my issue is resolved and I was able to upgrade via windows update. There was an issue with the recovery boot partition from macrium reflect. I had to temporarily disable that and was able to run the upgrade.
      My ComputerSystem Spec

  8. Bree's Avatar
    Posts : 9,971
    10 Home x64 (1809) (10 Pro on 2nd pc)
       15 May 2018 #18

    Glad to hear you resolved your issues. You can mark this thread Solved now. :)
      My ComputersSystem Spec

Page 2 of 2 FirstFirst 12

Related Threads
The XPS Viewer was in 1709 before the upgrade to 1803 and it is not in Apps and Features. How do I use Features on Demand with DISM to install the XPS Viewer? This does not work: dism /online /add-capability /capabilityname:XPS.Viewer~~~~
Hi, For last 1 month i have been trying to upgrade my windows from windows 10 1703 to 1709 and i get the same error -0xC1900101-0x30017 and it says "The installation failed in the First_BOOT phase with an error during BOOT operation" I have done...
Found problems The apple airport printer can't print Network Center can't click out 'Change adapter settings', so you can't disable a connection
1803 ISO Availability in Installation and Upgrade
Will the 1803 ISO be available the day of the update ?
I've managed to upgrade some of my home PC's from Win 7 or Win 8 to Wn 10 without any significant problems, but I am having major difficulty upgrading one of my PC's. It is running Win 7 Home 32-bit and when I originally ran the Windows 10...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:33.
Find Us