1.    31 Jul 2015 #1
    Join Date : Jul 2015
    Posts : 4
    Windows 10

    BITS keeps downloading Windows 10 in background


    Hello everyone!

    Yesterday I was able to upgrade for free to Windows 10 from Windows 7. And to be honest I'm don't really like to upgrade, I always want to do a fresh install when I have to change my operating system. And from what I read on some blogs, there are issues with the activation of Windows 10 that can only be fixed by upgrading to Windows 10 and then from there to make a bootable USB using their Windows 10 Tool.
    So I did that. I upgraded from Windows 10 using their app and now I want to make the USB stick for a fresh install. The problem is that today, when I put Windows 10 to download, for some reason my house ran out of power for few seconds and for some reason. Exactly then. What are the chances? Anyway, I won't go into details, let's just asume it is the same thing as running out of batery on a laptop.
    I restarted the computer and tried to continue the thing. But then there was a problem. When I re-run the Windows 10 Download Tool I got this error: https://i.imgur.com/EUtHfio.png
    I looked on C:\ and found these 2 folders (https://i.imgur.com/2RTIgTE.png) that includes, I guess, the .iso with Windows 10? https://i.imgur.com/0R76Sm6.png
    So I tried to delete that folder and start over with the Tool. But I couldn't delete the folder because it was used in a program. Then I found that the program was a service, which is BITS (Background Intelligent Transfer Service). I stopped the service and managed to delete the folders and then i tried to run the Tool again. It starts, it gives me the option to chose the edition, the architecture and so on, but then when it tries to download, it starts BITS again.
    And then there is another problem. BITS is already downloading something even if I have the Tool open or not, and that something I think is already the Windows 10 from the previous attempt. And that makes the download from the Windows 10 Tool even slower, because it downloads both of them.
    Now, after few hours, it still downloads in background and I don't know what and for how long. I have the tool closed, but BITS is still downloading something. https://i.imgur.com/wWWpnzN.png
    If I stop BITS from services, it stops downloading. But I can't keep BITS turned off, it affects Windows Update and many things, and also I can't download Windows 10 with the Tool because it uses it.

    I mean, what kind of bug is this and how can I solve it? Thank you!
      My ComputerSystem Spec
  2.    31 Jul 2015 #2
    Join Date : Oct 2014
    Posts : 391
    Windows 10x64 17035

    I ran into something similar and just reset WU. I think you're going to have to purge the SoftwareDistribution folder to get rid of the issue.
      My ComputerSystem Spec
  3.    31 Jul 2015 #3
    Join Date : Jul 2015
    Posts : 4
    Windows 10
    Thread Starter

    Reset WU? Can you give me some details about that? And what do you mean with 'purge the SoftwareDistribution'. I need to delete that folder from Windows?
      My ComputerSystem Spec
  4.    31 Jul 2015 #4
    Join Date : Oct 2014
    Posts : 391
    Windows 10x64 17035

    I use a batch script that I've had for a while to reset WU and it takes care of that folder. If you search for reset WU it'll probably pull a few of them up. I might have gotten mine from the Seven forum.

    Edit: DOS Script to Reset Windows Update Agent

    There it is.
      My ComputerSystem Spec
  5.    31 Jul 2015 #5
    Join Date : Jul 2015
    Posts : 4
    Windows 10
    Thread Starter

    Yep, that actually seems to work. Now there's nothing downloading when the Tool isn't opened, and even when it is, it doesn't.
    In that folder I only have one big .tmp file (which I think is the iso of Windows 10) instead of 5 I had before and the download works normaly. I'm even on 5% in less than one minute instead of 5% an hour I would when all of those 5 iso images downloaded at the same time. LOL
    Thank you so much for your help! +rep
      My ComputerSystem Spec
  6.    31 Jul 2015 #6
    Join Date : Oct 2014
    Posts : 391
    Windows 10x64 17035

    Glad you seem to have got it resolved.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Windows 7 - Having trouble downloading
I'm having trouble installing Windows 10, I'm told theres supposed to be a windows logo in the bottom right corner of my screen, near the time. I don't have one. I am currently making other updates to my computer in hopes it will be lodged in with...
Installation and Upgrade
Mobile Edge to get background downloading (mobile)
This could be a handy feature on the mobile version of Edge, would like to see this appear on other apps also When it comes to mobile browsing, there are some who want no limits, including the background downloading of files. Although for many...
Windows 10 News
Flipping DRAM bits - maliciously
Read more...
Windows 10 News
Windows 10: Few bits about next Technical Preview release
Read more...
Windows 10 News
Windows 10 Technical Preview - bits and pieces
Internet Explorer and the Windows 10 Technical Preview - MSDN IEBlog ...more
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:44.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums