Windows 10: Win10 not booting after Linux installation - UEFI/BIOS conflict? Solved

Page 1 of 2 12 LastLast

  1. Posts : 7
    Windows 10 pro
       1 Week Ago #1

    Win10 not booting after Linux installation - UEFI/BIOS conflict?


    I have tried to install Linux Mint, and was warned about installing due to an UEFI conflict. I ignored this warning(!).

    After that I have been unable to boot from the harddisk - no Win10 boot no Linux boot.

    I have Linux on a stick and have been able to boot that, and verify that the Win10 partitions appear fully intact (for all simple purposes at least).

    I have tried reinstalling Linux in other modes but without luck.

    Windows/Panther/Setupact.log:
    2017-12-16 12:19:44, Info IBS Callback_BootEnvironmentDetect: Detected boot environment: BIOS

    I have made a Win10 recovery USB stick and tried using that to re-establish Win10 booting, but without luck:

    Sequence of bootrec commands, in accordance with this thread:
    bootmgr not found. bootrec /rebuildbcd and /fixboot give error
    C:\>bootrec /fixmbr
    The operation completed successfully.
    C:\>bootrec /fixboot
    Element not found.
    C:\>bootrec /rebuildbcd
    Scanning all disks for Windows installations.
    Please wait, since this may take a while...
    Successfully scanned Windows installations.
    Total identified Windows installations: 1
    [1] D:\WindowsAdd installation to boot list? Yes(Y)/No(N)/All(A):a
    Element not found.

    Next step was trying diskpart in accordance with the same thread:
    C:\>diskpart
    Microsoft DiskPartversion 10.0.16299.15
    Copyright (C)Microsoft Corporation.
    On computer:MININT-FN071TD
    DISKPART> listdisk
    Disk ### Status Size Free Dyn Gpt
    -------- ------------- ------- ------- --- ---
    Disk 0 Online 465 GB 9 MB
    Disk 1 Online 7690 MB 0 B
    DISKPART> selectdisk 0
    Disk 0 is now theselected disk.
    DISKPART> listpart
    Partition ### Type Size Offset
    ------------- ---------------- ------- -------
    Partition 1 Recovery 2048 MB 1024 KB
    Partition 0 Extended 463 GB 2050 MB
    Partition 2 Logical 435 GB 2051 MB
    Partition 5 Logical 9 GB 437 GB
    Partition 6 Logical 4501 MB 446 GB
    Partition 3 Recovery 1000 MB 451 GB
    Partition 4 Recovery 13 GB 452 GB

    DISKPART> selectpart 2
    Partition 2 is nowthe selected partition.
    DISKPART> active
    Virtual Disk Serviceerror:
    The specifiedpartition type is not valid for this operation.
    DISKPART> selectpart 0
    Partition 0 is nowthe selected partition.
    DISKPART> active
    Virtual Disk Serviceerror:
    The specifiedpartition is a not a primary or logical volume.
    DISKPART>
    I have also attempted installing windows on the Linux HD partition from the recovery USB, but was told that I must boot Windows to accomplish this - which I can't.

    From Linux I have run boot-repair, and this is the report:
    Ubuntu Pastebin

    Can somebody come up with proposals for next steps - I would really like to avoid wiping my Windows 10; all data is backed up, but SW installs would be a pain to redo.

    Thanks in advance!
    Anders
      My ComputerSystem Spec

  2.    1 Week Ago #2

    Welcome to the forum. If your using uefi then running fix mbr etc has no effect as your on a gpt disk with no mbr. It's likely you have messed the uefi partition which is in effect the boot loader. Magnum reflect has option to fix this so give that a go it's free
      My ComputerSystem Spec


  3. Posts : 7
    Windows 10 pro
    Thread Starter
       1 Week Ago #3

    Thanks Samuria - currently my only working boot systems are Linux Mint Live USB and Win10 recovery USB - I assume you mean Macrium Reflect Free Macrium Reflect Free - Free download and software reviews - CNET Download.com which appears to be Windows only.
    How should I run it?
      My ComputerSystem Spec

  4.    1 Week Ago #4

    Code:
    bcdboot C:\Windows
    Try recreating your boot files (that's assuming C:, adjust accordingly).
      My ComputerSystem Spec

  5.    1 Week Ago #5

    The OP has an MBR drive and is booting in BIOS mode.

    However, the partitioning looks very strange. Which partition is your Windows installation actually located on? Can you provide the exact settings you selected when you installed Mint?
      My ComputerSystem Spec


  6. Posts : 7
    Windows 10 pro
    Thread Starter
       1 Week Ago #6

    Windows 10: Partition 2 Logical 435 GB 2051 MB
    Linux Mint: Partition 5 Logical 9 GB 437 GB
    Linux Mint Swap: Partition 6 Logical 4501 MB 446 GB

    Partition 5 was made in Windows for installing Linux, and a
    s far as I recall, later split into partition 5+6 by Linux installer.
    The rest of the partitions are misc. shipped with the PC (Win8, updated to Win10).

    I must admit I have been messing with this for some time, so I guess I have tried just about any combination of settings :-(

    In the messing around I have also tried bcdboot c:\windows with error - didn't copy the output.
      My ComputerSystem Spec


  7. Posts : 2,359
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       1 Week Ago #7

    Your disk 0 is now one big mess.
    Boot up your Recovery. Run diskpart->select disk 0->list volume then post the result.

    Do you have an external HD so we can work with ???

    EDIT: Also run diskpart->List disk. Does disk 0 has an asterisk under GPT ?
    Click image for larger version. 

Name:	p3.jpg 
Views:	50 
Size:	33.4 KB 
ID:	184740

    Your current disk 0 looks similar to the screen shots below:

    Click image for larger version. 

Name:	p2.jpg 
Views:	28 
Size:	65.6 KB 
ID:	184815
    The maximum number of partitions on MBR disk type that you can create is 4 so the 4th one becomes Extended (green box) and contains 3 logical partitions.
    Click image for larger version. 

Name:	p1.jpg 
Views:	1 
Size:	114.7 KB 
ID:	184816
    Last edited by topgundcp; 1 Week Ago at 23:44.
      My ComputerSystem Spec


  • Posts : 7
    Windows 10 pro
    Thread Starter
       1 Week Ago #8

    @topgundcp
    Can you advice how to make screenshots under the Win10 recovery disk?

    Yes I do have an external harddisk - it is used for backup (copy paste of all the files on , but about 500 GB free to play around with.

    I will be back shortly with text copy of diskpart output.
    Regards,
    Anders
      My ComputerSystem Spec


  • Posts : 7
    Windows 10 pro
    Thread Starter
       1 Week Ago #9

    I attach the output from diskpart copy/paste into notepad.
    No GPT asterisk

    diskpart output.txt
      My ComputerSystem Spec


  • Posts : 2,359
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       1 Week Ago #10

    Can you advice how to make screenshots under the Win10 recovery disk?
    There's no utility to make a screen shot with Recovery disk except using your smart phone to take a picture. However, Macrium Reflect Rescue disk does have a little utility called: pescreenshots.exe which you can run then use PrintScreen key to produce a .BMP file of the screen.

    From list volume result, drive D (465GB) is your Windows 10 OS which is partition 2 (465GB) from list partition and was converted into a logical disk, that's why you cannot set it to Active, setting Active only works with Primary partition.

    IMO, The easiest way to fix this problem is to use Macrium Rescue disk. You can download from my google drive:
    MacRescue.iso - Google Drive

    Use: Rufus - Create bootable USB drives the easy way to create a bootable USB from MacRescue.iso then boot up.

    Here's the steps you need to do:
    1. Create a backup image of your partition 2 (465GB) only, verify the image to make sure it's good and store it on the external HD.
    2. On the bottom left, click on the command icon, Use diskpart to wipe clean of your disk 0 then re-create a "System Reserved" partition

      diskpart
      select disk 0
      clean
      create par primary size=550MB
      format quick fs=ntfs label="System Reserved"
      select partition 1
      active
      set id=27
      exit

      NOTE: You can copy and paste all commands above into a text file to save typing
    3. Back to the Macrium screen, click on Backup tab then click on Refresh then go to Restore Tab to restore the backup image Next to System Reserved by drag and drop the Partition, click on "Restored Partition Properties" and set it to "Primary"
    4. Once done, click on "Fix Windows Boot Problem" and follow the screen to create a BCD to boot from
    5. Reboot.


    If you have any problem following the steps. Please ask.

    NOTE: Since your disk 0 is so messed up, you won't be able to use the factory recovery so we just clean the whole disk. If needed you can download a copy of Windows 10 ISO then re-install Windows from it.
    Last edited by topgundcp; 6 Days Ago at 02:59.
      My ComputerSystem Spec


  •  
    Page 1 of 2 12 LastLast

    Related Threads
    So basically back in the days a simple as F8 boots you to safe mode or F12 could bring up boot menu where you could boot from a flash drive or an optical disc , use a tool like hirens boot cd to undo the mess or just do a windows upgrade and you are...
    Hello, I bought new laptop (HP 250 G5) few days ago and it came without system on it so I tried to install Windows 10 from bootable DVD. I have both UEFI and Legacy modes enabled in BIOS. When I try to boot from my Interna CD/DVD ROM Drive i...
    So for the last 4 years I have played with linux installs on and off. But something I ALWAYS encounter, is when I eventually get tired of linux (from not being able to play my games), during the removal process I always screw up my bootloader then...
    How do I set my BIOS to have the DVD boot and install Windows 10 in UEFI mode? I do see a setting on my Asus motherboard UEFI "CSM Compatability" and in there are three options: UEFI and Legacy OPROM Legacy OPROM only UEFI only Do I select...
    It might be worth it to make a sticky referencing the Windows 7 tutorial for creating USB flash installation media, specifically the part 11 about moving the EFI files around. I have been bashing my head trying to figure out why my laptop refuses to...

    Tags for this Thread

    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 06:44.
    Find Us