Windows 10: Help with Legacy BIOS Boot setup and Windows 10 reinstall non-UEFI

  1.    15 Mar 2018 #1

    Help with Legacy BIOS Boot setup and Windows 10 reinstall non-UEFI


    I've been having constant problems with my new Sound BlasterX AE-5 soundcard not being consistently recognized at boot. It seems it is extremely similar to the issue that the older Sound Blaster Z cards had several years ago where they were not recognized on many, but not all, UEFI systems. The fix was to disable UEFI and boot in Legacy mode with CSM enabled. It sounds as if I'm going to need to delve into this myself, if I want to fix my sound card issues and not have to restart my computer four times every single time I boot from a shut-down state.

    My main boot drive is a Samsung 850 EVO Series 500GB SSD, that is currently setup as GPT. I believe I need to convert it to MBR, then turn off Secure Boot and set my Maximus IX Hero up in Legacy Mode and reinstall Windows 10 in non-UEFI mode.

    If I'm not mistaken, I believe I read that the Windows 10 install media creation tool creates bootable USB install drives that will boot with either UEFI or in Legacy mode. Can someone confirm that for me?

    Is anyone willing to point me to any online resources that may help me in this endeavor or offer me some advice?

    Thanks.
      My ComputerSystem Spec

  2.    15 Mar 2018 #2

    Changing from uefi to legacy bios is unlikely to solve your issue if it is a driver or hardware related issue.

    Try this first.

    Disable Fast Startup from Power menus.

    This forces a full boot up each time you boot pc.
      My ComputerSystem Spec

  3.    15 Mar 2018 #3

    Thanks for the input. I've already tried that. As a matter of fact, I disabled Fast Boot and increased my Post Boot Delay Time from 3 to 10 seconds because someone thought my computer may be booting too fast for the card to properly initialize. It makes no difference whatsoever. I've gone the whole gamut of tech support with Creative and with ASUS and I just got my motherboard back from an ASUS RMA; no problem found.

    While I am not 100% certain that this will fix my problem, I am certain that I've ready no less than fifty accounts from individuals with the previous generation of Sound Blaster Z cards that experienced the same exact symptoms that I'm experiencing and that, at the behest of Creative tech support, they switched from UEFI to Legacy Boot, and never again experienced the problem of their sound card not being properly recognized at boot once they did. I believe the new Sound BlasterX is based on a modified/improved version of the same sound core, though obviously not improved enough to have fixed this issue.

    As far as I can tell, I'm all out of options other than trying this, and as big a pain as it will be to try, I'd much rather do that than to continue to have to restart my computer four times every time I boot from a shut-down condition to get my sound to work properly, which is what it takes now.

    If you have some other things to try, I'd certainly be willing, but I've probably already tried them to no success. You never know though, you may have the one thing I haven't tried that will fix it.

    Thanks again.
      My ComputerSystem Spec


  4. Posts : 1
    windows 10 64bit
       27 Jun 2018 #4

    Good morning,

    this is the only thread that I found on internet, so far, that talked about Sound BlasterX AE-5 and BIOS and that it's closed to my issue.

    What's happened?

    Last night, I had to reset the bios on my Strix Z270E Gaming and, magically, the Sound Blaster stopped working.

    It is driving me crazy because, months ago, I had the same issue (PC not detecting the AE-5) and I remember that I found a thread somewhere that advised to change a setting on the bios and, after that, the AE-5 started working.

    Since last night, I've been changing settings and done many tests in the bios but, unfortunately, the audio card is not detected and I have no clue what to do now.

    Any advice would be greatly appreciated.

    Thanks for your help guys.

    Click image for larger version. 

Name:	1.PNG 
Views:	24 
Size:	31.2 KB 
ID:	193623

    The onboard HD audio is disabled in the bios
    Last edited by konex; 27 Jun 2018 at 04:22.
      My ComputerSystem Spec

  5.    27 Jun 2018 #5

    bfollowell said: View Post
    I've been having constant problems with my new Sound BlasterX AE-5 soundcard not being consistently recognized at boot. It seems it is extremely similar to the issue that the older Sound Blaster Z cards had several years ago where they were not recognized on many, but not all, UEFI systems. The fix was to disable UEFI and boot in Legacy mode with CSM enabled. It sounds as if I'm going to need to delve into this myself, if I want to fix my sound card issues and not have to restart my computer four times every single time I boot from a shut-down state.

    My main boot drive is a Samsung 850 EVO Series 500GB SSD, that is currently setup as GPT. I believe I need to convert it to MBR, then turn off Secure Boot and set my Maximus IX Hero up in Legacy Mode and reinstall Windows 10 in non-UEFI mode.

    If I'm not mistaken, I believe I read that the Windows 10 install media creation tool creates bootable USB install drives that will boot with either UEFI or in Legacy mode. Can someone confirm that for me?

    Is anyone willing to point me to any online resources that may help me in this endeavor or offer me some advice?

    Thanks.
    What are your complete system specs?
      My ComputerSystem Spec


 

Related Threads
How to Convert Windows 10 from Legacy BIOS to UEFI without Data Loss Starting in Windows 10 version 1703 build 15063, you can use the MBR2GPT.EXE command line tool to convert a disk from Master Boot Record (MBR) (used in Legacy BIOS) to GUID...
After running MBR2GPT on my system with a successful completion, I realized that I don't know how to change the BIOS from legacy to UEFI, resulting in the inability to boot the GPT'ed system. I was running Windows 10 Creator on an MBR system using...
How to Check if Windows 10 is using UEFI or Legacy BIOS You might be wondering if Windows 10 is using UEFI or the legacy BIOS. For more information, see: Boot and UEFI | Microsoft Docs UEFI Firmware UEFI in Windows | Microsoft Docs UEFI...
Hello, I've installed Windows 10 and Ubuntu using UEFI. But, now I created a bootable USB for a Linux that does not support UEFI, but only Legacy. I mean, when I plug the USB to my laptop, the UEFI does not recognize it, only the Legacy BIOS...
EFI, UEFI, Legacy BIOS....... in Installation and Upgrade
This weekend I will try to do a clean install of Win 10 again, from Win 7. Have to try som new methods to see if I can get my computer running flawlessly with Windows 10. I will use the clean install tutorials from this forum. I hav two options,...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:47.
Find Us