Page 1 of 2 12 LastLast
  1.    31 Jul 2015 #1
    Join Date : Jul 2015
    Posts : 8
    Windows 8.1

    Windows 10 Upgrade C1900101-20017 Error


    So I've been trying to update my PC to Windows 10 and keep getting this error!!!
    First I'll give you specifics about my PC.
    Alienware Aurora R4, came with an AMD R9270 GPU and I changed to a GTX 980. It came with one HardDrive which I replaced with an SSD and moved OS to SSD and important programs, but all files and other programs are stored on the old drive which is now E. I also have a B drive for expansion (videos etc.) i7 processor. 16GB RAM.
    So I tried the Windows 10 upgrade via Windows Update. It downloads fine, PC says configuring for Windows 10 update, then reboots back to Windows 8.1 and gives me error C1900101-20017. Tried again multiple times and got same error.
    Then I tried with Media Creation tool. I tried where it installs onto PC without USB or DVD and it got stuck at 37% then just said Installation failed, with no errors or anything. Tried again and same thing.
    So then I try the upgrade using a USB. Goes through to the thing where it asks me for key. Press skip. Choose to upgrade, then PC gives me the same error as before but with 0x infornt of it. It said:
    We couldn't install Windows 10
    We've set your PC back to the way it was just before you started installing Windows 10.
    0xC1900101 - 0x20017
    The installation failed in the SAFE_OS phase with an error during BOOT operation

    So I've tried all the usual stuff (unplug everything, turn off secure boot, disable services, troubleshooting, fixit, delete SoftwareDistribution etc.) so any help would be SO MUCH APPRECIATED! THANK YOU GUYS!!!
      My ComputerSystem Spec
  2.    31 Jul 2015 #2
    Join Date : Jul 2015
    Posts : 8
    Windows 8.1
    Thread Starter

    2015-07-31 09:42:47, Error CDiagnosticsHelper::SetSQMDatapoint: Attempting to set a datapoint in an invalid SQM session
    2015-07-31 09:42:47, Error CDiagnosticsHelper::SetSQMDatapoint: Attempting to set a datapoint in an invalid SQM session
    2015-07-31 09:42:48, Error MOUPG CDlpActionImpl<class CDlpErrorImpl<class CDlpObjectInternalImpl<class CUnknownImpl<class IMoSetupDlpAction> > > >::Suspend(1066): Result = 0xC1800104
    2015-07-31 09:42:48, Error MOUPG CSetupManager::ExecutePreDownloadMode(6591): Result = 0x800705BB
    2015-07-31 09:42:48, Error MOUPG CSetupManager::ExecuteDownlevelMode(369): Result = 0x800705BB
    2015-07-31 09:42:48, Error MOUPG CSetupManager::Execute(223): Result = 0x800705BB
    2015-07-31 09:42:48, Error MOUPG CSetupHost::Execute(370): Result = 0x800705BB
    2015-07-31 09:42:49, Error MOUPG CSetupManager::CopyDynamicUpdateFiles(2216): Result = 0x80070020[gle=0x00000020]
    2015-07-31 09:42:53, Error SP CSetupPlatform::ResurrectNewSystem: Failure: Win32Exception: \\?\C:\$Windows.~BT\Sources\NewSystem.dat: The system cannot find the file specified. [0x00000002] __cdecl UnBCL::FileStream::FileStream(const class UnBCL::String *,enum UnBCL::FileMode,enum UnBCL::FileAccess,enum UnBCL::FileShare,unsigned long)[gle=0x00000002]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(String) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(String) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(String) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(String) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(String) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]
    2015-07-31 09:42:53, Error MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]



    Just to add, I also found this :P Hope it helps
      My ComputerSystem Spec
  3.    31 Jul 2015 #3
    Join Date : Jul 2015
    Posts : 8
    Windows 8.1
    Thread Starter

    bump :P
      My ComputerSystem Spec
  4.    31 Jul 2015 #4
    Join Date : Jul 2015
    Posts : 2
    Windows 10 Home

    I also moved OS to ssd but I suppose this might address other hardware changes. The error I got was 1900101-20017 and also "installation failed in the SAFE_OS phase with an error during BOOT operation". I tried Windows Update, Media Creation Tool and almost everything suggested on different forums but nothing worked.
    What I did to successfully upgrade Windows 8.1 to Windows 10:
    1. Retrieve Windows 8.1 product key (in my case Windows 8.1 OEM version).
    I used Product Key Viewer Windows 9 Product Key Viewer Download - Softpedia
    Skip this step if you already have it.
    2. Deactivate Windows:
    Press Windows key + X
    Click Command Prompt (Admin) and type: slmgr.vbs -upk and hit Enter key
    3.Re-Activate Windows using your product key.
    Restart upgrade, mine worked this time.
    Please confirm everyone if this is working for you.
      My ComputerSystem Spec
  5.    01 Aug 2015 #5
    Join Date : Jul 2015
    Posts : 8
    Windows 8.1
    Thread Starter

    Ok I'm just about to try the update after deactivating and activating windows For your harddrive setup, how many did you have and what did you use each one for? Which ones did you leave in during the upgrade?
      My ComputerSystem Spec
  6.    01 Aug 2015 #6
    Join Date : Jul 2015
    Poole Dorset UK
    Posts : 2,567
    Windows 10 x64 Home Version(1709) Build16299.125

    Found this dated 31/07/2015


    Thank you for being a part of Windows 10.

    Boot from the Windows 10 installation media and then perform automatic repair and check if it helps.

    Follow the steps to perform Automatic repair:
    a. Insert installation media and restart the computer.
    b. Select language and click on Next.
    c. Select Repair your Computer and click on Skip this drive.
    d. Select Troubleshoot and click on Advanced Options.
    e. Here choose the option Automatic Repair and follow the prompted instructions.

    To create a media for Windows 10 follow the link:

    Download Windows 10
    http://www.microsoft.com/en-us/software-download/windows10

    Hope this may help you
      My ComputerSystem Spec
  7.    01 Aug 2015 #7
    Join Date : Jul 2015
    Posts : 8
    Windows 8.1
    Thread Starter

    Ok I tried that and it said it couldn't repair pc and left a log file on my D drive which is my DVD player?!
      My ComputerSystem Spec
  8.    01 Aug 2015 #8
    Join Date : Jul 2015
    Posts : 2
    Windows 10 Home

    Quote Originally Posted by EdDay57 View Post
    Ok I'm just about to try the update after deactivating and activating windows For your harddrive setup, how many did you have and what did you use each one for? Which ones did you leave in during the upgrade?
    It's a cheap laptop, so I'm using one ssd only.
    I previously cloned my original Toshiba HDD to this ssd using Paragon Migrate OS to SSD in order to keep the original hdd structure and to keep the product key that is stored in the UEFI bios. Windows stayed activated as planned.
    I am quite sure that if I used the original HDD for the upgrade instead everything would have worked out without any issues.
      My ComputerSystem Spec
  9.    01 Aug 2015 #9
    Join Date : Jul 2015
    Posts : 8
    Windows 8.1
    Thread Starter

    Hm well thats interesting. Exact same software I used so I think we are getting closer to the cause...
      My ComputerSystem Spec
  10.    01 Aug 2015 #10
    Join Date : Jul 2015
    Posts : 8
    Windows 8.1
    Thread Starter

    I'm starting to think that a factory reset may be the only way forward...
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved after upgrade windows 10 cannot activate Error code: 0xC004F034
did anyone get this Error code: 0xC004F034 after upgrade to windows 10? 26543
Windows Updates and Activation
Upgrade from 7: Update Error Code 80200053, & MediaCreationTool error
http://puu.sh/jj8wQ/4cad6d8add.png I have tried what I believe to be everything at this point. Clearing out the update download folder and retrying the update does not help whatsoever. Forcing the update through a command prompt just gets the...
Windows Updates and Activation
Upgrade windows 7 error
""The installation failed in the SAFE_OS phase with an error during INSTALL_RECOVERY_ENVIRONMENT OPERATION"" Please help!
Installation and Upgrade
Upgrade to 10122 gets error fbl_impressive Professional 10122 - Error
I upgraded to 10074 with no problems but trying to upgrade to 10122 gets error fbl_impressive Professional 10122 - Error 0xd0000225. I'm logged into my Microsoft account, so I don't think that's the problem. I've cleaned up all the files and...
Installation and Upgrade
Windows 10 upgrade error 0xc1900101-0x30018 is back.
Don't know what program/driver/windows update is causing it. This could be an issue for upgrading. There is one other method I haven't tried. See, Microsoft wants you to upgrade to the free version. Looks more like I will be sticking...
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:42.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums