Windows 10: Windows 10 Upgrade C1900101-20017 Error

Page 2 of 2 FirstFirst 12

  1. Posts : 2,554
    Windows 10 Home x64: 1607 Redstone (1) Build 14393.1198
       01 Aug 2015 #11

    Some one on another forum recommended Macrium Reflect read up on it and that is the one I will be using as I have an external hard drive on usb out of an old laptop formatted already
      My ComputerSystem Spec

  2.    19 Aug 2015 #12

    Cornel said: View Post
    I also moved OS to ssd but I suppose this might address other hardware changes. The error I got was 1900101-20017 and also "installation failed in the SAFE_OS phase with an error during BOOT operation". I tried Windows Update, Media Creation Tool and almost everything suggested on different forums but nothing worked.
    What I did to successfully upgrade Windows 8.1 to Windows 10:
    1. Retrieve Windows 8.1 product key (in my case Windows 8.1 OEM version).
    I used Product Key Viewer Windows 9 Product Key Viewer Download - Softpedia
    Skip this step if you already have it.
    2. Deactivate Windows:
    Press Windows key + X
    Click Command Prompt (Admin) and type: slmgr.vbs -upk and hit Enter key
    3.Re-Activate Windows using your product key.
    Restart upgrade, mine worked this time.
    Please confirm everyone if this is working for you.
    I tried this with my HP Pavilion running windows 8.1 on an SSD Drive. I still get the same error message.
      My ComputerSystem Spec

  3.    27 Aug 2015 #13

    Error 1900101-20017


    I keep getting this error message, I don't have installation media as per the attached comment, what would I do to try and correct this please?





    hTconeM9user said: View Post
    Thank you for being a part of Windows 10.

    Boot from the Windows 10 installation media and then perform automatic repair and check if it helps.

    Follow the steps to perform Automatic repair:
    a. Insert installation media and restart the computer.
    b. Select language and click on Next.
    c. Select Repair your Computer and click on Skip this drive.
    d. Select Troubleshoot and click on Advanced Options.
    e. Here choose the option Automatic Repair and follow the prompted instructions.

    To create a media for Windows 10 follow the link:

    Download Windows 10
    http://www.microsoft.com/en-us/software-download/windows10

    Hope this may help you
      My ComputerSystem Spec

  4.    02 Oct 2015 #14

    I had this same problem since 29th July. Windows 7 just would not upgrade to 10 (Home) - c1900101-20017 every single time.
    I tried nearly everything suggested by so-called 'experts' in forums and also stressed-out, underpaid Microsoft support types. I ended up rebuilding the PC from scratch after following some spurious advice about powering off before the 1st reboot. Nobody really knew what the problem was - still don't really. After about a dozen or so attempts to upgrade, I saw a Youtube by an Eastern European guy who had a similar MoBo to mine. He updated the BIOS to the latest version, then SET THE BIOS TO OPTIMUM DEFAULTS (F5) which disables any overclocking settings among other things. I figured that it couldn't hurt to try the upgrade one more time with the BIOS defaults...
    To my astonishment, the upgrade proceeded without a hitch.
    So before you uninstall anything, disconnect any peripherals or change your precious world even one little bit, please try this simple thing. No harm can come from it, unlike a lot of the so-called advice that is floating around.
    Dear Microsoft: surely you knew about this? Not everyone needs an overclocked CPU - most users don't even know what I mean by that. Come on guys, tell us these things!

    Finally Satisfied
    M
      My ComputerSystem Spec

  5.    04 Nov 2015 #15

    EdDay57 said: View Post
    Ok I tried that and it said it couldn't repair pc and left a log file on my D drive which is my DVD player?!
    I'm having the same problem trying to upgrade to Windows 10. I also used Paragon software to clone an HDD to SSD, which other posters mentioned as well. So, I believe this is the primary contributing factor here.

    When I attempt the upgrade, as some point I also get a rectangular popup message in the upper-right corner of the screen about alleged "problems on drive D:" and "running chkdsk", even though I have no drive D: on my machine. What really happens is that the update picks up hidden EFI partition on drive C: and for some reason assigns drive letter D: to it. This might be the actual reason for the failure. Immediately after the reboot (and the "SAFE_OS" message about the failure), I can actually see drive D: mapped to the EFI partition. It is visible in Explorer, even though it does not exist in Disk Manager. (The next reboot makes D: disappear for good).

    Apparently, Paragon software HDD-to-SSD migration process does something incorrectly. This is what later makes Windows 10 updater incorrectly interpret EFI partition on system drive as some sort of "broken" D: drive. And this is what makes the update to fail.

    In my case I just did a clean reinstall of Windows 8 on the target drive (deleting all C: partitions in the process) and then updated it to Windows 10. That way it went through without any issues.
    Last edited by AndreyT; 04 Nov 2015 at 13:29.
      My ComputerSystem Spec

  6.    03 Jan 2016 #16

    I just wanted to come in here and post what wound up being my solution after months of trying to upgrade to W10.
    I spent MONTHS trying to upgrade. It turned out to be my boot partition. Its usually called "System Reserved"( it ususallly wont show unless you are in disk management). On my machine it had been deleted when I incorrectly restored a system image to a new drive after a drive failure. Macrium startup repair fixed the machine after the restore so it would boot, but did not actually make a new boot partition. When I was first trying to install W10, the machine would not even boot. Just a black screen because W10 needed the boot partition. So, I created one, but after my C drive. So, my disk had C drive first, then the boot partition. After trying the upgrade, it would boot, but back to W7 with the C1900101-20017 error.... Months went by and I tried all of the suggestions...replaced my network card because old broadcom cards could cause the error and uninstalled many unused programs...still no dice on getting W10 to work. Then, I decided to move the boot partition to before the C drive partition and whammo, W10 installed without a hitch... TLDR version; make sure your boot partition (maybe called system reserved) is before your C drive. You have to look in disk management and the boot partition should be before(to the left) of the partition that contains your operating system...If it isnt, use a tool like mini tool partition wizard free to move teh boot partition to the left of the os
      My ComputerSystem Spec


  7. Posts : 1
    Windows 8.1 x64
       09 Mar 2016 #17

    I am having the same problem but my SSD has additional partitions


    I am having the same problem but my SSD has a two more partitions. I will list them in order:

    WINRE_DRV
    SYSTEM_DRV
    Local Disk
    Windows8_OS

    With my partitions in the above sequence, the SYSTEM_DRV is not directly adjacent to the Windows8_OS partition. I am curious how your partitions are layed out. I also used Paragon Hard Drive Manager to copy from a smaller SSD to a larger SSD. Any ideas would be appreciated.
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
did anyone get this Error code: 0xC004F034 after upgrade to windows 10? 26543
http://puu.sh/jj8wQ/4cad6d8add.png I have tried what I believe to be everything at this point. Clearing out the update download folder and retrying the update does not help whatsoever. Forcing the update through a command prompt just gets the...
Upgrade windows 7 error in Installation and Upgrade
""The installation failed in the SAFE_OS phase with an error during INSTALL_RECOVERY_ENVIRONMENT OPERATION"" Please help!
I upgraded to 10074 with no problems but trying to upgrade to 10122 gets error fbl_impressive Professional 10122 - Error 0xd0000225. I'm logged into my Microsoft account, so I don't think that's the problem. I've cleaned up all the files and...
Don't know what program/driver/windows update is causing it. This could be an issue for upgrading. There is one other method I haven't tried. See, Microsoft wants you to upgrade to the free version. Looks more like I will be sticking...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:35.
Find Us