Windows 10: How to get to secure boot setting in new UEFI interface Solved

  1.    26 Feb 2018 #1

    How to get to secure boot setting in new UEFI interface


    I recently solved my updates problem here, by performing an in-place upgrade of windows. I am now trying to do the same for my neighbour who is experiencing the same problem. His machine is an ASUS A510U.

    On entering UEFI settings I find a completely new interface where there is no mention of Secure Boot, which I need to ensure is disabled. The setting for CSM is disabled, so I can't see if legacy BIOS is available.

    Can anyone advise how to overcome this problem please?
      My ComputerSystem Spec

  2.    26 Feb 2018 #2

    If C is disabled, pc will be using UEFI. Secure boot is an option in bios somewhere. AFAIK all UEFI bioses have the ability to turn off secure boot.

    Anyway, Windows 10 is "secure boot friendly" so does not need secure boot switched off.
    Last edited by cereberus; 26 Feb 2018 at 08:00.
      My ComputerSystem Spec

  3.    26 Feb 2018 #3

    Legacy 16-bit BIOS support (CSM) is being deprecated in all new UEFI systems and will be entirely removed by 2020. This was announced last year by Intel.

    Why do you even need CSM? Most OS, including modern Linux distros will work just fine if you use their appropriate EFI loaders, even in dual boot configurations.
      My ComputerSystem Spec

  4.    26 Feb 2018 #4

    Why do you need to get into UEFI settings to do an in-place upgrade? An in-place upgrade is performed from inside Windows and requires no UEFI settings changes at all.
      My ComputerSystem Spec

  5.    26 Feb 2018 #5

    Thank everyone for your comments and advice. I decided to run the MS iso file and after many hours the job is done. No mention of secure boot in the process.
    My neighbour will be greatly relieved.
    Regards and thanks again.
      My ComputerSystem Spec


 

Related Threads
UEFI Installation With Secure boot enabled in Installation and Upgrade
Hello tech guys, i need emergency help, i posting this thread from my frined's computer, i have a HP laptop, and few days ago i send it to tech shop for motherboard repair, and they did it as well, but after few days i am facing problem with...
Solved UEFI with secure boot disabled in AntiVirus, Firewalls and System Security
I ran a Belarc analysis and it showed a notification that the " UEFI with secure boot is disabled ".Is this a default setting or does it need to be enabled?I looked at the boot settings but was unable to figure out how to resolve this issue.I am not...
I want to enable UEFI with Secure Boot and I do have an option to enable Secure Boot. But how can I tell if I am running UEFI firmware version 2.3.1.c ? Because to enable Secure Boot, machines must have UEFI firmware version 2.3.1.c I went to...
Hei, So I'm the guy who tried to move from Legacy to UEFI some days ago. I managed to move both Ubuntu and W10 to UEFI. More info on both of the situations here: Solved Can't boot into UEFI mode - Lenovo Z50-70 - Windows 10 Forums ...
Boot mode uefi with secure boot disable in Installation and Upgrade
Ok im about to upgrade to win 10 then do a clean install afterwards of win 10, but i wanted to assure i have everything correct before i start. I updated again my profile with Belarc to assure i have a completed list of my software, i notice this...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:59.
Find Us