Windows 10: Windows 10 won't boot after installing Ubuntu to a different drive Solved

Page 1 of 3 123 LastLast
  1.    01 Feb 2018 #1

    Windows 10 won't boot after installing Ubuntu to a different drive


    So, here is my problem:
    I tried to install Ubuntu 16.04.3 LTS to an old HDD I have (let's call it HDB) while maintaining my main OS (Windows 10) on my main HDD (let's call it HDA). The problem is that after I installed Ubuntu to HDB my Windows 10 (which was on HDA) wouldn't boot.

    Full history to better contextualize:
    Before starting the Ubuntu installation process I got a message saying that there were some Windows partitions on HDB, which I found strange since I formatted the drive before (and could boot my Windows 10 just fine), but just to be sure I cancelled the installation, shutted the PC down and removed both SATA and power cables from HDA so it would be impossible for the installer to do any changes on that drive. Then I installed Ubuntu to HDB - still got the message saying there were some windows folders/partitions in it, but I was pretty sure it had nothing to do with my HDA installation - and later on it loaded just fine. So I unplugged HDB's (now with Ubuntu) SATA and power cables from my MOBO and plugged HDA (which should have my Windows 10 installation untouched) back in, but to my surprise Windows 10 wouldn't boot, it was (still is) giving me the "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key" error.
    I looked for help on Ubuntu forums, we tested some things there and came to the conclusion that I somehow either managed to delete my EFI partition on HDA or it was on HDB the whole time and for some reason I was able to boot Windows 10 even with HDB disconnected and/or formatted (which I did before installing Ubuntu).
    So I think the question now is: Is it possible (if so, how) to recreate the EFI partition, which possibly never existed on HDA in the first place? I've seen some guides on how to do it, even some 3rd part apps that claim to do it, but I think my problem is quite different of what other people been having, and I don't want to mess it any further.
    I ran gpart on a live-usb Ubuntu to see what is the state of my HDDs and here it is:

    HDA (sda):
    Click image for larger version. 

Name:	Screenshot from 2018-02-01 15-28-56.png 
Views:	11 
Size:	668.2 KB 
ID:	175089
    Only shows a "msftres" partition (which is not the OS partition, I guess?) and a "basic data partition". Could Windows 10 installation be on the later?

    HDB (sdb):
    Click image for larger version. 

Name:	Screenshot from 2018-02-01 15-29-20.png 
Views:	8 
Size:	670.1 KB 
ID:	175088
    As expected, only has partitions related to Ubuntu (Linux) installation. If my Windows 10 EFI partition (and maybe others?) was there it was 100% overwritten it seems.

    Sorry for the lack of more technical info or if it looks confusing, Iím a just a noob when it comes to IT, I only know how to do some formatting, partitioning, OS installing and know a little of hardware, but thatís all, I have zero programming background. And sorry for any grammar mistake, English is not my first language. Thank you in advance.
      My ComputerSystem Spec


  2. Posts : 1,879
    Windows 7 Pro x64 Windows 10 Pro x64
       01 Feb 2018 #2

    Just sit tight, someone will be along to help you.

    Sounds like an easy fix.

    Did you even look at HDB when you got the message telling you there were windows files on it ?
      My ComputersSystem Spec

  3.    01 Feb 2018 #3

    No, I didn't. I thought that whatever Windows partition was there was from the old Windows installation I had in that drive a long time ago. I did "look" at it on "Computer" after formatting and it showed as empty (~160GB space), but EFI and other system partitions do not show there, from what I learned today, since they have no letter assigned to them, right?
      My ComputerSystem Spec


  4. Posts : 1,879
    Windows 7 Pro x64 Windows 10 Pro x64
       01 Feb 2018 #4

    Yes there is 1 hidden partition

    It would look like this in windows and the 2nd shot is Partition Wizard showing the other 16 MB partition.
    Attached Thumbnails Attached Thumbnails Capture.JPG   Capture 1.JPG  
      My ComputersSystem Spec


  5. Posts : 1,879
    Windows 7 Pro x64 Windows 10 Pro x64
       01 Feb 2018 #5

    Did you or someone else install W7 on HDA, while HDB was hooked up ?

    I`m wondering how any windows files got on HDB.

    This is why windows needs to be installed with all and any other drives unplugged.

    If NavyLCR sees this thread he will help you out quick.
      My ComputersSystem Spec


  6. Posts : 3,242
    3-Win-7Prox64 2-Win10Prox64
       01 Feb 2018 #6

    HI,
    Only other partition would be a Fat32 I believe it is about 16mb's it's the boot loader for win-10.
      My ComputersSystem Spec


  7. Posts : 1,879
    Windows 7 Pro x64 Windows 10 Pro x64
       01 Feb 2018 #7

    The hidden partition is 16 MB you can see it in my snip of PW. It's labeled Other, not Fat32.

    I still don't see how it could get on another drive.

    Just another reason why I don`t do UEFI installs
      My ComputersSystem Spec


  • Posts : 3,242
    3-Win-7Prox64 2-Win10Prox64
       01 Feb 2018 #8

    Hi,
    Yeah maybe that is for bitlocker ?
      My ComputersSystem Spec

  •    01 Feb 2018 #9

    Did you or someone else install W7 on HDA, while HDB was hooked up ?
    Maybe I installed Windows 10 on HBA while HDB was pluggued, could be the reason why boot files ended up there, but I can't be sure. The strange part is that after Windows 10 was intalled on HBA I am pretty sure that I removed HDB and could boot it with no problem at least once.

    So, I just formatted HDB again, converted to GPT and installed a fresh Windows 10 on it, just to be sure I removed the SATA and power cables from HDA again. Installation went perfectly fine, installed MiniTool Partition Wizard, shutted it down, plugged HDA cables back in, booted the new Windows 10 (on HDB), launched MiniTool Partition Wizard and HDA doesn't even show there! It's only getting worse hahaha!Click image for larger version. 

Name:	145.png 
Views:	4 
Size:	69.5 KB 
ID:	175146
    New Windows 10 installation on HDB seems to have every partition at least...
      My ComputerSystem Spec

  •    01 Feb 2018 #10

    Ok, I set BIOS config to default (I changed boot option to "UEFI only" to load the usb with Windows installer before installing it) and HDAis showing now. I don't know if that was really the problem, but it's showing now and that's one less thing to worry hah.
    So, I found some ways to restore the EFI partition, one of them is by using the "Partition Recovery" option in Partition Wizard, or creating it "manually" with DiskPart on Windows PE. The first option seems easier, but is it really safe? Link with the methods: How to Restore Deleted Windows Partition after Windows Can't Boot?
    Edit: printClick image for larger version. 

Name:	146.png 
Views:	16 
Size:	89.3 KB 
ID:	175148
      My ComputerSystem Spec


  •  
    Page 1 of 3 123 LastLast

    Related Threads
    Hi guys, So I'm no longer able to boot into my main drive, but all my files and folders on that drive still look intact. I honestly don't know what went wrong or if there is any way to fix this other than reinstalling Windows. Tried startup...
    Re-installing Windows 10 over Ubuntu in Installation and Upgrade
    A friend of mine installed Ubuntu 14.04 on my laptop because he thought it would make it faster but I have almost know knowledge of the operating system so its been pretty horrible. I made a boot USB drive using the windows media creation tool and...
    I used to use Windows for my work and It used to boot very fast. However, after dual boot with Ubuntu, my windows boot time became very long, it was annoying. I deleted Ubuntu, FORMATED ALL DRIVE, devided partitions, reinstalled Windows but it is...
    Apologies for the very basic question, but this is my first attempt at creating a virtual machine within Windows 10 pro using hyper-v. I have created a VM, and during the process allocated a drive/folder for that VM, and selected the Linux iso file...
    Hi, just want to check can I duel boot W10 & W7 on a SSD drive. Thanks
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    © Designer Media Ltd
    All times are GMT -5. The time now is 05:50.
    Find Us