Windows 10: ADK Deployment & v1709 Question (with a lot of caveats)

  1.    09 Jan 2018 #1

    ADK Deployment & v1709 Question (with a lot of caveats)


    Excuse me if this a bit long winded but feel I have to explain what it is I'm encountering and trying to do.

    Okay I upgraded from W7 to W10 in 8/2015 for a little history. I then obtained an use Macrium Reflect creating a WinPE using at that time the latest ADK Deployment Kit (created a bootable USB etc) now I've found that upgrading from W7 to W10 that I am in the MBR volumes/partitions an would like to convert the OS to the UEFI system. I have since done all the W10 upgrades an am now in the W10 Fall Update version (v1709) while still using the older version WinPE that I originally did in 10/2015.

    I see where the v1703 (an later versions) now have a conversion available that can convert MBR to GPT using the on-board utility that Windows now has added to the OS. I also see where it is recommended to use the newer version ADK Deployment & Imaging Tool. Do I need to create another USB or can I use the one I have previously used? Or can I update the WinPE USB to the newer version Deployment Tool and still have the same usage for Macrium Reflect?

    I also have seen online that there is a CMD prompt to do the same thing. (mbr2gpt.exe /convert /allowfullOS) without the WinPE boot.

    What I'm looking for is some guidance on how to go about doing this in the correct way an if there is a tutorial covering this.
    Last edited by tazmo8448; 10 Jan 2018 at 00:45. Reason: additional info for CMD prompt (allowfullOS)
      My ComputerSystem Spec


  2. Posts : 2,252
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       10 Jan 2018 #2

    can I update the WinPE USB to the newer version Deployment Tool and still have the same usage for Macrium Reflect?
    The mbr2gpt.exe is available if you create a new Macrium Rescue disk using WinPE 10. Boot up Macrium Rescue disk, click on the Command Prompt Icon on bottom left of taskbar to open, then use mbr2gpt.exe to convert.
    I also have seen online that there is a CMD prompt to do the same thing. (mbr2gpt.exe /convert) without the WinPE boot.
    If you have multiple Windows 10's then you can convert the one that's not currently running. You cannot convert the disk while Windows is running, you must use WinPE.

    mbr2gpt.exe will work if your current Windows has a standard partition layout. Since you upgrade from Windows 7, the disk layout might cause error.
      My ComputerSystem Spec

  3.    10 Jan 2018 #3

    Here's what I did without creating another USB w/WinPE although on restarts the Macrium option is no longer showing as before. So it looks as though I'll have to create another Macrium setup using the newer ADK tool.
    this btw is from the Intel site.......

    Convert partition table from MBR to GPT with MBR2GPT.exe
    Requirements:

    • Windows® 10 Creators Update x64 (Version 1703, Build 10.0.15063) or later.
    • A computer able to boot UEFI. In the BIOS setup, you should see options for UEFI boot. Confirm with your computer manufacturer for specific support.

    Instructions:

    1. Open Command Prompt with administrator privileges
    2. Issue the following command: mbr2gpt.exe /convert /allowfullOS
    3. Shut down and boot into your BIOS
    4. Change your settings to UEFI mode
      My ComputerSystem Spec

  4.    10 Jan 2018 #4

    here is the link to that site if needed.......
    Converting Windows® Installation from Legacy to UEFI without Data Loss
      My ComputerSystem Spec


  5. Posts : 2,252
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       10 Jan 2018 #5

    @tazmo8448
    Sorry I made a mistake, forget about what I said in the previous post. mbr2gpt.exe is not available with Macrium Rescue disk so you must boot from Windows Installation disk version 1703 or later.

    However, I mounted the boot.wim from Macrium Disk, copy mbr2gpt.exe to make it available.

    Here's the latest version of Rescue disk which I added mbr2gpt.exe if you want it:
    MacRescue.iso - Google Drive
    Last edited by topgundcp; 10 Jan 2018 at 01:29.
      My ComputerSystem Spec

  6.    10 Jan 2018 #6

    What I ended up doing was use the mbr2gpt.exe /convert /allowfullOS CMD prompt thus creating the GPT partitions (it added a 100 mb FAT32 partition) then went into Macrium ran an image file/backup... then downloaded the latest ADK Tool... then went to the Macrium Rescue Media Wizard an created another up to date bootable USB ( it found the newer ADK info an updated itself) plus added the boot option so it now shows when I restart windows as another OS boot option.
    Booted to the new WinPE USB (to double check) and now all is well in Mudville....

    thanks topgundcp for your time an effort ..I really do appreciate it...
    it had been two years since I last did this sort of thing but once I got back to it it slowly started coming back to me on how to go about it again...I was afraid I'd screw up something that really worked well for me these past two yrs but good ole MacReflect idiot proofed it more or less....
    Last edited by tazmo8448; 10 Jan 2018 at 02:33. Reason: additional info
      My ComputerSystem Spec


 

Related Threads
Installation Blocked on v1709 in Drivers and Hardware
I'm having issues installing Network Wifi drivers from Dell Support Page/Intel Drivers. Win10 OS version is OK But for some reason the install is blocked. Running the Falls Creators Update v1709 Has anyone had these issues before? I...
Windows 10 S v1709 installation key in Installation and Upgrade
Hi In a Windows 10 S v1709 installation, how do I get his product installation key? Thanks Bye
As the title says, I got the update to V1709 and so far everything is working fine except for the CMD, but powershell works. I tried the following commands sfc /scannow DISM /Online /Cleanup-Image /RestoreHealth But none of these seem...
With only 2 main reservations...err make that 2.5, I give current Opera v.44.0 a big thumbs-up. Good features, great efficiency, good if not great speed, good stability. The 2.5 caveats: 1.0 Bad default on font scaling makes fonts pale and...
Upgrade Questions With Caveats in Installation and Upgrade
I've done the upgrade to Windows 10 at least 30 times so far. All have been non-domain computers. I've done one so far that was a domain computer, and it was removed from the domain, thanks to the remove everything option. So my question is...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 06:32.
Find Us