Windows 10: 1703 to 1709 Upgrade - 0xc1900101 0x30018 error, have tried everything


  1. Posts : 2
    Windows 10 64-bit
       27 Dec 2017 #1

    1703 to 1709 Upgrade - 0xc1900101 0x30018 error, have tried everything


    I really hate to post for help anywhere, but this one has me stumped. The error I am getting is in the title, and appears like for many others at 42% on the upgrade process. It gives me the cannot configure for my hardware error and then gives me the hex codes whenever I try to update manually via USB or ISO. I have tried literally everything I have come across after 9 hours of troubleshooting.

    -manually updating via USB and ISO instead of windows update
    -uninstalled webroot AV
    -removed all USB devices except mouse/kb
    -tried manually resetting bits, etc via admin console
    -I do not have IIS installed on this computer
    -All drivers are current
    -SFC and remote image restoration commands all executed and no errors

    Issues of note:
    -Some of the FCU apps are actually somehow installed on my system like paint 3d and some of the MR apps, but I can't run any of them. I have a Samsung Odyssey I am trying to attach to the system which is why I am even bothering with all of this and it won't work without 1709 properly installed and up to date :/

    I have attached both files from the panther folder for help. I have read through them and I understand some of what I am seeing but the errors on the errlog file I have had problems nailing down a proper cause/effect in order to see which one of them is the one causing the main issues. The storage errors especially I have no clue why they are there since I have no issues. This system is more or less brand new and I will list my specs at the end.

    I am starting to think there was an issue I missed during the first time the upgrade failed but I am not sure. The rollback directory error file only has one line, and it's "IBSLIB OSRollbackService::CBootFilesRestoreCheckpoint::Rollback: Failed to create WinPE rollback directory: H:\$WINDOWS.~BT\Sources\Rollback\WinPE[gle=0x000000b7]" Which is odd since I have no H:\ drive currently attached to my system. This goes back to my belief that the upgrade screwed up AND I didn't properly roll back? I am really trying to stop from having to clean install windows because I shouldn't have to - my rig is cleanly built and well maintained - there is no reason for this and is obviously some kind of error from MS's side that they haven't addressed yet?


    My specs:

    Ryzen 7 1800x
    Asus Rog Hero VI
    16GB FlareX DDR4 3200mhz
    OS installed on Samsung NvMe drive @ 500GB w/ 390GB free
    Asus Strix GTX 1080ti
    Custom water loop should be immaterial


    If someone that is knowledgeable can help me with these logs, I would be immensely grateful. You don't have to treat me with kid gloves I am pretty knowledgeable with my rig, comfortable with Registry edits and the command console but I am a stranger to powershell just FYI. Please help and thank you in advance! If I missed some critical info my apologies but i've been up all night working on this and am at the end of my rope. Need sleep!
      My ComputerSystem Spec


  2. Posts : 5,703
    Windows 10 Pro X64 16299.192
       27 Dec 2017 #2

    If you are doing an update, you don't need USB. Just right click on the ISO and select Mount, then run Setup.exe from the mounted iso.
    If you createed the USB flash drive directly from the MCT (Media Creation Tool) then I would suggest running MCT again and create the ISO instead then do the Mount as above.

    See if that helps.
      My ComputersSystem Spec

  3.    27 Dec 2017 #3

    atcline27 said: View Post
    I have attached both files from the panther folder for help.
    Setuperr and Setupact I suppose? Can't see any attachments at all though in your post - can you try again?

    Either attach them as .txt files or put them inside [code] ... [/code] tags

    Without that it is hard to say but unplugging all USB and uninstalling any graphic drivers is always a good start.
      My ComputerSystem Spec


  4. Posts : 2
    Windows 10 64-bit
    Thread Starter
       27 Dec 2017 #4

    hmm thought I did attach them that's odd. Yes I already unplugged usb and i'm updated to latest Nvidia graphics drivers.

    I will try the iso way but I don't see how that would make any difference as the installation process should be the same unless there is something that I am unaware of when you create bootable media on USB vs ISO. I will still give it an attempt later tonight.

    I was able to get the setuperr.log attached but the act.log will not attach for the life of me and I cannot copy and paste a file that big without freezing the page it appears.... not sure what's going on here it's only a 70k KB file? Anyhow I compressed it to a .rar so both are attached. Thanks again for your help!
    1703 to 1709 Upgrade - 0xc1900101 0x30018 error, have tried everything Attached Files
      My ComputerSystem Spec


  5. Posts : 17,841
    windows 10 professional version 1607 build 14393.969 64 bit
       28 Dec 2017 #5

    The title of the thread is: 1703 to 1709 Upgrade - 0xc1900101 0x30018 error, have tried everything


    The logs that were submitted were:
    setuperr
    setupact

    Using search > find
    There are no hits for the title:
    0xc1900101

    or
    0x30018


    Are there portions of the logs that are missing?
    Are these the logs for this error code?

    How come there are no hits in the logs for the thread title?



    Look for these folders and files and post into the thread any of the files:

    C:\Windows\Panther
    setuperr.log
    setupact.log
    Setupmem.dmp
    setupapi.dev.log
    BlueBox.log
    Event logs (*.evtx)
    C:\$Windows.~BT\Sources\Rollback
    $Windows.~bt\Sources\Rollback\setupmem.dmp
    $Windows.~bt\Sources\Rollback\setupapi\setupapi.dev.log
    $Windows.~bt\Sources\Rollback*.evtx
    $Windows.~BT\Sources\Panther\UnattendGC
    miglog.xml
    Windows\Logs\Mosetup

    Run the DM log collector and post a zip into the thread:
    BSOD - Posting Instructions - Windows 10 Forums
    It will collect: msinfo32, dxdiag, mini dumps, drivers, hosts, install, uninstall, services, startup, event viewer logs, etc.
      My ComputerSystem Spec

  6.    28 Dec 2017 #6

    Your error log has this
    Code:
    2017-12-27 08:20:52, Error                 SYSPRP ActionPlatform::LaunchModule: Could not load DLL C:\Windows\System32\inetsrv\iissyspr.dll; dwRet = 0x7e[gle=0x0000007e]
    You could try getting rid of IISAdmin and try again. See: 1703 - 1709 update fails, Solved - Page 2 - Windows 10 Forums

    If that doesn't work (sc delete "IISADMIN") might. See: Sysprep problem on WES 7
      My ComputerSystem Spec


 

Related Threads
Solved Windows 10 Error code 0xc1900101-0x30018 in Installation and Upgrade
Upgrading a Windows 8.1 installation and it stuck at getting devices ready at 2%. No BSOD. Has to be specific to 8.1 as I have already installed 10 on a clean partition with no issues on this machine. All drivers up to date. Did try removing Avast....
Trying to update an existing Win10 1703 to 1709. It fails consistenly with the following error messages: ======================= We couldn't install Windows 10 We've set your PC back to the way it was right before you started installing Windows...
Hey guys, I've been having a problem with upgrading to Windows 10. I've tried using the tool both by running it on my PC and putting it on a USB. It gets through the first part of copying files and does the first reboot, then it starts back to...
Hello, I tried install Win10 several times. First when I wasnt patient, I downloaded Microsoft Media Creation Tool and tried to install windows that way, those attemps ended on 33%, second time and 32% with 6% in the second step, with the same error...
Don't know what program/driver/windows update is causing it. This could be an issue for upgrading. There is one other method I haven't tried. See, Microsoft wants you to upgrade to the free version. Looks more like I will be sticking...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:46.
Find Us