Windows 10: Crazy Display Solved

Page 1 of 2 12 LastLast
  1.    24 Nov 2017 #1

    Crazy Display


    While on my HP Pavilion 6620 F the screen momentarily went blank then the monitor had "No Signal" for about 2 seconds then everything came back but at a different display size. Going to settings and resolution it now has only 3 choices and it gave me 1024 X 768 (Recommended). That's way bigger than normal for my 22" monitor. Changing it doesn't work out either. It's either much bigger or smaller. I've done all windows updates, checked for updates on my video card VIA the device manager. What I did do to get it back for a short time (1 hour) was to do a system restore. When it failed again, I did another system restore and it failed in about 20 seconds. Everything is there on the screen but just much larger (wider only). Am I losing my video card or missing something else? I've also ran System Mechanic, Malwarebytes and windows defender all to no avail.
      My ComputerSystem Spec

  2.    24 Nov 2017 #2

    Press the Win key+X and choose Device Manager. Expand Display, if there is a yellow flag next to the Video device, or if it has the Microsoft Default driver, then you need to download a driver
    Go to the HP Drivers site. HP Software and Driver Downloads for HP Printers, Laptops, Desktops and More | HP® Customer Support Type in your Full Model #, (ie) Pavilion 6620 Fxxx Choose your Windows 10 version (ie) 32bit or 64bit, and download the Display/Video driver for your computer.
      My ComputerSystem Spec

  3.    24 Nov 2017 #3

    I've tried that. This is what happens: I go to the location for HP Video check and when I click on it I get a pop up saying "This app has been blocked for your protection" "An administrator has blocked you from running this app, for more information contact the administrator." The thing is I am the administrator. Clicking on the properties for the video check and giving myself full control under the security tab makes no difference. Who, in this case, is the administrator that's stopping me? I really think I got hit with some malware or a virus and I don't know how to get rid of it.
      My ComputerSystem Spec

  4.    24 Nov 2017 #4

    No one said to go to HP Video check?!
    Follow the instructions in Post #2 and download the driver.
    The driver downloads as a Zipped file, when you click on it, it unzips to C:\swsetup\ or some such, take note of where it unzips. If the Driver fails to install, browse to this folder, open it and Right click Setup.exe and choose to Run As Administrator. If the driver is for an older version of Windows, (ie) Windows 7 then Right click Setup.exe choose Properties/Compatibility and make it compatible with that OS.
      My ComputerSystem Spec

  5.    25 Nov 2017 #5

    From the device manager, I do have the latest drivers. From HP, even as administrator it says I'm blocked by another administrator. HP sends me to the HP support assistant which still won't let me download anything because it's blocked. I even restarted and signed on as administrator and tried it that way. It doesn't block me but it just says it doesn't work. I have no clue other than I have a virus and I can't find it nor get it out.
      My ComputerSystem Spec

  6.    25 Nov 2017 #6

    Hey friend.

    Looks like everyone is having this exact same problem. It happened to me too.

    The fix is simple, just roll back drivers in device manager for the Display Adapter
      My ComputerSystem Spec

  7.    25 Nov 2017 #7

    Where the block is for rolling back the drivers, it's not backlit. It's only written faintly in the background. Under driver details it says no driver files are required or have been loaded. Should I disable the device? It's ATI Radeon HD 4200.
      My ComputerSystem Spec

  8.    25 Nov 2017 #8

    What I can say for sure is I had this problem at 7:30 this morning and it took me until 3 PM to figure this out. I must have deleted/uninstalled the device 3-4 x throughout the day. So try it.

    I think the other poster is right, you need administrator privileges. At least try uninstalling the display adapter and restarting the system, then look to see if it's no longer greyed out. Good luck.
      My ComputerSystem Spec

  9.    25 Nov 2017 #9

    Right now the adapter is disabled. Restarted and no change. I'm willing to try to uninstalling it but if that doesn't work, can it be reinstalled and if so, how?
      My ComputerSystem Spec

  10.    25 Nov 2017 #10

    Well in my experience Windows will assign a generic name to the device when it boots after the driver is uninstalled or sometimes it just reappears as its same name. You can rest assured it will still be there, hopefully. It will probably automatically reinstall the same driver protocol as before until you mange to roll it back.

    There's a AMD utility as well that cleans all their software off your computer. Forget what it's called but it should be in the AMD or ATI program file if you have one. Use that, delete the drivers, uninstall the device, etc. The main thing is to figure out how to click that roll back button.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
WD going crazy with permissions in AntiVirus, Firewalls and System Security
So it seems that since I booted my laptop this morning, Windows Defender went crazy with permissions, blocking both Firefox and Set Point Device (Mouse) from doing changes to the Desktop folder. I also wasn't able at first to copy files from my...
My wife's display goes blank, gets lines, streaks, etc. when moving the lid up and down and sometimes when you don't even touch it. Anyone know what might be causing this and how to fix it? Thanks! :)
How Do I Fix this Crazy Error? in Drivers and Hardware
I got the following error when I ran a diagnostic. Now I got nothing connected in my PCIe slot, no graphics card, nothing. How can I fix this? Platform Power Management Capabilities: PCI Express Active-State Power Management (ASPM) Disabled PCI...
This is getting crazier every day. All of a sudden when I try to open my CD ROM drive I get this message. Frank (frank-1) is denying access to your PC. Contac the owner of the media server to allow your PC to access it. So its telling me that I...
Crazy Popup in General Support
Hello Everyone, I just installed Windows 10. Now, every few seconds a popup occurs. At the very top it says: C:/Users/XXXXX/AppData/Local/ArcadeTwistcat/VOTrx.exe It interferes with every site I go to by stopping typing, blocking what I am reading...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:19.
Find Us