Windows 10: Artifacts on screen. Screen goes black Solved

Page 3 of 4 FirstFirst 1234 LastLast
  1.    12 Jul 2017 #21

    It's probably dead. Is it still under warranty?
      My ComputersSystem Spec

  2.    12 Jul 2017 #22

    Yeah, i have a 3 year warranty. I sent it out for RMA 2 days ago. If all goes well I'll have one that works in a week or two. Im just hoping the bad card was the reason for my black screen when installing amd display drivers.
      My ComputerSystem Spec

  3.    13 Jul 2017 #23

    Well, there's a place near me that has TONS of pc hardware, so i picked up one of these for $5.
    Click image for larger version. 

Name:	20170713_154243.jpg 
Views:	1 
Size:	717.5 KB 
ID:	143778
    Not a bad deal i think.

    Anyway, i installed it and I'm still getting artefacts on screen..
    Click image for larger version. 

Name:	20170713_155108.jpg 
Views:	1 
Size:	767.1 KB 
ID:	143779
    Is this gpu bad as well or some other issue?
    Tried some drivers unsuccessfully but I'm going to try some others when i get home.
    Just updated bios to 2.40 for ryzen microcode update.
      My ComputerSystem Spec

  4.    13 Jul 2017 #24

    Have you checked cable, are you using any adapters ?
      My ComputersSystem Spec

  5.    13 Jul 2017 #25

    CountMike said: View Post
    Have you checked cable, are you using any adapters ?
    No adapters. With the rx580 i was using hdmi, had same problem with different hdmi cables and monitors.
    With this ati sapphire x1650 im using a dvi-d cable. It was brand new in package, traded a couple old1gb sticks of laptop ram for it.

    Would i be correct to assume it's not a driver issue because artifacts are displaying in bios?

    Im really perplexed by this. Did i just send back a perfectly good strix rx580? Or is this card bad too?
      My ComputerSystem Spec


  6. Posts : 2,344
    Win10 Pro Build 17040
       13 Jul 2017 #26

    - check the mobo connector on the gfx card for dust and dirt - make sure it's properly seated
    - I guess you've done this already..




    - in answer to your earlier post, yes..
    - two of these in crossfire mode
    - runs really well
    Last edited by BugMeister; 13 Jul 2017 at 17:42.
      My ComputersSystem Spec

  7.    17 Jul 2017 #27

    Well, good news. Pulled out my old Dell and put that x1650 in it. Had artifacts on screen.
    Click image for larger version. 

Name:	20170716_222220.jpg 
Views:	1 
Size:	458.2 KB 
ID:	144380

    Traded the x1650 for a different card and its working fine.
    Click image for larger version. 

Name:	20170717_162204.jpg 
Views:	3 
Size:	328.5 KB 
ID:	144382
    Guess the rx580 was just bad.
    Hopefully i don't have to wait more than a week for the new one to get here.
      My ComputerSystem Spec

  8.    17 Jul 2017 #28

    Following the thread, I was starting to suspect the monitor. But it looks like you had lightning strike twice on the GPU, with two bad cards to deal with. My sympathies, and good troubleshooting work!
    --Ed--
      My ComputersSystem Spec

  9.    17 Jul 2017 #29

    Thanks Ed! I did have some bad luck huh?
    Once the new card gets here and is working (hopefully) il mark this thread as solved.
      My ComputerSystem Spec

  10.    03 Sep 2017 #30

    Forgot to update this post. New gpu works great. Thanks everyone.Click image for larger version. 

Name:	20170902_185218.jpg 
Views:	2 
Size:	348.7 KB 
ID:	151791
      My ComputerSystem Spec


 
Page 3 of 4 FirstFirst 1234 LastLast

Related Threads
black screen issue at Locked screen instead of beautiful windows spotlight !! just like in shown picture my Windows 10 Pro is completely Genuine and Verified and windows updates are up-to-date:cool: I had this issue over lots of months...
One of my coworkers recently bought a new Toshiba laptop. He has only had it a few months before one day he turned his comp on and it loaded into starting recovery repair or something along those lines. he tried turning it on and off a few times...
Hey everyone. I did a bit of research and this seems to have been an issue for a while, or has been in the past. Was upgrading to windows 10, I first had to restart my pc cause it was initially stuck on that preparing to install problem with the...
Hi, I have a Lenovo Thinkpad Edge with an Intel I5 processor, 64 bit with no hardware upgrades (stock). I had accidentally stepped on the screen (fell off my lap and then crunch) which was mangled beyond repair, so I have been using it similar to a...
I recently upgraded to Windows 10 from the taskbar on my desktop. The upgrade was successful and I was able to use my computer normally. Today, when I started my computer, a disk check was started. After a long time of being stuck at 10%, I force...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:12.
Find Us