Windows 10: Black Screen After Graphics Driver Update


  1. Posts : 15
    Windows 10 x64
       25 Apr 2017 #1

    (SOLVED) Black Screen After Graphics Driver Update


    Greetings, everyone. I've been experiencing framerate problems with my PC so I decided to downgrade by graphics drivers(Nvidia) to 359.06, while installing my monitor suddenly bluescreened. I'm not talking about a BSOD by the way, my system is hooked up to a TV and my TV bluescreened and my manufacturer's logo is on the screen. At first I thought this was normal as this happened when I installed graphics updates, but it was taking very long to go away, so I restarted my computer. While it was booting my computer would keep changing resolutions from 1024x768, 720x400, 640x480 and the refresh rate was also messed up going from 60Hz to 70Hz. After the BIOS screen loaded, I would see the Windows 10 logo, and then after that, Blue Screen with the tv's logo moving around the screen. I would appreciate your assistance.
    Last edited by Fir; 26 Apr 2017 at 09:27.
      My ComputerSystem Spec

  2.    25 Apr 2017 #2

    Have you tried onboard graphics? Also if you have another PC, try that graphics card on the other one.
      My ComputersSystem Spec

  3.    25 Apr 2017 #3

    Or try a PC monitor if you have one. The computer might be trying to display a format that the TV doesn't support.
      My ComputerSystem Spec


  4. Posts : 15
    Windows 10 x64
    Thread Starter
       26 Apr 2017 #4

    JSheridan said: View Post
    Or try a PC monitor if you have one. The computer might be trying to display a format that the TV doesn't support.
    I have tried that before, all I got was a blackscreen.
      My ComputerSystem Spec


  5. Posts : 15
    Windows 10 x64
    Thread Starter
       26 Apr 2017 #5

    RoasterMen said: View Post
    Have you tried onboard graphics? Also if you have another PC, try that graphics card on the other one.
    I don't know how to do that, also I don't have another PC.
      My ComputerSystem Spec


  6. Posts : 15
    Windows 10 x64
    Thread Starter
       26 Apr 2017 #6

    Okay I have more to say. I turned on my computer and it worked fine. Tonight I tried turning on my computer, I tried to access my BIOS settings and pressed my DEL key too late and I pressed while Windows was loading, for some reason because of this, Windows loaded with 1280x960 instead of 1360x768, I restarted my computer and got a BSOD. It says SYSTEM_SERVICE_EXCEPTION nvlddmkm.sys. I restarted again and I experience the bluescreen with my TV again.
      My ComputerSystem Spec

  7.    26 Apr 2017 #7

    359.06 is a very old driver and I seem to remember caused a few problems around Christmas 2015. Suggest use a more up to date driver.

    Just checked on Nvidia Forums, buggy driver.
      My ComputersSystem Spec


  • Posts : 15
    Windows 10 x64
    Thread Starter
       26 Apr 2017 #8

    Thanks for everyone who helped, but I finally fixed it. I couldn't get same mode to work by pressing F8 so I rebooted my PC 3 times and got to troubleshooting mode, I enabled safe mode through there, and my computer finally booted atleast properly. I still have 381.06 so I reinstalled it, restarted my PC and it worked while getting a 50-60+ fps boost in my game. Finally I fixed it.
      My ComputerSystem Spec


  •  

    Related Threads
    Medion Akoya i3 laptop with Intel hd 300hd graphics. Four installs later after encountering a black screen from 30% install, I found that windows 10 is fully installing but display only outputting to hdmi port. I have no bios setting to change this ...
    Not sure where to put this, as I haven't gotten help in other forum parts, so I am putting it wherever I think it might work. Please help me, kudos to you if you at least try. Computer model: Lenovo Y700 Microsoft 10 6th gen i7 processor It has...
    Have been waiting for NVIDIA to fix their driver since windows 10 release. I tried the latest driver from windows update and they still crash to black screen on my Asus GT610, rolling back to the windows 8 driver and everything is fine. Anyone...
    Hey ya'll! I just updated from Windows 7 to Windows 10. Here's my specs: Alienware M15x - R1 Notebook Nvidia GeForce 8600M GT Intel Core2 Duo CPU T8100 @ 2.10GHz (if you need more specs let me know) So, I had problems going from Vista to...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 10:32.
    Find Us