Page 3 of 4 FirstFirst 1234 LastLast

  1. Joined : Aug 2016
    Posts : 14
    Windows 10
       16 Aug 2016 #21

    Nope, just a normal wired mouse.
      My System SpecsSystem Spec


  2. Joined : Jun 2016
    Posts : 1,386
    Win10 1607
       16 Aug 2016 #22

    EZES said: View Post
    Nope, just a normal wired mouse.
    I should of said above , it sounds a bit like your USB is acting up , if it's the same on all ports then I'd assume a driver issue , rather than a worn/faulty port .
      My System SpecsSystem Spec


  3. Joined : Aug 2016
    Posts : 14
    Windows 10
       16 Aug 2016 #23

    There are no drivers for the said mouse. I bought a cheap Marvo mouse to check if it was the mouse or the something else. I previously had a Hama uRage mouse that worked fine for 2 years until two weeks ago when it started. Then I plugged in an old, beaten up SteelSeries Kinzu I had years and years ago and it worked just fine.. I don't know. I believe I will buy a SteelSeries Rival 100 and see if the problem persists.
      My System SpecsSystem Spec


  4. Joined : Jul 2016
    Posts : 24
    Win 10 Pro x64
       16 Aug 2016 #24

    For the mouse, you can see if power management for the USB ports is enabled to let the system shut them off to save power. In Device Manager "Universal Serial Bus Controllers".
      My System SpecsSystem Spec


  5. Joined : Jun 2016
    Posts : 1,386
    Win10 1607
       16 Aug 2016 #25

    zekeblue said: View Post
    For the mouse, you can see if power management for the USB ports is enabled to let the system shut them off to save power. In Device Manager "Universal Serial Bus Controllers".
    there is also an option in the Advanced Settings for your Power Scheme called USB Selective Suspend which you could turn off too.


    Stick with the Kinzu a while then and see if the issue comes back.

    KB
    Last edited by Kbird; 17 Aug 2016 at 09:48.
      My System SpecsSystem Spec


  6. Joined : Aug 2016
    Posts : 14
    Windows 10
       17 Aug 2016 #26

    @zekeblue - I've tried that back on Windows 7 too and the problem still persisted. @Kbird - I will try and stick with the Kinzu a couple of days but it will be very frustrating lol.
      My System SpecsSystem Spec


  7. Joined : Sep 2015
    Hellsinki
    Posts : 375
    Windows 10 Home
       17 Aug 2016 #27

    If you are by any chance using the USB3.0 port for your mouse, I would recommend that you update the driver at:

    Gigabyte Support

    PS. I noticed that there are different revisions of your Motherboard, you need to check which one you have before you download drivers!
      My System SpecsSystem Spec


  8. Joined : Aug 2016
    Posts : 14
    Windows 10
       17 Aug 2016 #28

    And how do I do that? Anyways, 2 hours with the SS Mouse and no interruptions. It would've happened by now if it was malfunctioning like the previous one. Any verdicts? I am thinking of ordering the Rival 100 today and, well, see what's up.
      My System SpecsSystem Spec


  9. Joined : Jun 2016
    Posts : 1,386
    Win10 1607
       17 Aug 2016 #29

    The Revision of the MB 1.0 or 2.0 , should be printed on the Motherboard itself , sometimes it is on a sticker though. Not sure if the Manual will say anything if you have it ?

    However the VIA USB3 Driver appears to be the same for either revision on win7 or win10 ... Ver. 4.90A

    I would try and use a USB2 port for the Mouse and Keyboard though , check the Manual to see which is which, you can download it too if needed .
      My System SpecsSystem Spec


  10. Joined : Aug 2016
    Posts : 14
    Windows 10
       17 Aug 2016 #30

    I know which is which but it does not matter anyway. Whether I use USB 2.0 or 3.0 the mouse still doesn't work correctly but the keyboard and headset do.
      My System SpecsSystem Spec


 
Page 3 of 4 FirstFirst 1234 LastLast


Similar Threads
Thread Forum
Solved No 1920x1080 resolution while using Windows 10
As the title said, I can't find my native resolution, 1920x1080 on Windows 10. I don't know how to fix this and I'm waiting for answers. Thanks.
Graphic Cards
Basic card with 1920x1080 resolution for Dell Dimension 3100
My wife is uses this PC daily and I have upgraded it to Windows 10 Pro (32-bit). This is a great improvement over 8.1 Pro and now provides full functionality, including the 'Sleep' option that was missing in 8.1. We recently decided to purchase...
Graphic Cards
Solved Can not get 1920x1080 resolution back since upgrade to Windows 10
Since upgrade to windows 10 yesterday my screen resolution is wrong. 1920x1080 is now not available. Graphics card is ATI Radeon X1600 (Pc is quite old) Have looked on AMD website and cannot find driver. Have tried windows update, but all up to...
Graphic Cards
No 1920x1080 resolution while using Windows 10 - cannot update drvrs
Hi, I just recently upgraded to Windows 10 on my Dell XPS laptop but I seem to be stuck with 1024x768 screen resolution with no way to change it. From the research I've done it seems to be a driver issue but I have been unable to locate a working...
Drivers and Hardware
Native resolution is getting black boxed. 1920x1080
On Windows 7 my computer was fine with this resolution. The second I upgraded, my resolution pretty much just broke by putting a black box around my screen. I've tried updating my drivers and other stuff yet I require assistance still.
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:31.
Find Us
Twitter Facebook Google+



Windows 10 Forums