Windows 10: Amd Crimson Driver doesnt work on Windows 10 Solved

  1.    10 Jul 2016 #1

    Amd Crimson Driver doesnt work on Windows 10


    Status: Unresolved
    Computer Type: Desktop PC
    GPU: Sapphire HD 7970 Dual-x 3gb GDDR5 (factory OC, using single GPU)
    CPU: Intel Ivy bridge i5 3570k
    Motherboard: GIGABYTE GA-Z77X-UD5H LGA1155
    RAM: Kingston Predator 8GB
    PSU: Corsair TX650M 650w 80Plus Bronze
    OS: Windows 10 Pro 64 bits
    GPU Drivers: Radeon crimson 16.6.2 Hotfix (installed only INF files through device manager)
    Chipset Drivers: z77 chipset , version 10.1.1.8
    Background Applications before Black Screen: http://imgur.com/T1Qz5wi

    Description of Problem:
    After installing Windows 10 Pro on a new Seagate drive, everything was ok for a while, I was downloading drivers and moving around the desktop, but then all of a sudden i got the black screen of death , i did a reboot and i was unable to get past the loading screen of the windows logo, the circle thing got stuck. I rebooted till i finally made it into safe mode, there I disabled the intel HD driver on device manager and i was able to log into the desktop in the next normal boot, but then another crash, i tried to install the Crimson drivers and right after i clicked the setup the screen freezes and i cant do anything, i can move the mouse but nothing responds so I'm forced to reboot, i tried installing the AMD drivers on safe mode and it said there was an error finding the device controller.

    Troubleshooting:
    The last thing i tried was to manually install the Crimson drivers on the device manager, by clicking on the default display driver, then update driver and manually choosing the path to the extracted AMD folder, it installed correctly, switched the resolution to 1080 automatically( monitors native res) but nothing else changed, catalyst center didn't install so i tried opening the setup again to find the same issue reported above, system freeze and reboot, then i have to do the same annoying procedure, going into safe mode, disabling intel HD graphics on device manager , i don't know why it keeps activating on its own ( how can i stop that?), and then rebooting into windows again. I even used DDU again to see if i can install the driver afterwards, but same result, should i switch to an specific older version of crimson, or catalyst? I'm out of ideas and i have no clue what is causing all this, Ive also seen many people on the forum having problems with the new drivers. Id appreciate your help guys
    looking forward to your reply
      My ComputerSystem Spec

  2.    11 Jul 2016 #2

    Can you disable intel HD graphics in BIOS, shouldn't pop up anywhere than ?
      My ComputerSystem Spec

  3.    12 Jul 2016 #3

    It worked ! i forgot about the bios settings, i read the manual and found the option to set PCI priority first over intel, and then disabled the intel graphics driver, reboot and voila, i could install the amd driver without hindrance, thanks a lot ! i wonder why this didnt happen on Windows 7, i guess motherboard can get confused sometimes.
      My ComputerSystem Spec

  4.    13 Jul 2016 #4

    foxslink said: View Post
    It worked ! i forgot about the bios settings, i read the manual and found the option to set PCI priority first over intel, and then disabled the intel graphics driver, reboot and voila, i could install the amd driver without hindrance, thanks a lot ! i wonder why this didnt happen on Windows 7, i guess motherboard can get confused sometimes.
    Could be many causes but drivers can change some aspects in BIOS.
      My ComputerSystem Spec

  5.    23 Jul 2016 #5

    foxslink said: View Post
    It worked ! i forgot about the bios settings, i read the manual and found the option to set PCI priority first over intel, and then disabled the intel graphics driver...
    @foxslink could you be so kind and tell me after the bios switch PCI priority, where did you disabled the intel graphics in device manager or also in bios? Thanks
      My ComputerSystem Spec

  6.    25 Jul 2016 #6

    Sara said: View Post
    @foxslink could you be so kind and tell me after the bios switch PCI priority, where did you disabled the intel graphics in device manager or also in bios? Thanks
    No problemo, in my mobo's Bios i went into the Peripherals tab, down in the graphics options youll find the intel graphics button, you can disable by pressing enter and selecting Disable. On device manager youll find it in display adapters section, there are usually 2 devices there, one of them is intel's, you have to disable it here too, not uninstall, or it it will install again when you reboot
      My ComputerSystem Spec


 

Related Threads
I just updated to Windows 10 which has installed Radeon Crimson driver v15.11. However, the Radeon Settings Utility finds WHQL driver 16.3.2. There is also the non-WHQL Crimson v6.6.1 Hotfix driver on AMD's web site which I had problems with in...
There is a feature missing with screen configuration under Windows 10 and new Amd drivers Crimson, even the last WHQL ones (15.12). The Amd setting do not have the screen configuration, no more. The driver choose ( I guess) the screen number 1 by...
Hi guys, i recently bought a windows 10 tablet from Onda that came with full licenced windows 10 (didnt upgrade from anything) and i reset it as soon as id finished fiddling about with it and testing it so i could set it up fresh. it worked...
is the issue fixed in Windows 10 that has to do with Sound customization for windows such as changing the start sound and exit sounds etc. I could never get it work with Win 7 pro. either with Soundpackager from Win customize nore a straight wav...
i upgraded 2 computers to windows 10 and java doesnt work on both
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:16.
Find Us