Hello guys,

Recently my laptop (Asus X550L, Windows 10) was getting an annoying error on my Intel graphics. It will hang up a bit then display a prompt that my "graphic stopped working and was recovered." It happens when I'm playing some videos on Youtube or playing games. I also notice that the applications I setup to run on my GT840m won't run on it, instead, it will use the onboard graphics.

Below are the things I tried:
1. Update my intel driver using windows update. After download and installation, on the end, it says, "illegal operation attempted on a registry key marked for deletion". Also tried downloading driver on their website but it also fails to install.
2. Removed the driver then tried to re-install it using windows update and downloaded driver. Same happens above. But now the working graphics is my discrete (GT 840M).
3. I also tried to update/re-install the driver on Safe Mode, same result.
4. Tried to look some answers regarding the error on no. 1 in connection with driver installations but I did not find anything on the internet.

Here are my basic laptop specs:
Intel i7-4500u
Intel Graphics Display 4400
Nvidia GeForce 840M
8Gb Ram

I'm out of ideas so I'm hoping that anyone can help me here. Thanks!