Page 1 of 2 12 LastLast
  1.    17 Oct 2015 #1
    Join Date : Aug 2015
    Posts : 51
    Windows 10

    Cannot delete download once drivers are installed


    I don't know if this is the right place to ask this question so if it isn't, please let me know.
    I've downloaded drivers for my NVIDIA graphics card and have installed them, however I cannot delete the original EXE from my download folder, I get a popup telling me that the action cannot be completed because the file is open in Windows Explorer,duh. The preview pane is disabled so I know it's not that. I've never had any problems like this when running 7 so whats with 10 and how do I delete it. No reason to keep it if the drivers are already installed. Thanks in advanc for any help.
      My ComputerSystem Spec
  2.    17 Oct 2015 #2
    Join Date : Aug 2015
    Posts : 90
    Windows 10 64

    That's not good. If the zip file you installed from is still being opened by an application then it could either be your compressed file opener? (WinZip?) or it's become corrupted somehow. I wouldn't really trust a graphics install that left me with that mess.

    Get into task manager and see what file is open and see if you can find out why? You can close the file, you can then close the zip. if you can close the offending process. You may have to look through your start-up programs for clues to find out what's opening it on start up..

    You should restart your graphics install from scratch. You may have a problem waiting in the wings.

    You need a graphics driver Uninstaller to remove all your old files completely for a sure clean up. The one of choice for Nvidia is the DDU - Display Driver Uninstaller.. (Google for the latest version..) and use it according to it's instructions and get a fresh set of graphics drivers downloaded from a different site and try again.

    Good luck.
      My ComputerSystem Spec
  3.    17 Oct 2015 #3
    Join Date : Oct 2015
    Posts : 2
    windows 10

    "REVO Uninstaller" might help.
      My ComputerSystem Spec
  4.    18 Oct 2015 #4
    Join Date : Aug 2015
    Posts : 51
    Windows 10
    Thread Starter

    SoxmisUK
    , the file which cannot be deleted is an exe file which installs the video card drivers and was downloaded directly from the NVIDIA website. I've downloaded many of these files, while in Win 7, and never had any problems deleting it once the drivers were installed. Since I've upgraded to Win 10 now I'm getting this problem. I use REVO UNINSTALLER when deleting programs cause it does such a good job of rooting out all the extraneous stuff which is usually left behind by the program uninstaller. Normally you shouldn't have to use REVO when updating video drivers as they are normally overwritten by the new install. I've checked where the program files are being used by using REVO and AUTORUNS (Microsoft put this out years ago) and all are being used from Program Files (X86) and also checked Task Manager and none are being run from the Dowloads folder. Seems to me that Win 10 is treating this file as if it were part of the operating system, or parts thereof. In Win 7 I would normally go into safe mode and delete the file but after seeing how to get into safe mode in Win 10 I'm not so sure if that's a good idea. I haven't tried it yet and I don't know if safe mode in Win 10 allows you to view files and folders. I've downloaded other exe's and deleted them, this makes no sense.
      My ComputerSystem Spec
  5.    18 Oct 2015 #5
    Join Date : Aug 2015
    Posts : 90
    Windows 10 64

    I think you should try safe mode. Try to delete the exe from there.
      My ComputerSystem Spec
  6.    21 Oct 2015 #6
    Join Date : Aug 2015
    Posts : 51
    Windows 10
    Thread Starter

    I tried Safe mode to delete the EXE, unfortunately I got the same results, can't delete the file. I used Revo to uninstall the drivers but once the drivers are installed I end up with the same problem. What gives with Win 10? This is really stupid. I think Microsoft should investigate this problem, or am I the only one who is having this problem?
      My ComputerSystem Spec
  7.    22 Oct 2015 #7
    Join Date : Aug 2015
    Melbourne
    Posts : 223
    Win 10 Pro X64

    Try to use something like Hiren boot CD using the XP mini or other programs built in and once it's loaded delete the file or create a live Linux CD/DVD/USB to do the same
      My ComputerSystem Spec
  8.    22 Oct 2015 #8
    Join Date : Aug 2015
    Posts : 90
    Windows 10 64

    Bring up your System Configuration and choose the Services tab. Tick hide all Microsoft Services. and then untick everything that is left, reboot see if you can delete the file.

    Edit: If it doesn't work put it back the way it was.
      My ComputerSystem Spec
  9.    22 Oct 2015 #9
    Join Date : Jul 2015
    Posts : 858
    Windows 10 Home x64

    If it's drive C try doing a chkdsk c: /f and try deleting it afterwards.
      My ComputerSystem Spec
  10.    22 Oct 2015 #10
    Join Date : Aug 2015
    Posts : 90
    Windows 10 64

    Is there anything related to this error in the events viewer?
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Windows 10 Clean Install / Delete one-touch recovery system / Drivers
I have a PB (Asus) EasyNote ENTF71BM with Celeron quad core N2930 processor, Intel HD Graphics, 4GB DDR3 L memory. I am British but living in Poland with very limited command of Polish language. I bought the PB in Poland with W8 pre-installed in...
Installation and Upgrade
WIN10 Installing : Select the drivers to be installed
Hello Guyz! I have this problem when i want to install win10 from by bootable usb :( It says Select the driver to be installed. Anyone know how to fix?
Installation and Upgrade
Solved Windows 10 download - can I delete and re-download?
This should be an easy question. To avoid potential conflicts, I need to upgrade a few hardware items before the Windows 10 install due to driver issues, including my graphics card. Not a problem, was looking for an excuse anyway, and may even...
General Support
Low FPS and slow loading times. Proper drivers installed.
Hey guys I just went through hell to install windows 10, I finally have it installed, but it is very slow when it comes to fps, from league where I get as low as 8 fps, to borderlands where I get 30-40, it has lowered drastically from what it once...
Performance & Maintenance
Solved BSOD when Graphics Drivers installed
My computer was frequently BSODing under Windows 7. I thought that my Windows install was bad, so I bought a new SSD hard drive and installed a fresh copy of Windows 10 on it. Everything worked well until my video driver auto installed itself...
BSOD Crashes and Debugging
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:16.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums