Page 1 of 2 12 LastLast

  1. Joined : Jul 2015
    Posts : 20
    windows 10
       24 Aug 2015 #1

    Windows 10 and Nvidia Optimus issue


    after upgrade to windows 10, did anyone notice that nvidia optimus is not working properly as it keep switching between discrete and integrated graphic even for some simple thing like open action center. this has cause graphic shuttering and lag for windows GUI.

    i can assured that this is not happen with windows 8. and the issue is still persists even after a clean install of windows 10 following by intel and nvidia gpu driver. perhaps it is some driver issue?

    GPU: GTX 780M
    IGPU: HD 4600

    look like other also experience this

    https://www.tenforums.com/redirect-to...0-and-optimus/

    Dell Precision m3800 stuttering and lag

    http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_devices/nvidia-optimus-not-working-properly/a059390d-dfc1-44aa-9a47-d2172d70933e


    -----------------------------------------------------------------------------------------------------------------------------
    nvidia have fixed the issue with 365.10 driver.
    Last edited by janice1234; 13 May 2016 at 15:46.
      My System SpecsSystem Spec


  2. Joined : Jun 2014
    United States
    Posts : 132
    Windows 8.1 Pro 64-bit
       24 Aug 2015 #2

    Wow! One more reason I'm glad I held off upgrading. My laptop uses Optimus and I love it, sure don't want it buggered up. Thanks for posting!
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 1
    Windows 10 64-bit
       24 Aug 2015 #3

    Tell me about Optimus... I also have issues with that magnificent piece of junk. After upgrading to Windows 10, all games using DirectX version 8 and lower refuse to work on my GT755M. No matter what I do in Nvidia Control Panel or Nvidia Inspector, they always run on Intel GPU. The only solution is to use wrappers like dgVoodoo 2, WineD3D or nGlide. I've reported my issue to Nvidia and here's the answer I've got: http://nvidia.custhelp.com/app/answers/detail/a_id/3733
      My System SpecsSystem Spec


  4. Joined : Jun 2014
    United States
    Posts : 132
    Windows 8.1 Pro 64-bit
       25 Aug 2015 #4

    Optimus.....junk? Works fine for me on 8.1. Your complaint should be with ALL three players, Nvidia, Intel and MS.
      My System SpecsSystem Spec


  5. Joined : Sep 2014
    Posts : 92
    64-bit 10240 10 Pro
       25 Aug 2015 #5

    I use a GTX 750Ti with The latest Nvidia driver and have zero problems.
      My System SpecsSystem Spec


  6. Joined : Jul 2015
    Posts : 20
    windows 10
       25 Aug 2015 #6

    Gary said: View Post
    I use a GTX 750Ti with The latest Nvidia driver and have zero problems.
    GTX 750TI is a desktop GPU, this issue only affect nvidia optimus (nvidia mobile series gpu).
      My System SpecsSystem Spec


  7. Joined : Jun 2014
    United States
    Posts : 132
    Windows 8.1 Pro 64-bit
       25 Aug 2015 #7

    janice1234 said: View Post
    GTX 750TI is a desktop GPU, this issue only affect nvidia optimus (nvidia mobile series gpu).
    Um, yea.
      My System SpecsSystem Spec


  8. Joined : Jul 2015
    Posts : 20
    windows 10
       26 Aug 2015 #8

    https://forums.geforce.com/default/t...50966/#4650966

    from geforce community, an user did experience this and solved it by using older windows 8 driver.
    Hello,

    I can confirm this issue is happening on Windows 10 with me as well.

    GPU : GT 650M
    iGPU : HD 3000

    I have also tried a clean install to no avail. I did notice that the stuttering problem doesn't happen when the nvidia driver isn't installed, so it's confirmed that this is a driver problem.

    Apparently the gpu switching occurs on some calls made to shcore.dll, but not all of them.

    Any ideas how to work around this issue? The micro stuttering can be quite maddening at times.
    So, I reverted to Driver version 347.88 and most of these issues got fixed.

    The latest driver that works without issue for me is 350.12 for Windows 8.1.
    Yes - Using windows 8.1 drivers on windows 10 is more stable than the official drivers for Win10. Go figure.

    I tested newer versions of windows 8.1 drivers, but none of them work and the windows 10 drivers are just broken on Nvidia Optimus

    For now, there is no benefit of having a directx 12 driver, so I'd recommend sticking with the aforementioned version in order to have a slick Windows 10 experience.
      My System SpecsSystem Spec


  9. Joined : Jun 2014
    United States
    Posts : 132
    Windows 8.1 Pro 64-bit
       26 Aug 2015 #9

    Great info janice1234 especially if I ever decide to upgrade. Thanks again!
      My System SpecsSystem Spec


  10. Joined : Jul 2015
    Posts : 20
    windows 10
       27 Aug 2015 #10

    some update about this issue,

    after tested the suggestion posted by geforce community, i can confirm that the current workaround for this issue will be using older ver of driver 350.12 with windows 10. but keep in mind that the older driver did not support directx 12.
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved Update issue.. UEFI firmware issue
14703 Any suggestions??
Installation and Setup
nVidia - Graphics Adapter WDDM2.0 - NVIDIA GeForce GT 740M
what is this update and it fails to install.
Windows Updates and Activation
Solved Nvidia geforce experience & nvidia control panel not working.
So I just updated to windows 10. and first thing i go to do is turn up my saturation, nvidia control panel doesnt work, i go to my device manager looks like my graphics card isnt even installed, i install it and restart pc, nvidia control panel...
Graphic Cards
Nvidia Beta Drivers now out for Windows 10
Nvidia have today released a beta driver for Windows 10. You can download it from here: http://www.nvidia.co.uk/Download/Find.aspx?lang=en-uk If anyone has a link to the changelog, I'll add it here.
Drivers and Hardware
Star Wars: The Old Republic is not working with NVIDIA Optimus
I don't know if this is only for Windows 10, but I'll post it here, maybe someone knows a workaround. I installed Star Wars The Old Republic (the new MMORPG) and when I start it with my NVIDIA GeFore 610M card, it refuses to launch, no error...
Gaming
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:18.
Find Us
Twitter Facebook Google+



Windows 10 Forums