GPU failing to detect monitors


  1. Posts : 2
    Windows 10
       #1

    GPU failing to detect monitors


    Hello everyone,

    Windows 10 build
    Thermal take 850w PSU
    Ryzen 9 3600X*
    64gb ddr4 3600k ram *
    AsRock B550 Mobo
    Radeon RX 580 XFX
    2Tb ssd
    1Tb ssd with C: drive and OS
    16 TB HDD
    |

    My problem is simple enough but I don't know how to go about fixing it. This is a new system. Everything was working fine. I got windows installed. Yada yada. Well it wasn't detecting the other PC in my network as needed so I had to enable smb, change network sharing settings, and do the process as outlined in this article: ETA**

    So I did that and restarted it then shut it down. I did that because I needed to add the 2 TB ssd to it which had came in the mail a couple days after my build was complete. Easy enough right?

    Due to performance differences I had noticed with my intended application , I decided to move the 1Tb SSD which has the OS on it to the other M.2 slot on the Mobo (mine has two slots)

    On seemed to be working faster than the other for whatever reason with the specific hardware. I wanted this slot to be where the new 2 TB ssd was seated for that extra performance. So I moved the c drive to the other slot. That's all I did!!


    Now upon turning on my system. It fires up fine and boots as far as I can tell. But that's the problem. I can't tell. After making this change it will not detect my monitors.

    The GPU has one HDMI slot, three DP slots, and one funky ass DVI D slot that seems to be hard to find a cable for?

    Anyways. I had been using it with the hdmi port previously and it was displaying fine onto the single monitor necessary. Well that wasn't working so I went out and bought a DP cable as well as a DP to HDMI cable.

    I have tried every which combination to and from my system's GPU ports (no onboard video with amd ryzen cpu) to the monitor and it just fails to detect. It notes the connection. Because the message it displays is different while turned on. But it says "no signal" vs "no cable connected" when it's turned off.

    So anyways yeah, that is my problem. I have tried getting into the BIOS or various mobo settings with function keys during start up but that is not making any difference.

    I have yet to purchase a DVI D cable (because I can't seem to find one not online) but that's the last thing I can think of trying at this point.

    I should not I have also tried booting from a windows iso installation from a removable usb. This seems to boot the system up in a different manner from what I can tell in that it no longer shuts immediately off with a power button push and instead you have to cold restart it with a long push. This is when I am trying to get into recovery / repair by booting from the usb or anything that may have some effect.

    I am at a loss what else to try. Because of the particular issue I was facing also, I don't have the system configured to accept a remote connection yet (it wasn't detecting my other machine.. ) so I don't know how to get into this to fix this silly issue.


    Any help or pointers would be greatly appreciated. I am mobile right now but once I am back home I will edit this post or add another reply with a better breakdown on my specific hardware or OS build if appropriate I just don't have that info on memory or on hand at the time.

    Thank you kindly for your assistance!
    Last edited by Lightedhype; 22 Apr 2021 at 16:48. Reason: Eta
      My Computer


  2. Posts : 2,768
    Windows 11 Pro, 21H2
       #2

    Welcome to TenForums!

    You noted that you tried to get into the BIOS but you never noted whether you can successfully do that. If you cannot even see the BIOS screens then the issue has nothing to do with Windows because that occurs at a level before Windows even starts to load.

    Things that you can try:

    1) You know what you did just before the problem started. Try reversing that to see if that change is really what caused the problem.

    2) Perform a Clear CMOS operation (see the user guide for your MB). Upon subsequent reboot, enter the BIOS, start by setting default settings. Then, make sure that that the PCIe graphics adapter is set to initialize first (There is typically an option to init the PCIe graphics first, or CPU graphics first).

    If that doesn't help, let us know and we'll make other suggestions.
      My Computers


  3. Posts : 1,144
    win10 home
       #3

    When you boot from the usb,did you change the boot menu to show the usb as first selection?
    Suggest you completely shutdown,power "off" at the wall socket.
    Disconnect all peripherals,except for mouse,keyboard and only one monitor.
    Return the original ssd to the original slot and remove the other drives.
    Restart and see if it works.
    From your paragraph 11,the indications are that the bios works and Win 10 loads,could you confirm this please.
      My Computer


  4. Posts : 2
    Windows 10
    Thread Starter
       #4

    Thanks for your help. It turns out clearing the CMOS fixed the issue right up and I have actually replicated the issue and fix since then once more while running some trials.
      My Computer


  5. Posts : 2,768
    Windows 11 Pro, 21H2
       #5

    That's great to hear! Thanks for sharing the results.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:41.
Find Us




Windows 10 Forums