Sparkle GTX660 Ti problem


  1. Posts : 3
    Win 10
       #1

    Sparkle GTX660 Ti problem


    Hi guys
    I've recently bought 2nd hand card.

    After instalation this thing happen:

    Sparkle Gtx660 Ti issue - YouTube

    Any idea what could cause that?

    Inside that case there is:
    -I5 3570 no O/C
    -2x4GB Ram
    -Corsair CV550
    -some noname MOBO ZX61C/B75
    -500GB HDD
    -Win10 PRO

    I cannot get into BIOS after card instalation, no POST, keyboard doesn't respond, no nothing, only that weird resetting all the time. I've keep it that way for about 5mins but nothing changed. After that I've disconnected it and PC works fine.

    Motherboard doesn't allow me to turn off onboard graphics - there is only AUTO option.
    PSU is more then enough to power up and keep it working.

    Thanks for help
      My Computer

  2. bobkn's Avatar
    Posts : 3,601
    Win 10 X64 Pro 20H2 19042.685
       #2

    All that I can suggest is clearing the CMOS.

    A utility like CPU-Z will identify the motherboard, so you can downlaod a manual for it.

    I hope the card is OK.
      My Computers


  3. Posts : 111
    Windows 10
       #3

    Do you have access to another PC to try the card in? Your motherboard BIOS has to be detecting the card because your video shows the monitor getting a signal briefly. I suspect the graphics card is faulty.
      My Computers


  4. Posts : 3
    Win 10
    Thread Starter
       #4

    Bobkn - I will reset CMOS later on and see what gonna happen, right now I'm at work.
    I've tried CPU-Z when I was looking for new BIOS and it shows only Intel B75.

    exploder - Unfortunetly no access till Mon/Tue.

    I've forgot to mention in my 1 post when I tried to sort it out by myself, I've keeped card in PCIe slot whithout additional power, connected to monitor messege show up - "this graphic card need extra power supply, connect PCIe power". No disco like in a clip, keyboard respond but obviosly didn't pass to BIOS. Then I've tried with both cables - "disco", with 1 cable same story.

    - - - Updated - - -

    UPDATE
    Clearing CMOS helped a bit, no disco but still no display ☹. Can't see even BIOS to setup anything. I've bought even DVI cable just to rule out HDMI fault.

    In terms of finding new BIOS
    Sparkle GTX660 Ti problem-20210403_100332.jpg

    Sparkle GTX660 Ti problem-20210403_110115.jpg
      My Computer

  5. bobkn's Avatar
    Posts : 3,601
    Win 10 X64 Pro 20H2 19042.685
       #5

    Odd. I've not dealt with a mystery motherboard like that before. (My own desktop PCs have been assembled by me since 1997. For good or for ill.)

    If you can't find an ID label or something silkscreened onto the motherboard, you may be out of luck as regards BIOS updates.

    I take it that you have no access to another PC to test the graphics card?

    By the way, there are more convenient ways to capture the screen rather than taking a smartphone picture. Lately, I've been using shift-Windows key -s. That allows you to draw a box around whatever you wish to capture, and saves it to the clipboard. Works well.
      My Computers

  6. stormy13's Avatar
    Posts : 322
    Windows 10 Pro
       #6

    bobkn said:
    By the way, there are more convenient ways to capture the screen rather than taking a smartphone picture. Lately, I've been using shift-Windows key -s. That allows you to draw a box around whatever you wish to capture, and saves it to the clipboard. Works well.

    Alt+PrntScrn (print screen depending on what short form your keyboard has) to take a shot of the current window (or just PrntScrn for everything), open Paint and Ctrl+V.
    Or open Snip and Sketch to do as you mentioned.
      My Computer


  7. Posts : 3
    Win 10
    Thread Starter
       #7

    Bobkn - that's also a new thing to me that MB is so noname. I've bought that c$#p on Amazon. It was needed for a quick build, for my daughter for school as her laptop died.

    In 1997 there was a very few MB producents so it wasn't so difficult to find whatever you need for your PC. I was around that time in that stuff, but stopped in 2009 - family, work, etc.

    Access to other computer - as I wrote earlier, no till Mon/Tue - still working now

    When it comes to screen shot quality - that's completly on me. Just don't have enough time at home - I'm away home 14h a day and only way to try to solve it with forum support is by my mobile.

    - - - Updated - - -

    Today problem was solved. How? Don't ask me.

    Went to my mate with my PC.
    Connect it to his monitor - didn't work.
    His GPU (GTX560 Ti) in my PC - no display
    Connected my GPU to his PC - worked fine
    My GPU in my PC - works fine.
    So real answer for that is a big unknown.
    Thanks for helping anyway
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:57.
Find Us




Windows 10 Forums