1. Joined : Aug 2015
    Posts : 3
    Windows 10 home premium 64bit
       17 Aug 2015 #1

    Catalyst Control Center refuses to install AMD Mobility HD 4200


    Just as the title says, I'm able to install the drivers but not CCC which I kinda need. I use overscaling for my tv that it's plugged into via hdmi.I've tried using DDU for fresh install with the 2 most recent drivers for it in compatibility mode for Windows 7&8 and with admin from the drivers download directory. Does anyone have any idea how to fix this?
      My System SpecsSystem Spec


  2. Joined : Aug 2015
    Posts : 119
    Windows 7 (reverted back)
       17 Aug 2015 #2

    Don't use Express Install, to Advanced Setup then uncheck everything but the Display Driver and Catalyst Control Center. I think the Install Manager and Runtime are greyed out. That's it, just click install... I haven't crashed yet, although I haven't really installed or tried any games yet either.
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 3
    Windows 10 home premium 64bit
       17 Aug 2015 #3

    The drivers I have don't show CCC in the installer just catalyst install manager is there another driver I'm missing somewhere? Do legacy drivers bit come with CCC?
    Last edited by Sloppy; 17 Aug 2015 at 15:29.
      My System SpecsSystem Spec


  4. Joined : Aug 2015
    Posts : 3
    Windows 10 home premium 64bit
       17 Aug 2015 #4

    Ok so for anyone who has the same issue, I ended up having to uninstall the device under device manager and then using Windows 10 check for update to reinstall the device then I restarted the computer. After doing that I was able to install catalyst control center but not the drivers so from there I force installed them through device manager>display adapter>ati mobility> update driver>picked my own from the amd extraction(mine was under C:\AMD\Support\13-1-legacy_vista_win7_win8_64_dd_ccc\Packages\Drivers\Display\W86A_INF) and it gave me a error after installing and told me I needed to restart. When I restarted it was working just fine.
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Solved ATI Radeon HD 4200 driver for 64-bit Windows 10?
It has come to my attention that there isn't a driver for the ATI Radeon HD 4200 for 64-bit Windows 10. This is troubling for me because I just don't have the money for a new card and I sorta really need that driver. If you guys can help me, with...
Graphic Cards
How to Install AMD Mobility Radeon HD 4200 drivers on W7 to Upgrade?
So, I don't have W10 yet and I can't upgrade to it because I just diagnosed the problem. Unfortunately there is no OFFICIAL compatibility for the AMD Mobility Radeon HD 4200 series (which sucks). However, there are workarounds which I found esp here...
Graphic Cards
Catalyst Control Center gone
It was showing up fine in the past, but yesterday I installed the UX theme program, and after that, I noticed that right clicking on my desktop no longer gave me the option to open the Catalyst Control Center, nor does clicking on the little icon in...
Graphic Cards
Windows System Control Center (WSCC)
KLS SOFT - WSCC - Windows System Control Center I just saw the post on CCleaner, a great utility, and thought you might be interested in another utility, or set of utilities. WSCC is a frontend for Sysinternals, Nirsoft, and Windows utilities....
Software and Apps
AMD Drivers for Catylast Control Center
I have a ATI Saphire 5770 graphics card I need to configure thru the Catalyst Control Center to use Eyeinfinty for 3 24in monitors so I can race online (Iracing.com). Just downloaded and am running the latest TP 10041 ANyone tried the Catalyst...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:06.
Find Us
Twitter Facebook Google+



Windows 10 Forums