Windows 10: No Audio via HDMI after monitor wakes from sleep - AMD Radeon HD 7800

Page 3 of 5 FirstFirst 12345 LastLast
  1.    01 Nov 2015 #21

    Ben said: View Post
    Wow, I think they fixed it in a recent Windows 10 or AMD update. It's been a few days I haven't got this issue.
    Not fixed for me, all updates done.

    Thankfully MrQ's little program makes it easier and bearable to live with.
      My System SpecsSystem Spec

  2.    03 Nov 2015 #22

    Ben said: View Post
    Wow, I think they fixed it in a recent Windows 10 or AMD update. It's been a few days I haven't got this issue.
    Not fixed for me either; I tried the latest BETA driver and checked manually for updates but this didn't help to sort out the problem.
    upcoast said: View Post
    Not fixed for me, all updates done.

    Thankfully MrQ's little program makes it easier and bearable to live with.
    Happy to hear my program helps to make it less of an issue.
      My System SpecsSystem Spec

  3.    03 Nov 2015 #23

    I have this issue with a NVidia gpu, its been ongoing for some time now it seems to be intermittent though, every 2 or 3 wakes and it reverts to the realtek sound card which I either uninstall or disable only to find that its somehow reenabled its self. luckily turning my pc off is not too much of a issue.
      My System SpecsSystem Spec

  4.    08 Nov 2015 #24

    razy60 said: View Post
    I have this issue with a NVidia gpu, its been ongoing for some time now it seems to be intermittent though, every 2 or 3 wakes and it reverts to the realtek sound card which I either uninstall or disable only to find that its somehow reenabled its self. luckily turning my pc off is not too much of a issue.
    Can't you disable your onboard audio in the BIOS?
      My System SpecsSystem Spec

  5.    09 Nov 2015 #25

    MrQ said: View Post
    Can't you disable your onboard audio in the BIOS?
    Cheers, completely forgot bios.
      My System SpecsSystem Spec


  6. Posts : 5
    windows 10/1511,Home/Pro WIndows 7Ylt/HP
       28 Nov 2015 #26

    Not just AMD, other audio device have the same problem. IDC here


    I have the exact same 'no audio after sleep' problem; started with 1511 Windows 10 upgrade, but on my computer it is with the "IDC High Definition Audio Codec" device.
    I actually keep the properties window open, so i can disable/enable after sleep to restore audio. I was looking for a devcon or nirsoft script to make it easier.
    I am pretty sure the problem occurs with whichever is the primary device in a system. not just AMD HDMI.

    Could you modify your program to make device name a command line input?
      My System SpecsSystem Spec

  7.    28 Nov 2015 #27

    I seem to have cured mine, I have a AV amp which passes all video if I have it set to hdmi 1&2 it wakes the pc, if I only set it to 1 output then it's fine. I have 2 outputs TV & Pj.
      My System SpecsSystem Spec


  8. Posts : 5
    windows 10/1511,Home/Pro WIndows 7Ylt/HP
       30 Nov 2015 #28

    Not AMD problem.


    Spudz said: View Post
    This isn't an AMD exclusive issue as it occurs on my Intel D54250WYK NUC as well.
    Running Windows 10 Pro with Kodi 15.1 Media Center. Monitor goes to sleep, wakes up, no audio and no audio device in Device Manager.
    Restarting the PC fixes the issue.
    All drivers are up to date, tried reverting Kodi to version 14.2 same issue.
    Mr. Q I see someone else has already highlighted that this no audio after sleep problem is not an AMD exclusive.

    Could you make a version of your program that we can input the problem device name?
      My System SpecsSystem Spec

  9.    12 Dec 2015 #29

    It's weird. I installed the program and I DO have an AMD card (AMD HD 7770) but the sound does not return...
      My System SpecsSystem Spec

  10.    12 Dec 2015 #30

    At spyro. Did you double click on the amdaudiofix_x64 icon in the folder, I've got mine pinned in the start menu.

    If a media player is open you should close it first before hitting the audiofix .
      My System SpecsSystem Spec


 
Page 3 of 5 FirstFirst 12345 LastLast

Related Threads
I use the on-board ATI Radeon HD3300 graphics on Asus/AMD MB on my Windows 10 test system. On August 8th windows update installed a new driver from AMD. Ever since I can't use sleep on my Win 10 system. With the POWERCFG command, I was able to...
I upgraded a Dell XPS9000 from Microsoft Windows 7 Ultimate to Windows 10 Professional. The update went smooth the exception of the following: 1. Creative Lab X-FI Sound Board - No Sound -- Creative Labs doe NOT have WIN10 drivers yet. 2. AMD...
hdmi audio in Graphic Cards
Now i cant get the audio to work i have the realtek audio drivers and the CCC audio drivers. I am using a radeon hd7700 gpu.
Per the title, I run my computer through my TV using an HDMI cable. Sound works brilliantly on Windows 8.1 but after upgrading to Windows 10, I'm left without audio, and in the sound settings it doesn't show HDMI as an available device. Ideas?
This happened on the previous build as well but I was hoping it would be fixed with the newer build. I have a AMD R9 280X GPU which I connect with an HDMI cable to my one monitor with built in speakers (ASUS). Any time I restart or shut down my...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:46.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums