Desktop moved from primary to secondary monitor (by a ghost??)

  1. Hairy Scot's Avatar
    Posts : 182
    Windows 10 Pro X64 1909 Build 18363.778
       #1

    Desktop moved from primary to secondary monitor (by a ghost??)


    I have a Gigabyte P27 laptop with a Dell U2913WM monitor attached via VGA connector and a Samsung TV connected via HDMI.
    I use extended desktop and the Dell is set as Main Display. The built in monitor is disabled.
    The configuration is, from left to right, Dell (3), TV (2), Built in (1).
    I been running this way for about a year with no issues until two days ago when all of a sudden after boot up the desktop had disappeared from the Dell and appeared on the Samsung. But the taskbar stayed on the Dell.
    I dragged and dropped the stray icons back to the Dell and all was fine until the next restart when they moved back to the TV.
    I have since discovered that any screen refresh causes the same phenomenon.
    I've hunted high and low but I can find nothing that would explain this or suggest how to fix it.
    Any help or info would be greatly appreciated.
      My Computer

  2. bro67's Avatar
    Posts : 8,169
    Mac OS Catalina
       #2

    That is because the laptop will always be Display 1. No way to change it.
      My Computers

  3. Hairy Scot's Avatar
    Posts : 182
    Windows 10 Pro X64 1909 Build 18363.778
    Thread Starter
       #3

    bro67 said:
    That is because the laptop will always be Display 1. No way to change it.
    ?????

    I'm sorry, but how is that relevant?
    The Laptop's built in monitor is not the issue.
    The issue is that all of a sudden Windows has apparently decided to dynamically swap things between the two external monitors.
      My Computer

  4. thomaseg1's Avatar
    Posts : 9,412
    Windows 10 Professional (x64) Version 2004 19041.264 & version 2004 build 19635.1
       #4

    disconnect all, reconnect 1 at a time (with new cables) . You may have a fault in one of the cables.
      My Computers

  5. Hairy Scot's Avatar
    Posts : 182
    Windows 10 Pro X64 1909 Build 18363.778
    Thread Starter
       #5

    Installed DisplayFusion.
    That's fixed it.
    However still can't explain what caused the problem.
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:45.
Find Us




Windows 10 Forums