Windows 10: Four display inputs = black screen


  1. Posts : 18
    Microsoft Windows 10 Home 64-bit
       1 Week Ago #1

    Four display inputs = black screen


    I have a GTX 1070 with four inputs, two HDMIs and two Displayports. Two of the inputs are my monitors running at 1920x1080p and 1920x1200p. One of the others is a 4k TV and I'm the last was my HTC Vive. For some reason recently my computer doesn't want to let me have four inputs in at the same time. When I plug in the fourth input all of my screens go black and unplugging that input won't even bring them back up, I have to restart my computer. I've resorted to just swapping out my Vive and TV when I use them but it's rather annoying seeing as how I have four inputs that have worked in the past.

    Any idea as to why this would happen and what I could do to solve the issue?
      My ComputerSystem Spec

  2. Caledon Ken's Avatar
    Posts : 9,747
    Windows 10 Pro x64 Build 1803
       1 Week Ago #2

    Hi TeamMM3.

    Have you or has windows updated the drivers?

    I assume this just started, bad assumption (maybe).

    I might be inclined to use DDU to remove all drivers and reapply latest.

    https://www.wagnardsoft.com/

    I not recommending any other tools, just DDU to give you clean slate.

    If that doesn't work clean the slate again and try an older driver. If it works then you have to stop automated driver updates.


    Ken
      My ComputerSystem Spec

  3.    1 Week Ago #3

    TeamMM3 said: View Post
    I have a GTX 1070 with four inputs, two HDMIs and two Displayports. Two of the inputs are my monitors running at 1920x1080p and 1920x1200p. One of the others is a 4k TV and I'm the last was my HTC Vive. For some reason recently my computer doesn't want to let me have four inputs in at the same time. When I plug in the fourth input all of my screens go black and unplugging that input won't even bring them back up, I have to restart my computer. I've resorted to just swapping out my Vive and TV when I use them but it's rather annoying seeing as how I have four inputs that have worked in the past.

    Any idea as to why this would happen and what I could do to solve the issue?
    It sounds like you are exceeding the max horizontal resolution for the 1070 (7680w x 4320h) , perhaps earlier drivers did not enforce this ? or the new driver take the TV into account even if turned off? or you had a Bios update on the Card?

    (1920 + 1920 + 3840)=7860 + Vive (@2160w I think for both eyes)

    GTX 1070 Ti Gaming Graphics Card | NVIDIA GeForce
      My ComputerSystem Spec

  4. Caledon Ken's Avatar
    Posts : 9,747
    Windows 10 Pro x64 Build 1803
       1 Week Ago #4

    Could you get around this by trying older driver?
      My ComputerSystem Spec

  5.    1 Week Ago #5

    Caledon Ken said: View Post
    Could you get around this by trying older driver?
    Worth a try for sure , I think this was my issue several months ago when I had to go back to a 970 while my 1070ti was RMA'd and I could not run the 3rd or 4th screen I have anymore but I am not 100% sure ? though I was told that the 970 simply didnt have the "bandwidth" at the time by Support as it could not do it with 3 DP outputs @ 2160 . This just sounded similar to what I experienced with the 3rd monitor not getting a signal
      My ComputerSystem Spec


  6. Posts : 18
    Microsoft Windows 10 Home 64-bit
    Thread Starter
       1 Week Ago #6

    Well it turned out the fix was easier than trying old drivers. Apparently in all of my troubleshooting before posting this I hadn't actually had my TV on when I was plugged in my Vive or plugging in my TV. What was happening when my two monitors went blank was actually my computer disabling both of my main monitors and putting everything on my TV. Since it was off I never realized this was happening. I just have never had windows do that with any other inputs before, usually it will either just add the newly plugged in display as another monitor not disable all of the other inputs. Anyway, fortunately it was a simple fix. And yes, I had this four monitor setup working just fine before so not sure why this time it did what it did. Thank you all for the suggestions though!
      My ComputerSystem Spec

  7. Caledon Ken's Avatar
    Posts : 9,747
    Windows 10 Pro x64 Build 1803
       6 Days Ago #7

    Glad you got sorted and thanks for posting solution.
      My ComputerSystem Spec


 

Related Threads
Black Screen on restart, no display signal! in Installation and Upgrade
Hello Ladies and Gentlemen, I'm having a nightmare trying to reinstall windows 10. I'll give a very brief description running up to this problem. Firstly I was using Windows7 and upgraded to windows 10 some time ago and everything worked,...
Hello Suddenly every time I try to Connect to Wireless Display, both my PC screen and my projector image go Black, and stay black until I manually disconnect from the Wireless Display by scrolling thru the Display options (Duplicate, PC only,...
When installing the AMD display diver my screen becomes black. My computer does do anything and I have to manually turn it off and turn it on again. When this happens and my computer boots up again the driver is not installed. I ran DDU before I...
I have two BENQ GL2250 monitors connected to my Lenovo H535s via VGA. On bootup the Lenovo logo displays on monitor #2, and not on monitor #1. Then my usual display comes up on monitor #1 and monitor #2 goes to sleep. Tried HDMI leads too and a...
While using PowerPlanner7, I believe I may have accidentally turned off display or brightness to 0. I am unsure if I successfully made it back to the desktop after rebooting(my attempt to solve the problem). I have tried searching the Internet for...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:57.
Find Us