Windows 10: Problem with turning off the display device

  1.    31 Jan 2018 #1

    Problem with turning off the display device


    I'm running windows 10 pro on an intel NUC7i5. I'm using my TV as a monitor connected via an HDMI cable.
    As long as I keep the TV on, windows runs reliably. In fact I have never seen it stop or crash even when running continuously for weeks at a stretch. However if I turn off my TV, then when I turn the TV back on again many hours later, about half the time the display is visible and the other half the time the screen is completely blank (as if the display hdmi cable has been disconnected). If I simply unplug the display hdmi cable and plug it back in again the display will again come alive (about half the time) and then windows will again behave normally. The other half the time I have to reboot the nuc to restart windows. (It restarts normally every time.)

    Is there something windows could be doing that requires the display to be alive? I'm generally running Kodi although I don't think the problem has anything to do with what program I am running. I could do more testing to verify that, although it takes a long time to collect the data. Also, in the power applet I have said that windows should never sleep or hibernate. At one point I tried allowing it to sleep, but I believe I saw a similar problem where only a blank screen would appear when windows woke up.

    Does anyone know what the issue could be? Or if not what experiments can I run to narrow down the problem?

    Thank
    ~Paul
      My ComputerSystem Spec


  2. Posts : 4,633
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       31 Jan 2018 #2

    Also, in the power applet I have said that windows should never sleep or hibernate.
    What I'd also look for is other settings in Power Options that can put things like the USB ports to sleep in the interest of saving energy, such as MultiMedia settings.
      My ComputerSystem Spec

  3.    14 Feb 2018 #3

    Ok, I looked thru the many dozens of Power options and disabled anything that gave any suggestion that it might save energy. At first, I thought this improved things, but after a few days, it started showing a blank screen about 3/4 of the times that I turn the TV back on. This is worse than before, but perhaps could be just a statistical variation. Also lately the trick of unplugging the HDMI cable and replugging it back in hasn't worked, so now a reboot seems to be the only recourse. (Again this could be just a statistical variation). In any case, the problem has clearly not been solved so I'm hoping someone out there can suggest something else to try.
    Thanks
    ~Paul
      My ComputerSystem Spec


 

Related Threads
Dell display turning grey in Graphic Cards
My Dell Inspiron One 2020 monitor turns grey after a few seconds. It's not completely black, just grey, so I don't think it's going to sleep. After it turns grey I have to relog into my account. I have to move my mouse every few seconds to prevent...
I have a Bluetooth speaker that I use on several of my devices. On my PC, if I leave the device connected when shutting off either it or the PC, when I turn on the speaker, the PC will turn on too. I have to disconnect the speaker every time I'm...
Display is turning off once a day in Performance & Maintenance
Hi! I have a computer with the following configuration: i5 4460, ASRock B85M-DGS, 8Gb ram HyperX, Sapphire Radeon R7 265 Dual-X (with latest video drivers 15.7.1), SSD Kingston v300 120GB, windows 10 with latest updates and my display is LED Samsung...
Solved Power Option for "Turning off display" remains at "15 minutes" in AntiVirus, Firewalls and System Security
I am running Windows 10 Professional 64 bit. Whenever I set the option "Turn off the display" to "Never", it reverts back to the default "15 minutes". This is under the "High Performance" profile. I have never, since Windows 3.11, ever had a setting...
Ok here's whats happening I have a emachine el1360G originally windows 7 but recently upgraded to windows 10 pro. I had no previous problems with my headphones. There the kind you just plug in there nothing special. There the 5.00 ones from...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:21.
Find Us