Monitor black/blank after 1709 update


  1. Posts : 1
    Windows 10 64 bit
       #1

    Monitor black/blank after 1709 update


    I have a dual monitor setup that was previously working prior to updating to 1709. My main monitor is an ASUS VG248QE using display port. This monitor is working fine. My secondary monitor is an old NEC LCD 1920 NX monitor using DVI cable. Both are plugged into my GPU NVidia Geforce GTX 660.

    Problem: My secondary monitor has a black screen while my main asus monitor is fine. The indicator light on the secondary monitor is green (indicating that signal is present). Also when going into display settings it shows that the monitor is detected and it has its recommended resolution settings. My computer thinks its on and working. Sometimes things get opened up on the other monitor, but I can see it bc all i see is a black/blank screen. This all occurred after updating to 1709 creaters update.

    I already reinstalled my display drivers. I even tried restoring back to 1703 but the problem persisted. I then updated back to 1709 and problem still persisted.

    Has anyone had similar problem and found solution ?
      My Computer


  2. Posts : 35,622
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #2

    Hi, I think I recall a thread very similar to this where the solution was to use an OLDER version of the graphics driver.

    Please feel free to search the forum, which is what I'd have to try to do. Meanwhile, of course, someone else may well suggest a way forward.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 03:12.
Find Us




Windows 10 Forums