Clean install, Black screen after driver graphics cards (Internal+PEG)


  1. Posts : 3
    Windows 10 Professional
       #1

    Clean install, Black screen after driver graphics cards (Internal+PEG)


    I decided to reinstall Win 10 Pro a few days ago to start up fresh again for the new year, it works fine on stock windows drivers but the moment I either manually install Nvidia or Intel Graphics Drivers.
    After 6 reformats and reinstalls, discussing it with multiple people I ended up here because it's my Gaming Desktop but its just collecting dust now and I have no idea what to do anymore
    Only a system restore removing all drivers or a reinstall temporarily fixes it.

    DIY Setup:
    - Win 10 Pro
    - Intel I7-7700
    - WD Black PCIe M.2 512GB SSD
    - Seagate 3TB HDD
    - MSI Z270 Gaming Pro Carbon
    - Nvidia GTX 1060 FE
    - Kingston HyperX 32GB running at 2133Mhz (XMP turned off)

    Things I've tried that did not work:

    - Switching Graphics Card Slots for my GTX 1060 FE
    - Since my mobo allows me the choice to either use PEG or Internal Graphics (not both) I've tried installing the Nvidia Drivers, then switch to internal graphics, try and see if anything was wrong with it but drivers reported to be "working", look around to see if I see anything else that looked weird until windows auto installed Intel drivers for my internal graphics and ended with a black screen again. Switched back to PEG in my UEFI only to see a black screen again.
    - Tried to run it just on internal on-board graphics card resulting in the same problem after Windows installs a driver for it.
    - Let windows pick the drivers to install and manually download the correct drivers and install them, both leading to instant black screens while installing.
    - Flash UEFI with the latest firmware AMI v160 (only a few minor upgrades in the firmware) successfully
    - Flash UEFI back to previous firmware AMI v160 successfully.
    - Reset UEFI to factory defaults
    - Try connecting with an old monitor instead of my usual HDMI.
    - Check if windows recognizes my card correctly which it looks like it does because it downloads the right driver only a few versions older.
    - Reinstall windows multiple (6) times.

    All resulting in black screens the moment
    Like I already said, I'm running out of ideas, mostly because it both goes to a black screen after installing drivers for the GTX 1060 FE and for the Internal card.
    Everything worked perfectly before I formatted from the same Win 10 Pro I had installed previously, the first time I installed it several months ago it finished without a problem, this time I'm not that lucky even-though I haven't changed anything in my setup.
    I really hope someone can help me out of this mess.
      My Computer

  2. Bastet's Avatar
    Posts : 1,754
    Windows 10 Pro 64bit
       #2

    Once the pc is working (without the drivers) have you tried downloading the nVidia drivers from the nVidia website & doing a clean install of said drivers? This fixed the problem for me after allowing nVidia to update them from GeForce experience & doing a quick install.
    If that works then move on to the Intel drivers & do the same.
      My Computer


  3. Posts : 3
    Windows 10 Professional
    Thread Starter
       #3

    I tried doing a custom clean install already before Windows was able to get one from the microsoft servers and at about 15% into the installation of the driver phase (Installing Graphics Driver) the screen flickers as usual but then drops all of the signal to both HDMI and other connectors.
    Same thing happens with the Intel graphics card, I grabbed those files with the MSI Live Update program. Those still require a reboot and after that the signal drops.
    (I have had annoying situations like this before where Guru3D's DDU could properly remove old drivers and fix a black screen but it was never as bad as this)

    The strange thing is that it does adopt all adjustments post installation, when I look at my UEFI screen it's clearly running on different drivers (size is correct, everything is 1080p, and everything looks much smoother), the moment I see the windows wheel turn however, about 1 1/2 times on my SSD, the screen goes black again.
      My Computer


  4. Posts : 38,545
    windows 10 professional version 1607 build 14393.969 64 bit
       #4

    Please update the system specs in the "My Computer" section:

    How To Fill Out Your System Specs
    System Specs - Fill in at Ten Forums:
    System Specs - Fill in at Ten Forums Site Use Tutorials
    In the left corner below in your post you find 'My System Specs'.
    After clicking it you can find a link a little below that says 'Update your System Spec', click on this link to get to the page where you can fill in your system specs.
    System Info - See Your System Specs - Windows 7 Help Forums


    Include PSU. cooler, case, peripherals and anything attached to the computer by wired or wireless (mouse, keyboard, headset, printer, xbox, etc.)
      My Computer


  5. Posts : 3
    Windows 10 Professional
    Thread Starter
       #5

    Updated, sorry.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:45.
Find Us




Windows 10 Forums