Windows 10: Bat file problem. Windows Cannot Access the Specified Adress or File Solved

Page 2 of 2 FirstFirst 12
  1.    20 Nov 2017 #11

    I recreated this problem. I downloaded your bat and after clicking on "more info" warning from defender your bat ran fine.

    What is trying to do with move ..\DME_AUM.pack .\Packs\DME_AUM.pack is move a file called "DME_AUM.pack" from one level lower in your directory tree to a folder called "Packs" in the directory where your bat file is running.

    I'm assuming you have it in the right place so I make a directory C:\Temp, another called C:\Temp\Packs and put the file in root of C:

    It works fine in admin cmd prompt:
    PHP Code:
    PS C:\Tempcmd
    Microsoft Windows 
    [Version 10.0.16299.64]
    (
    c2017 Microsoft CorporationAll rights reserved.

    C:\Temp>move ..\DME_AUM.pack .\Packs\DME_AUM.pack
            1 file
    (smoved
    If I move the file back and change your bat to add a "pause" like this
    PHP Code:
    @echo off
    move 
    ..\DME_AUM.pack .\Packs\DME_AUM.pack
    pause
    exit 
    then I get the same error as you:
    PHP Code:
    The system cannot find the file specified.
    Press any key to continue . . . 

    You could just put ext:pack in the search field in Windows File Explorer and move them manually but it is interesting the bat file doesn't find the file even when run as administrator.

    Can I ask are these files in the root of some drive? Like C:\ or D:\ ?
      My ComputerSystem Spec

  2.    20 Nov 2017 #12

    That one is part of Empire Total War Darthmod in H drive. Adress is H:\Steam\steamapps\common\Empire Total War\data\DME\Packs
    The other ones: For instance, this one is very simple on the c drive.
    C:\Program Files (x86)\Steam\SteamApps\common\Sudden Strike 2 Gold

    code\release\game_exe.exe

    I used bat to exe converter and it worked. I reckon I could launch that in summer and Win 10 was installed in spring.
      My ComputerSystem Spec

  3.    20 Nov 2017 #13

    Maybe useful info, I noticded steam folder in H drive is read-only and my user account has no full access. When tried to apply I get failed to enumerate objects in the container in that directory where bat files are.
      My ComputerSystem Spec

  4.    20 Nov 2017 #14

    I don't think it is anything to do with Steam as it failed for me on a temp folder on the C drive.

    I don't think it is anything to do with using Home version either (I have Pro) or AV (as after unblocking the thing it failed just the same and I use defender).

    Either it is a bug in Windows or the bat script is wrong somehow. Considering it works if you copy/paste into cmd window it looks like a bug to me but I'm not a .bat expert.

    I'll keep looking but perhaps someone else will have a clue.

    As for the "enumerate objects" thing you need to take ownership first. I don't think it is relevant to your problem but try this from an admin cmd prompt. Leave the "%USERDOMAIN%\%USERNAME%" exactly as it is - don't put your name in - it will be replaced automatically by the cmd shell.

    This bit of code takes ownership of "H:\Steam" directory and then grants you full authority.

    PHP Code:
    takeown  /f  "H:\Steam" /r
    icacls       
    "H:\Steam" /grant "%USERDOMAIN%\%USERNAME%":(F) /
      My ComputerSystem Spec

  5.    06 Dec 2017 #15

    I just had a very long Windows update. After this, all bat files launch without this error. Seems there was some general bug in the system and now its corrected. Case resolved.
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
I formatted my drive, quickly installed Windows 7 Home with my serial, then instantly upgraded to Windows 10 without using 7 other than to install 10. I am getting really annoying errors. Everytime I try and either rename a icon, or the C drive name...
We had an issue using file explorer and quick access in Windows 10: the never-ending "working on it" message whenever we tried to access our files. The system never even got to the state where we could use the options menu to disable Quick...
Set File Explorer to Open to This PC or Quick access by Default in Windows 10 In Windows 10, File Explorer opens to Quick access by default which shows your Frequent folders and Recent files. Frequent folders = Displays up to ten folders that...
I'm trying to copy a ripped movie file (iso) from my G drive to desktop. The file is 45GB. It gets to 99% then a message comes up saying the process can't complete because the System has the file open. I have nothing running and can't find anything...
Hello. Just installed Win10. I'm having trouble both opening and renaming/changing some files. I had no trouble before on win8. I am administrator with elevated previliges. I changed UAC level to the lowest. I keep getting this error:...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:57.
Find Us