Windows 10: The VirtualRegistry compatibility fix doesn't seem to work


  1. Posts : 121
    Windows 10 Professional x64
       18 Nov 2017 #1

    The VirtualRegistry compatibility fix doesn't seem to work


    Dear forum readers,

    I've been trying to have it working for a few hours now, to no avail.

    What I do :

    Create two registry keys on HKCU : NHR1 and NHR2, as follows :

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\NHR1]
    "Test"="A"
    
    [HKEY_CURRENT_USER\NHR1\SC]
    "Test"="B"
    
    [HKEY_CURRENT_USER\NHR2]
    "Test"="C"
    
    [HKEY_CURRENT_USER\NHR2\SC]
    "Test"="D"
    The goal is that all accesses from powershell.exe to NHR1 are redirected to NHR2.

    So, I start the 64-bit compatibility administrator, create an application fix with the VirtualRegistry shim, with the following command line as a parameter :

    ADDREDIRECT(HKCU\NHR1^HKCU\NHR2)

    DB saved and installed.

    And what I get from my newly started 64-bit powershell.exe :

    Code:
    PS C:\Users\Olivier> gi HKCU:\NHR1\
    
    
        Hive: HKEY_CURRENT_USER
    
    
    Name                           Property
    ----                           --------
    NHR1                           Test : A
    
    
    PS C:\Users\Olivier>
    No redirection happened. How useful... So is it just me or what ?

    Shim database attached, just in case.

    Thanks for your help !
    The VirtualRegistry compatibility fix doesn't seem to work Attached Files
      My ComputerSystem Spec


 

Related Threads
Solved Win + D doesn't work in General Support
Several months ago, the Win + D shortcut stopped working. To the best of my recollection (warning: my memory is not improving with age!) I had made no changes to my system immediately prior to its ceasing to work. It just stopped. I have tried...
Now this isn't Steam, but I regularly check the store and notice that even the most popular games (like GTA V, Turbo Dismount, Skyrim, etc) only list Windows 8.1 as the most recent compatible OS, even though many people play those games on Windows...
ALT+TAB doesn't work. in General Support
So, my alt tab does not really work. It temporarily freezes my computer and or/ becomes unresponsive for a short period of time. I alt tab and it shows the tabs that I can go into, but it stops from there. Then it proceeds to reload my desktop and...
Key doesn't work in Windows Updates and Activation
Trying to upg from 8.1 w wmp and used produkey to get outlook and system reg key and when I when install asks for reg key, neither work. I downloaded from ms win 10 download site. the install window doesn't give ANY other options except QUIT. ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:33.
Find Us