Windows 10: Cannot Rename Folder with a Dot (".")

Page 1 of 2 12 LastLast
  1.    18 Nov 2017 #1

    Cannot Rename Folder with a Dot (".")


    Hello! I have a kind of unusual problem. I have a couple folders with music in them, but the albums have dots in their titles. The two issues I'm currently having are with "I Love You." by the Neighbourhood and "Promises Ltd." by Promises Ltd.

    I've tried renaming them through CMD with no results. I've been told to use their 8.3 filenames, but when I tried doing that, it was just a blank space where the name was supposed to be.

    Not only that, but I cannot do anything to the files themselves. If I try opening the folders, Windows says their locations are "unavailable." Very frustrating.
      My ComputerSystem Spec

  2. Barman58's Avatar
    Posts : 2,786
    Windows 10 Pro x64 1803 - 17134.5 XP/Vista/Win7/Win8.1 in VM for testing
       18 Nov 2017 #2

    It is one of the basic rules of the windows file system that you cannot use certain "system" characters in the creation of a filename things such as the \ > < $ and other characters have special meanings to the operating system

    The . can be used in the folder name as a separator as in ... this.is.new ... but should not be used at the end of a name as it confuses the OS into looking for the next part of the name

    I have many thousands of tracks in many albums digitised and unfortunately you have to compromise - some older systems did not allow spaces which had to be replaced with something else - This_is_New.MP3
      My ComputerSystem Spec

  3.    18 Nov 2017 #3

    Interesting. How can I rename them, however? Windows (for whatever reason) will not let me rename them to something else.
      My ComputerSystem Spec

  4. Barman58's Avatar
    Posts : 2,786
    Windows 10 Pro x64 1803 - 17134.5 XP/Vista/Win7/Win8.1 in VM for testing
       18 Nov 2017 #4

    files with to windows, "Illegal" filenames from other operating systems cannot be read or manipulated within Windows easily

    It may involve using a linux or other OS converting them to the Old Dos 8.3 system using special software and then renaming them in windows to something more human readable.

    By far the easiest method is to re-acquire the files from source within Windows so that the meet standards
      My ComputerSystem Spec

  5. Kari's Avatar
    Posts : 15,021
    Windows 10 Pro
       18 Nov 2017 #5

    The dot as last character in file or folder name tells Windows that what comes thereafter is an extension. It confuses Windows if no extension exists.

    I have not tested this but theoretically, if you select to show file extensions in File Explorer, you should then be able to rename a file or a folder with dot as last character and no extension simply by removing the dot. Worth to try.

    Click image for larger version. 

Name:	image.png 
Views:	4 
Size:	588.9 KB 
ID:	164539
      My ComputerSystem Spec

  6. Kari's Avatar
    Posts : 15,021
    Windows 10 Pro
       18 Nov 2017 #6

    Seems I cannot test this, Windows does not let me create / rename a file or folder so that name would end with a dot.

    Try what I told in my previous post, show file name extensions and then rename problem albums adding an extension (folders can have extensions, too). For instance, rename "Promises Ltd." to "Promises Ltd.xyz", then rename it again removing the extension and the dot.

    It might just work.
      My ComputerSystem Spec

  7. AndreTen's Avatar
    Posts : 14,649
    Windows 10 (Pro and Insider Pro)
       18 Nov 2017 #7

    koukaclover, did you try renaming with * at the end?
      My ComputersSystem Spec

  8.    18 Nov 2017 #8

    In command prompt, have you tried enclosing the old folder name in quotes?
      My ComputerSystem Spec

  9.    18 Nov 2017 #9

    Download 7zip and browse to the file. There you can rename it in 7zip.
      My ComputerSystem Spec

  10.    18 Nov 2017 #10

    Interesting:

    Code:
    C:\Users\John>md "Docements.temp.test.folder"
    
    C:\Users\John>dir
     Volume in drive C has no label.
     Volume Serial Number is B6BA-9DF7
    
     Directory of C:\Users\John
    
    11/18/2017  02:59 PM    <DIR>          .
    11/18/2017  02:59 PM    <DIR>          ..
    11/16/2017  01:55 PM    <DIR>          3D Objects
    11/16/2017  01:55 PM    <DIR>          Contacts
    11/17/2017  03:44 PM    <DIR>          Desktop
    11/18/2017  02:59 PM    <DIR>          Docements.temp.test.folder
    11/16/2017  02:15 PM    <JUNCTION>     Documents [D:\John\Documents]
    11/16/2017  02:16 PM    <JUNCTION>     Downloads [D:\John\Downloads]
    11/17/2017  06:25 PM    <DIR>          Favorites
    11/16/2017  01:58 PM    <DIR>          Links
    11/16/2017  02:23 PM    <JUNCTION>     Music [D:\John\Music]
    11/16/2017  02:23 PM    <JUNCTION>     Pictures [D:\John\Pictures]
    11/16/2017  01:55 PM    <DIR>          Saved Games
    11/16/2017  01:56 PM    <DIR>          Searches
    11/16/2017  02:22 PM    <JUNCTION>     Videos [D:\John\Videos]
                   0 File(s)              0 bytes
                  15 Dir(s)  219,543,801,856 bytes free
    I'm only having issues when the folder name ends with a period with nothing behind it. In fact, nothing will let me create or rename the folder to a name with a period at the end and nothing following it. But periods in the middle don't seem to affect anything at all.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Hello and hope this finds anyone who is reading this well. I tried to take screenshots via the WinKey+PrtSc and the Fn+WinKey+PrtSc method. As expected, the screen briefly dimmed and then reestablished normal illumination as you would expect...
Hi I have recently updated to the creator version My files end up in unintended destinations. When I click in the documents tab in the sidebar of the documents screen, it takes me to a “Documents” folder that appears in “One Drive” group. Any...
Hi,everybody. I've recently installed about 30,000 news fonts on my Windosw 10. The PC slowed down a bit, so I started removing 'some' (many) fonts. However, now that I've removed thousands of fonts, when I open the Fonts folder it only shows...
I recently had a hard drive failure that cost me fifteen years worth of files and data. I am recovering the files currently using Puran file recovery, which seems to be working. However, all the MS Word files (for instance) I recover are simply...
So I basically delete a folder, on my Disk D, and it doesn't vanish, it stays there empty and when I click on it, it says "Folder not accessible access is denied". It's driving me crazy cause sometimes even a explorer.exe restart won't fix....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:10.
Find Us