Windows 10: Cannot Rename Folder with a Dot (".")

Page 2 of 2 FirstFirst 12
  1. AndreTen's Avatar
    Posts : 14,732
    Windows 10 (Pro and Insider Pro)
       19 Nov 2017 #11

    NavyLCDR said: View Post
    Interesting:

    Code:
    C:\Users\John>md "Docements.temp.test.folder"
    
    C:\Users\John>dir
     Volume in drive C has no label.
     Volume Serial Number is B6BA-9DF7
    
     Directory of C:\Users\John
    
    11/18/2017  02:59 PM    <DIR>          .
    11/18/2017  02:59 PM    <DIR>          ..
    11/16/2017  01:55 PM    <DIR>          3D Objects
    11/16/2017  01:55 PM    <DIR>          Contacts
    11/17/2017  03:44 PM    <DIR>          Desktop
    11/18/2017  02:59 PM    <DIR>          Docements.temp.test.folder
    11/16/2017  02:15 PM    <JUNCTION>     Documents [D:\John\Documents]
    11/16/2017  02:16 PM    <JUNCTION>     Downloads [D:\John\Downloads]
    11/17/2017  06:25 PM    <DIR>          Favorites
    11/16/2017  01:58 PM    <DIR>          Links
    11/16/2017  02:23 PM    <JUNCTION>     Music [D:\John\Music]
    11/16/2017  02:23 PM    <JUNCTION>     Pictures [D:\John\Pictures]
    11/16/2017  01:55 PM    <DIR>          Saved Games
    11/16/2017  01:56 PM    <DIR>          Searches
    11/16/2017  02:22 PM    <JUNCTION>     Videos [D:\John\Videos]
                   0 File(s)              0 bytes
                  15 Dir(s)  219,543,801,856 bytes free
    I'm only having issues when the folder name ends with a period with nothing behind it. In fact, nothing will let me create or rename the folder to a name with a period at the end and nothing following it. But periods in the middle don't seem to affect anything at all.
    Exactly. I've tried with 7zip (just before reddice posted his suggestion). But by extraction system renames that folder. to folder_ Have to be done with different operating system
      My ComputersSystem Spec

  2. Barman58's Avatar
    Posts : 2,788
    Windows 10 Pro x64 1803 - 17134.5 XP/Vista/Win7/Win8.1 in VM for testing
       19 Nov 2017 #12

    IIRC the ability to use the period in a file/folder name came in when the character limit was raised from the initial 8.3 system to the current 128 Character limit, prior to this the only period allowed was the one that proceeds the file extension which is still an issue as it prevents the use of period as the last character.

    I think this issue is one for a live linux setup, as linux is derived from UNIX which has always treated the Period as a standard Character so renaming to a standard Windows 8.3 setup, (or even a valid windows Long file name), should be a simple task
      My ComputerSystem Spec

  3.    19 Nov 2017 #13

    Install Cygwin. It's emulates Linux on Windows in a completely native fashion. And it's free.

    In Explorer I created files and folders ending with dot. Afterwards Explorer would not let me rename them. That's the problem you're having. It's very real. And very annoying.

    But a command-line shell (bash) with Cygwin had no such problem. Rename folder "x." to "anything-else" by typing:
    Code:
    mv x. anything-else
    Done.

    Use Cygwin bash to fix your problem.
    Then use bash to replace CMD entirely.

    CMD is surely the world's worst command-line shell language. MS introduced it in 1981, and it's based on its predecessor from the CP/M operating systems of the early 70s. Totally obsolete. And disgraceful.

    Get bash. You'll never look back.
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
Hello and hope this finds anyone who is reading this well. I tried to take screenshots via the WinKey+PrtSc and the Fn+WinKey+PrtSc method. As expected, the screen briefly dimmed and then reestablished normal illumination as you would expect...
Hi I have recently updated to the creator version My files end up in unintended destinations. When I click in the documents tab in the sidebar of the documents screen, it takes me to a “Documents” folder that appears in “One Drive” group. Any...
Hi,everybody. I've recently installed about 30,000 news fonts on my Windosw 10. The PC slowed down a bit, so I started removing 'some' (many) fonts. However, now that I've removed thousands of fonts, when I open the Fonts folder it only shows...
I recently had a hard drive failure that cost me fifteen years worth of files and data. I am recovering the files currently using Puran file recovery, which seems to be working. However, all the MS Word files (for instance) I recover are simply...
So I basically delete a folder, on my Disk D, and it doesn't vanish, it stays there empty and when I click on it, it says "Folder not accessible access is denied". It's driving me crazy cause sometimes even a explorer.exe restart won't fix....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:15.
Find Us