1.    2 Weeks Ago #1
    Join Date : Jul 2015
    Texas
    Posts : 4
    Windows 10 Pro

    Run-time broker Windows 10 Event ID 10016 Errors


    I've been having problems for a few months now, sometimes when trying to open any traditional application, have to wait a few seconds like 5 or 10 before the application launches. At the beginning didn't pay much attention, but started checking the Task Manager which i was able to launch and I could see the application(s) listed on the processes running and then some seconds later the application will launch correctly.
    The issue started becoming more common it didn't matter the application, i think just Task manager and the new Windows Apps (Metro) were able to open on that state. I checked the Event Viewer and the only thing showing Error specifically around the same time i was trying to open the application is the Event ID 10016.
    I've started doing some research and found several websites and forums reporting similar symptom and some workaround to solve the problem, I was able to identify the application as the Run-time Broker. Basically the same information on must of them as it shows in here: Windows 10 error 10016 from Run-time broker - cannot change - Microsoft Community
    I did try that I was able to change Ownership on the Reg keys and able to set the security permission on The Component Services as listed. in my case the Run-Time Broker shows twice and i was able to change the security permission on both to add my user with access to Local Activation marked. But still getting the errors.
    Tired of trying to fix it I did reinstall Windows, a fresh Installation. I did it using a new downloaded image with the latest Fall Creators Update as in some forums they notice the problems when they performed update from one Windows Version to another, but surprise the error is still showing in there not even completed installing all the drivers i checked the Event Viewer and keeps popping from time to time, same related to Run-time Broker.
    "The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
    {D63B10C5-BB46-4990-A94F-E40B9D520160}
    and APPID
    {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}....."

    I did try to set the workaround all ran fine still no changes.
    Don't know what to do it seems that for must people the workaround just works fine and the Windows Re-installation also works, but not in my case.

    Any help will be appreciated
      My ComputerSystem Spec
  2.    2 Weeks Ago #2
    Join Date : May 2017
    Posts : 63
    Windows

    Those Distributed COM errors are a "feature" of Windows 10 (and typical of the quality to expect from this product, one might add). You will see those on any fresh install of Windows 10. There's more than one of these, too. I think it's roughly three or four of those on virgin WinX installs. Note that you can resolve the error by adding proper security permissions. If you look at the full event log entry, you'll see that it's the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) that's denied launch permissions, so that's the user you need to add permissions for.

    HOWEVER, while actions like the above work fine to resolve most of those DCOM errors, the situation with this particular one is not so simple: Notice that when you try to edit launch permissions for RuntimeBroker, you'll be greeted with a warning saying that this object has unrecognized or callback security descriptors set, and the only way to edit permissions is to remove those unrecognized objects. The issue here is that heaven only know what the consequences of doing so might be. I have gone down that road at one point, which did indeed resolve the DCOM errors, but instead I saw COM Surrogate crashes popping up at random times that I could not correlate with any activities on the machine. And, no, I am not sure those crashes are in any way related to RuntimeBroker now being allowed to launch. Again, this is Windows 10 we are talking about.

    Anyway, long story short, my recommendation would be to leave well enough alone. The issues you are seeing are almost certainly unrelated to those DCOM errors, and there is even a chance that those DCOM errors have no consequences of any sort at all.
      My ComputerSystem Spec
  3.    2 Weeks Ago #3
    Join Date : Jul 2015
    Texas
    Posts : 4
    Windows 10 Pro
    Thread Starter

    Thanks for the reply, it might be true what you said and the error that i have might not be related with the Run-time broker event.
    I'll be keeping digging on the system to see if i can find something else.

    Regards!
      My ComputerSystem Spec
  4.    2 Weeks Ago #4
    Join Date : Jun 2015
    UK
    Posts : 2,101
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)

    There are many posts on the forum about how to fix these errors. However, I doubt whether people really understand what causes the 'errors' or what are the unknown consequences of trying to fix them. My approach is to ignore these 'errors' and leave it to MS to fix them (if they are capable of doing so).
      My ComputersSystem Spec
  5.    2 Weeks Ago #5
    Join Date : Oct 2014
    Trnava
    Posts : 2,866
    Windows 10.4 Home 1709 x64



    Quote Originally Posted by Steve C View Post
    My approach is to ignore these 'errors' and leave it to MS to fix them (if they are capable of doing so).

    Same here, I have disabled logging and event viewer altogether and no more errors.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Windows 10 Event ID 10010 and 10016 Errors With DistributedCOM
I am having a number of events that seem to be located repeatedly with the source: DistributedCOM Event ID: 10010 and Event ID: 10016 also getting repeatedly Service Control Manager Event ID: 7031
Performance & Maintenance
Event ID 10016 every time I launch Chrome or Vivaldi.
I get this error every time I launch one of these browsers. The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {D63B10C5-BB46-4990-A94F-E40B9D520160} and APPID...
Browsers and Email
BSOD Event ID 10016 ShellServiceHost and event 7000 !!!
I know there are threads about event 10016 and i tried everything i could, also grant permission to local authority NT through launch and activation permissions but it didn't work i still got the same error sometimes when i something stops working...
BSOD Crashes and Debugging
Distributed COM 10016 - Runtime Broker
So all of a sudden all my apps + store stopped working. Digging into the issue deeper I discovered Runtime broker had something to do with it. As all error messages mark it as a problem. - <Event...
Performance & Maintenance
Solved Windows 10 Event 10016
Hi. I'm trying to start up a videogame, but whenever I do it immediately crashes and the 10016 error activates in the Event Viewer. I looked around the internet for solutions, and found the usual method; I went into Component Services, and scrolled...
Performance & Maintenance
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:10.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums