Windows 10: Trying to delete a folder - You need permission to perform this action

  1. Posts : 10
    Windows 10 Pro 64-bit
       24 Oct 2017 #1

    Trying to delete a folder - You need permission to perform this action

    This started with me trying to install Mozilla Thunderbird, but I quickly came to the belief that I'm sure it's not the installer that's causing an issue.

    I am running Windows 10 Pro and have administrator rights (two users on the computer, both with admin rights - the other user is my wife who hasn't used my laptop in months).

    When I tried to install the program with the default settings, it sets the installation folder to my AppData folder, but when I try that I get an error saying "You don't have sufficient disk space to install to this location". I have 36GB of free space on my 250GB SSD. Whatever...

    So I tried installing it to C:\Program Files(x86). I created the folder Mozilla Thunderbird in there but when I tried installing it there I got an error saying "You don't have access to write to the installation directory." HUH?? I just installed a program there yesterday. (Maybe it is the Thunderbird installer...)

    I also tried installing to C:\Program Files\Mozilla Thunderbird and even C:\My Programs\Mozilla Thunderbird. All attempts resulted in the write access error.

    Then I started looking into permissions issues. I have the utility that adds Take Ownership to the context menu, which I tried on all of the above folders, but also got the write access error. When I right-click on any of those folders and select Properties --> Security --> Advanced the Owner: line says "Unable to display current owner" - even though I just created that folder. If I click on Change next to that it says I "do not have permission to change this object's permission settings"

    Finally, I can't even delete those folders that I just created! I get the message "You need permission to perform this action. You require permission from the computer's administrator to make changes to this folder."

    What's going on here? Since I have recently (yesterday) installed other programs to Program Files(x86), that tells me it could be the Thunderbird installer, but these permissions issues are telling me that, at the very least, there's some other problem/issue going on apart from the installer.

    How can I resolve this mess?
      My ComputerSystem Spec

  2. Posts : 4,457
    Mac OS Sierra
       24 Oct 2017 #2

    The program should create a folder if it has an installer. If you wish to add it to a system folder, you have to change the Security Settings to be able to place it there. The Operating Systems are getting locked down even tighter in an attempt to stop malware from taking over.
      My ComputerSystem Spec

  3. Posts : 10
    Windows 10 Pro 64-bit
    Thread Starter
       24 Oct 2017 #3

    Actually, the installer did create the folder in Profram Files (x86) - I didn't describe that part accurately. I created the other folders manually.

    I'm not precisely sure what you mean by "system folder" in the context of my post and I get why the OS is getting locked down, but the Program Files and User data folders are where pretty much everything is installed when a user installs something. This is the first time I've ever had an issue installing to the Program Files folder.
      My ComputerSystem Spec

  4.    24 Oct 2017 #4 - Windows Repair is a tool designed help fix a large majority of known Windows problems including; registry errors, file permissions, issues with Internet Explorer, Windows Updates, Windows Firewall and more. Download - Windows Repair Tool and run the - Windows Repair Tool from Safe Mode With Networking and from Repairs tab click Open Repairs button. From opened Repairs window place check mark for Reset Registry Permissions, Reset Service Permissions, Register System Files, Repair WMI, Remove Policies Set By Infections, Repair MSI (Windows Installer), Restore Important Windows Services, Set Windows Services To Default Startup, Repair Windows 8/10 Component Store, Restore Windows 8/10 COM+ Unmarshalers, Restore UAC (User Account Control) Settings, Repair MDAC & MS Jet and Reset File Permissions check boxes and click Start Repair button.
      My ComputerSystem Spec

  5. Posts : 10
    Windows 10 Pro 64-bit
    Thread Starter
       24 Oct 2017 #5

    Wow - that Windows Repair tool looks pretty powerful. I'll give that a shot this evening after work.
      My ComputerSystem Spec


Related Threads
Solved you need permission to perform this action in User Accounts and Family Safety
So basically I just got a new laptop and whenever i try to delete certain files this notification comes up and it prevents me from deleting the file. I've watched many videos on youtube to fix this problem but none works. I'm the only account on...
When I try to delete some folders it asks me to give administrator permission to delete it so I do then it tells me I require permission from MSI/BBass (myself) to make changes to this folder. This has happened for multiple folders in my steam...
New Dell XPS-8900 running Win10. I created a Homegroup on the 8900 and joined the Homegroup with my Win8.1 laptop. When I try to copy a file from the laptop to the 8900 (or from the 8900 to the laptop) I get this error: ..... You need...
I frequently get the error message "you need permission to perform this action". Most recently, trying to copy a file from a notebook networked drive to my desktop computer. I'm the only person using my computers and network. Of course, I have...
I am trying to delete a folder on an external hard disk that was created on another computer. First it tells me that I need administrator permissions to modify it, which I grant. Then it tells me that I need permission from dougal\robert to do so,...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:33.
Find Us