1.    16 Oct 2017 #1
    Join Date : Oct 2017
    Posts : 4
    Windows 10

    System clock won't update


    Hello,

    let's see if someone can help me out with this; yesterday I noticed my system clock was not updating, and in the Event Viewer I saw this message:

    "The time provider 'VMICTimeProvider' has indicated that the current hardware and operating environment is not supported and has stopped. This behavior is expected for VMICTimeProvider on non-HyperV-guest environments. This may be the expected behavior for the current provider in the current operating environment as well".

    As far as I know, I have not changed any setting or downloaded any program, so I do not understand what the issue is. Today I bought a new CMOS battery, just in case, but that did not help. Looking forward to your reply, thank you in advance,

    Enrico
      My ComputerSystem Spec
  2.    16 Oct 2017 #2
    Join Date : Oct 2017
    London
    Posts : 7
    Win 10

    Hi,

    Have you checked the settings tab to see whether this is set to auto time zone and have you chosen then correct time and set this to auto?

    Go to Settings>Time>Date and Time

    Sometimes the Time Zone can change, you will need to deselect the auto settings and apply the correct zone first, then reapply auto settings.

    Let me know if you need further help.

    Thanks.
      My ComputerSystem Spec
  3.    16 Oct 2017 #3
    Join Date : Oct 2017
    Posts : 4
    Windows 10
    Thread Starter

    Hi,

    All my settings are correct. I did not have this problem until yesterday, and there is nothing new I did or installed lately...
      My ComputerSystem Spec
  4.    16 Oct 2017 #4
    Join Date : May 2015
    Central IL
    Posts : 4,247
    Mac OS Sierra

    What do you have set in Region Settings and if you are using Hyper-V, your motherboard needs to be compatible, which means check the Bios settings. If Zulu time, you would have the offset for London GMT. This happens a lot when dual booting between Linux and Windows, that the CMOS clock gets set at the offset of Linux, due to a extra GRUB entry is not set to stop the OS from changing bios to zulu.
      My ComputerSystem Spec
  5.    17 Oct 2017 #5
    Join Date : Oct 2017
    Posts : 4
    Windows 10
    Thread Starter

    Hi bro67,

    in region settings I have the clock set to UTC +1, which is my time zone. I don't know whether I am using Hyper-V, but I know this clock issue started when I was dual-booting between Linux and Windows. After a while, I uninstalled Linux e did a new Windows 10 install. Maybe some settings are still affecting my machine, just guessing...anyways, when dual-booting, I always used a different SSD for Linux, and never Hyper-V.
    One thing I noticed, besides the Hyper -V..when I go into Internet Time settings, and I synchronize the clock, I get the message: "an error occurred when Windows was synchronizing with time.windows.com. This operation returned because the time out period expired".
      My ComputerSystem Spec
  6.    17 Oct 2017 #6
    Join Date : May 2015
    Central IL
    Posts : 4,247
    Mac OS Sierra

    Either time is set incorrectly in the Bios or you are looking at the port blocked. Try a different time server and make sure that both the bios and OS clocks are set the same. You may have to pull the CMOS battery to clear the bios.
      My ComputerSystem Spec
  7.    17 Oct 2017 #7
    Join Date : Apr 2017
    Posts : 8,801
    windows 10 professional version 1607 build 14393.969 64 bit

    When testing the time you can use the website: time.is

    The troubleshooting steps in this link may be useful:
    https://support.microsoft.com/en-gb/...ts-to-a-previo
      My ComputerSystem Spec
  8.    4 Weeks Ago #8
    Join Date : Oct 2017
    Posts : 4
    Windows 10
    Thread Starter

    Quote Originally Posted by bro67 View Post
    Either time is set incorrectly in the Bios or you are looking at the port blocked. Try a different time server and make sure that both the bios and OS clocks are set the same. You may have to pull the CMOS battery to clear the bios.
    Hello, the above is exactly what I did. I replaced the CMOS battery, and before I cleared the BIOS; then set the BIOS clock to the correct time, and the system time is now correct. Just to test it, I left the computer on for a few hours, then turned it off over night, and back on again in the morning, and the time was still correct. Therefore I am going to mark the thread as solved, and thank you bro67 for your suggestions, they were the right thing to do!

    Enrico
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
System clock font …size increase?
Hi I am just wondering if its possible to increase the size of the system clock on the bottom right corner of the taskbar. thanks
Customization
Solved Can I display the DAY on the system tray clock?
I have grown accustomed to having the day show in the system tray with the time and date... Now, I've been an IT guy now for going on about 15 years just about, so I DO know my way around... And I know it makes me sound like an old man who maybe...
General Support
System clock changes randomly and often, causes applications to crash
I've been having a problem lately where I would be using a moderately resource-intensive application and it would crash completely, and the system clock in the lower right-hand corner would change. This happens especially when playing games, but it...
General Support
Solved Post Anniversary Update: System Clock Font Black
I've tried switching themes, changing colours etc. etc. no difference. What's with this latest "upgrade" that would alter only the colour of the system clock font? It's happened on both of my Windows 10 installations. I do have the Aerolite...
Customization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:24.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums