Page 2 of 5 FirstFirst 1234 ... LastLast
  1.    26 Sep 2017 #11
    Join Date : Jun 2015
    UK
    Posts : 2,091
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)

    Quote Originally Posted by dalchina View Post
    It seems something went wrong in the original upgrade- as to what is impossible to say. It's a problem that doesn't seem amenable to being repaired; the bcd data doesn't seem to be updated appropriately when I click one of the advanced startup commands to cause the correct form of restart.

    The odd thing is something is updated enough to cause the boot to hang once, until I power off. If I knew why that was, there might be a clue.

    Of course, there are no diagnostic tools one could use during this sequence, which I wish I understood better. It seems the partitions are ok, but the earlier error messages (could not write bcd data e.g.) may have been misleading.

    (And I agree with @cereberus this is probably not a QA issue, bar the questionable appropriateness of the error messages- a common problem with MS).
    Does the command bcdedit /export <yourfilename> work for you? If not, you might have a problem similar to one I experienced. I'll post more details if that command fails.
      My ComputersSystem Spec
  2.    26 Sep 2017 #12
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,992
    Win 10 Pro (1703)
    Thread Starter

    Hi, thanks, that works ok...
      My ComputerSystem Spec
  3.    26 Sep 2017 #13
    Join Date : Jun 2015
    UK
    Posts : 2,091
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)

    Quote Originally Posted by dalchina View Post
    Hi, thanks, that works ok...
    I guess you have a different problem than mine here Solution for Failed Windows 10 Update Installation Error 0x80004005
      My ComputersSystem Spec
  4.    26 Sep 2017 #14
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,992
    Win 10 Pro (1703)
    Thread Starter

    Yep- have also rebuilt the EFI partition in this thread - it didn't help.

    I think the message that the bcd data couldn't be updated was misleading or a consequence of sthg else. But it seems it's not set correctly as I said by selecting on of the advanced options, yet it can be written with bcdedit.

    My guess is that somewhere there's a partition id number discrepancy, but I've no idea where..

    Your post is a very good record of actions taken.
      My ComputerSystem Spec
  5.    26 Sep 2017 #15
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,146
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    I have questions for you:
    1. if you open admin command, copy and paste: reagentc /boottore&shutdown /r /f /t 00
      Does it boot into recovery ?
    2. Is the disk layout still look like the screen you posted in the other thread with 2 recovery partitions (450MB and 480MB)?
      Click image for larger version. 

Name:	151353d1504250279t-creators-upgrade-appeared-ok-but-advanced-recovery-functions-fail-1.jpg 
Views:	36 
Size:	61.2 KB 
ID:	155144
      According to suggestions from the thread, you changed from partitiion 5 to partition 1 with reagentc, which in my opinion is not correct. When you upgrade, windows creates an extra 450MB after C: and put a new Winre.wim there and set it to partition 5 (counting from left to right)
      My ComputerSystem Spec
  6.    26 Sep 2017 #16
    Join Date : Aug 2016
    S/E England
    Posts : 4,501
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Quote Originally Posted by dalchina View Post
    My guess is that somewhere there's a partition id number discrepancy, but I've no idea where..
    I had occasion to sort out booting to my recovery partition a while back. The GUID involved is the one shown by bcdedit as 'recoverysequence' for {current}. This should match the 'Boot Configuration Data (BCD) identifier' shown by reagentc /info

    Somehow I'd managed to change mine and it was booting to a quite different recovery environment. I used reagentc to find the correct GUID and bcdedit to set it to boot correctly. This was back in Anniversary update, in case of further problems I kept a record of the information back then, and the updated information after the upgrade to Creators Update.

    I've attached my records in case they are of help.

    Interestingly, I've since discovered how my other system manages to boot to the recovery environment despite having no recovery partition (apparently the free upgrade to 10 was unable to find anywhere to put one, being an MBR which already had four partitions). The Windows RE location is shown by reagentc as:
    \\?\GLOBALROOT\device\harddisk0\partition3\Recovery\WindowsRE

    But partition 3 is my C: drive. The files that would normally be found in the recovery partition are instead in the hidden and inaccessible C:\Recovery folder, along with a 0 byte hidden file at the root of C: called $WINRE_BACKUP_PARTITION.MARKER
    How does Windows boot to advanced recovery option e.g. command prompt? Attached Files
      My ComputersSystem Spec
  7.    26 Sep 2017 #17
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,992
    Win 10 Pro (1703)
    Thread Starter

    Thanks- looks very promising- will investigate tomorrow.
    However, what has persuaded me to discount the 480Mb recovery partition to date is its apparent lack of content:
    Click image for larger version. 

Name:	1.jpg 
Views:	3 
Size:	60.7 KB 
ID:	155147

    Here's the other one:
    Click image for larger version. 

Name:	2.jpg 
Views:	3 
Size:	75.8 KB 
ID:	155148

    (I'm guessing the two oddly named folders were added by Cryptoprevent when I allocated a drive letter when trying to fix things).
      My ComputerSystem Spec
  8.    26 Sep 2017 #18
    Join Date : Aug 2016
    S/E England
    Posts : 4,501
    10 Home x64 (1709) (10 Pro on 2nd pc)

    If the content is missing, why not do a clean install to a spare HDD then copy the files from the recovery partition it creates? Then put back your proper drive(s) and put the files into the empty recovery partition.
      My ComputersSystem Spec
  9.    26 Sep 2017 #19
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,992
    Win 10 Pro (1703)
    Thread Starter

    .. it's a laptop... with an M2 SSD. Not something I wish to fiddle with, although it's very mch designed for people to take the back off and fiddle.

    Note that earlier I did a clean install, which was fine in this respect, then restored the system partition. Why do you see two recovery partitions? 'Cos I also did an in-place upgrade repair install.
      My ComputerSystem Spec
  10.    26 Sep 2017 #20
    Join Date : Aug 2016
    S/E England
    Posts : 4,501
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Quote Originally Posted by dalchina View Post
    However, what has persuaded me to discount the 480Mb recovery partition to date is its apparent lack of content...
    What alerted me to my problem was that making a system image had stopped including the recovery partition in the images (that and the unfamiliar RE I was booting to). It appears that the reagentc and bcdedit info has to be correct for the system to know where to find (or in your case upgrade) the WinRE. I suspect yours was incorrect before the upgrade to Creators hence the lack of files being put into what you'd expect to be the recovery partition to be used.

    I corrected mine before the upgrade to Creators, which did successfully upgrade my recovery partition. You can recognise a 1703 Advanced Start up by the white box around the selected option, 1607 and before didn't have that.
      My ComputersSystem Spec

 
Page 2 of 5 FirstFirst 1234 ... LastLast


Similar Threads
Thread Forum
General Tips Open Command Prompt at Boot in Windows 10
How to Open a Command Prompt at Boot in Windows 10 A command prompt is an entry point for typing computer commands in the Command Prompt window. By typing commands at the command prompt, you can perform tasks on your computer without using the...
Tutorials
Solved Unable to login to boot command prompt
Hi, I have just used the SHIFT-Restart option to activate the Windows 10 Troubleshooting and tried to open a command prompt. It asked for a password. I entered my password but was told it was incorrect. I booted normally using the PIN I...
General Support
Solved How to boot to a command prompt in Win10 ?
Tapping F8 or spacebar doesn't do anything ? I want to boot to command prompt only. I need to rename my user folder, in an attempt to get it named correctly, after the clean upgrade decided to drop the last character, which now gives me a...
General Support
SFC wont run from boot command prompt, says ....
SFC wont run from boot command prompt, says there are other pending actions and needs to reboot. Rebooting does no good. in other win OS this command, dism.exe /image:c:\/cleanup-image /revertpendingactions would fix this issue. Edit: I just...
General Support
Advanced Boot Options Menu (Choose an option)
The same trick from Windows 8/8.1 still works in 10. https://www.tenforums.com/tutorials/2294-boot-options-menu-open-windows-10-a.html Click on Start, click the power icon at the top of the Start Menu. Hold down Shift and click on Restart. ...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:18.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums