Page 1 of 3 123 LastLast
  1.    19 Sep 2017 #1
    Join Date : Sep 2015
    Posts : 25
    windows 10

    Explorer.exe crash when right click->New


    Hi,
    I have a windows 10 computer which crashes when I right click and open the "new" submenu.
    I already tried to :
    - disable all non microsoft shell extension with ShellExView
    - try in safe mode (same issue)
    - run sfc /scannow and dism repair

    I found out that if I edit "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew \Classes" to remove DOCX or rename DOCX to docx it fixes the issue. BUT, this change is overwriten each time I open this "new" right click menu, so it only works one time.
    A solution could be to make this change permanent but I don't know how...

    Here is a crash dump analysis from osronline :

    Code:
    *** WARNING: Unable to verify timestamp for sppc.dll
    *** ERROR: Module load completed but symbols could not be loaded for sppc.dll
    *** WARNING: Unable to verify timestamp for DropboxExt64.18.0.dll
    *** ERROR: Module load completed but symbols could not be loaded for DropboxExt64.18.0.dll
    *** WARNING: Unable to verify timestamp for ashShA64.dll
    *** ERROR: Module load completed but symbols could not be loaded for ashShA64.dll
    TRIAGER: Could not open triage file : e:\dump_analysis\program\triage\modclass.ini, error 2
    GetUrlPageData2 (WinHttp) failed: 12029.
    *** The OS name list needs to be updated! Unknown Windows version: 10.0 ***
    
    FAULTING_IP: 
    shell32!CheckFileTypeForShellNew+32
    00007ffe`a84b5616 488b03          mov     rax,qword ptr [rbx]
    
    EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)
    ExceptionAddress: 00007ffea84b5616 (shell32!CheckFileTypeForShellNew+0x0000000000000032)
       ExceptionCode: c0000005 (Access violation)
      ExceptionFlags: 00000000
    NumberParameters: 2
       Parameter[0]: 0000000000000000
       Parameter[1]: 0000000000000000
    Attempt to read from address 0000000000000000
    
    PROCESS_NAME:  explorer.exe
    
    ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".
    
    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx"  referenced memory at "0x%08lx". The memory could not be "%s".
    
    EXCEPTION_PARAMETER1:  0000000000000000
    
    EXCEPTION_PARAMETER2:  0000000000000000
    
    READ_ADDRESS:  0000000000000000 
    
    FOLLOWUP_IP: 
    shell32!CheckFileTypeForShellNew+32
    00007ffe`a84b5616 488b03          mov     rax,qword ptr [rbx]
    
    NTGLOBALFLAG:  0
    
    APPLICATION_VERIFIER_FLAGS:  0
    
    FAULTING_THREAD:  0000000000002528
    
    BUGCHECK_STR:  APPLICATION_FAULT_NULL_POINTER_READ_AFTER_CALL
    
    PRIMARY_PROBLEM_CLASS:  NULL_POINTER_READ_AFTER_CALL
    
    DEFAULT_BUCKET_ID:  NULL_POINTER_READ_AFTER_CALL
    
    LAST_CONTROL_TRANSFER:  from 00007ffea84b65b8 to 00007ffea84b5616
    
      SYMBOL_STACK_INDEX:  0
    
    SYMBOL_NAME:  shell32!CheckFileTypeForShellNew+32
    
    FOLLOWUP_NAME:  MachineOwner
    
    MODULE_NAME: shell32
    
    IMAGE_NAME:  shell32.dll
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  0
    
    STACK_COMMAND:  ~77s; .ecxr ; kb
    
    FAILURE_BUCKET_ID:  NULL_POINTER_READ_AFTER_CALL_c0000005_shell32.dll!CheckFileTypeForShellNew
    
    BUCKET_ID:  X64_APPLICATION_FAULT_NULL_POINTER_READ_AFTER_CALL_shell32!CheckFileTypeForShellNew+32
    
    WATSON_STAGEONE_URL:   http://watson.microsoft.com/StageOne/explorer_exe/10_0_15063_447/951324bb/shell32_dll/10_0_15063_502/944613c6/c0000005/00435616.htm?Retriage=1
      My ComputerSystem Spec
  2.    19 Sep 2017 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,930
    Win 10 Pro (1703)

    Hi, you might like to try this freeware program to remove a possibly corrupt entry:

    Click image for larger version. 

Name:	1.jpg 
Views:	2 
Size:	169.3 KB 
ID:	154051

    Naturally you could do the same in the registry- it's a convenient tool.
    You can compare what it does with the registry to the action you quote.
      My ComputerSystem Spec
  3.    19 Sep 2017 #3
    Join Date : Sep 2015
    Posts : 25
    windows 10
    Thread Starter

    I removed docx with this software but it did not change the ShellNew \Classes value and the crash still happens
      My ComputerSystem Spec
  4.    19 Sep 2017 #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,930
    Win 10 Pro (1703)

    Are you sure it's the docx extension and not another?

    Also you could check this doesn't happen if you create a new user for test purposes. If it does, there's an underlying problem with Windows.

    And do you have a relevant system restore point?
      My ComputerSystem Spec
  5.    19 Sep 2017 #5
    Join Date : Sep 2015
    Posts : 25
    windows 10
    Thread Starter

    Well, the problem disappear if I manualy remove docx extension from the shellnew registry... until it is added again by windows.
    I do not have a relevant restore point.
    I will test a new user later.
      My ComputerSystem Spec
  6.    20 Sep 2017 #6
    Join Date : Sep 2014
    Posts : 448
    10 preview 64bit

    As i said in your other post
    Run the tool

    The first timestamp error sppc. dll, relates to windows activation

    Roy
      My ComputerSystem Spec
  7.    20 Sep 2017 #7
    Join Date : Sep 2015
    Posts : 25
    windows 10
    Thread Starter

    Please find below the report, I see no errors
    I also tried a new user it works fine, but there is no .DOCX in registry. So the issue remains : how to remove it from my current account. Or what else can I do ? The new menu editor dalchina suggested does not change the ShellNew registry, but changes value elsewhere.
    Thanks.
    Code:
    Windows Diagnostic Information
    ------------------------------
    
    Tool Version: 10.0.15063.0
    Licensing Status: Licenced
    Licensing Status Reason: 0x4004F401
    Local Genuine State: Genuine
    Local Genuine Result P: 1
    Last Online Genuine Result: 0x00000000
    Grace Time Minutes: 0
    Total Grace Days: 0
    Validity Expiration: 
    Active Partial Product Key: F6YK4
    Active Product Key Pid2: 00325-95885-16799-AAOEM
    O S Version: 10.0.15063.2.00010300.0.0.101
    Product Name: Windows 10 Home
    Processor Architecture: x64
    Edition Id: Core
    Build Lab: 15063.rs2_release.170317-1834
    Time Zone: Paris, Madrid(GMT+02:00)
    Active Sku Id: 8db63db6-4f8f-46d6-a448-66444faaaa72
    Active Sku Description: Windows(R) Operating System, OEM_DM channel
    Product Uniqueness Groups: 55c92734-d682-4d71-983e-d6ec3f16059f
    Active Product Key P Key Id: 2045a198-062d-5f61-c8dc-7f337ad7b895
    Active Product Key Pid Ex: 03612-03259-588-516799-02-1036-15063.0000-2432017
    Active Product Key Channel: OEM:DM
    Active Volume Customer Pid: 
    Offline Installation Id: 269497590915452156012357192015382210660211872767222425510106404
    Domain Joined: false
    Computer Sid: S-1-5-21-2499206201-2461669800-726101907
    Product L C I D: 1036
    User L C I D: 1036
    System L C I D: 1036
    Code Signing: SIGNED_INFO_PRS_SIGNED
    Service Available: true
    Oem Marker Version: 
    Oem Id: 
    Oem Table Id: 
    O A3 Product Key: 7D96M-8NVTW-VW6GV-TJ4PR-F6YK4
    Manufacturer: HP
    Model: HP Pavilion Gaming Notebook
    Install Date: 20170831101432.000000+120
    Result: PASS
    Tampered Items: 
    Server Props: GenuineId=55c92734-d682-4d71-983e-d6ec3f16059f;OemId=0000064397;OptionalInfoId=+p7ApsH3aZ357NpWNJQHluUn2P/ZO8OCoUSwNWsn/nGg3lO5jJk7m7s44NU//PcU;Pid=voVvDbBuLPn+e39K/8KiYKQDaMD0pA1eUSjLhGkg3/4=;SkuId=8db63db6-4f8f-46d6-a448-66444faaaa72;TimeStampServer=2016-04-06T06:29:38Z;
    
    ****** Errors from Event Log *****
    No Security SPP Event Log errors found
    
    ------------------------------------------------
    Created by Superfly for EightForums & TenForums
      My ComputerSystem Spec
  8.    20 Sep 2017 #8
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,930
    Win 10 Pro (1703)

    That's progress- indicates the problem is definitely related to your user configuration, so it's effectively data, not Windows that needs fixing.

    What put the docx entry there? You might try
    a. changing the association with docx
    (In Settings or Control panel)
    b. uninstalling the program that created the association
      My ComputerSystem Spec
  9.    20 Sep 2017 #9
    Join Date : Sep 2015
    Posts : 25
    windows 10
    Thread Starter

    I am not sure : does changing file association affects the "new" menu ?
      My ComputerSystem Spec
  10.    20 Sep 2017 #10
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,930
    Win 10 Pro (1703)

    Windows 'out of the box' knows nothing about docx....
      My ComputerSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
Frequent Crash including mouse crash
Hi, I don't know if this is the right forum to post this in but for the past few weeks my computer will stop working and when I finally get some reaction from it there will be a notice at the bottom of the page that says something like "msn has...
Performance & Maintenance
Unable to Left-Click on Windows 10 Start Menu, But Right Click Works
I ran the System File Checker as suggested; it detected no problems. I have two PCs with Windows 10. On the one that I upgraded to Windows 10 most recently, I have no problem. On the one that I upgraded about 9 months before that (it is a Samsung...
General Support
Browser crash / Unable to right click or open files / computer freeze
So for a bit now, perhaps a week, my computer has been acting weird. I haven't made any big changes(or at all I think) lately and don't know what's causing it. So what happends? I'll be doing stuff on my browser(Chrome, but I also tried Firefox...
Browsers and Email
Right Click Crash Brand New Laptop
Hello everyone, sorry if this is in the wrong place. I've had my Asus X555U laptop less than a month and it's already develpoped these issues. The Right click crash when I click on anything to do with Windows Explorer, it also likes to take 20...
General Support
Windows 10 became suddenly unreliable, with Crash after Crash!
Windows 10 has been working like a Dream but now its turned into a nightmare! Constantly Crashing after an hour of use, has anyone else had this problem, as its been working fine for months.
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 01:47.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums