Windows 10: Windows 10 results in repeated Internal Power Failure in Dell Inspiron

Page 3 of 5 FirstFirst 12345 LastLast
  1.    29 Jul 2015 #21

    I have exactly the same system 7548 and the same problem internal power error,
    And I'm totally unable to run my system into safe mode.

    Any help.. Please.
      My ComputerSystem Spec

  2.    29 Jul 2015 #22

    Please suggest me something I'm unable to run my system in safe mode,
    I have the same dell inspiron 7548
    Updated windows 10 from Windows 8.1.

    Any help would be appreciated.
    Thanks
      My ComputerSystem Spec

  3.    30 Jul 2015 #23

    I upgraded a couple of 5 year old Dell desktops (an Inspiron 580 and Optiplex 790) to Windows 10 with no problems. I did make sure to upgrade each pc to the latest bios (A07 for the Inspiron 580 and A18 for the Optiplex 790) before attempting to upgrade to Windows 10. Both started with Windows 7 Home.

    I also upgraded three Dell laptops, an Inspiron 1545, Inspiron 17r 7110 and an Inspiron 17r 5737. All with no problems. Once again, I made sure that each was upgraded to the latest Dell bios before attempting the Windows 10 upgrade. The 1545 had Windows 7 Home, 17r 7110 had Windows 7 Pro and the 17r 5737 had Windows 8.1 Home before the upgrade.
      My ComputerSystem Spec

  4.    30 Jul 2015 #24

    Hey guys.
    Have some unknown devices after the upgrade ?
    What drivers have you installed on it ?
    Can you post a screenshot of your device manager ?
    I tried to install the RTM, but I kept getting unknown items.

    Dell has just launched some new Dell Inspiron 7548 with Windows 10 embedded. Maybe new drivers soon ?
      My ComputerSystem Spec

  5.    30 Jul 2015 #25

    Hello there,
    Did you figure out how to get to the safe mode??
    I'm struggling with the same problem.
    anthonyonten said: View Post
    Yes. But that doesn't seem to offer me safe mode, just non secure boot. Thanks for replying, much appreciated.
      My ComputerSystem Spec

  6.    30 Jul 2015 #26

    I found that the Windows 8 or 8.1 drivers work in Windows 10. When I had some yellow flags in the device manager, I loaded some Dell Windows 8 drivers and that did the trick.
      My ComputerSystem Spec

  7.    30 Jul 2015 #27

    There isn't windows 8.1 anymore can't get back to previous windows since I upgraded to Windows 10 couple of hours ago, and my system keep restarting with internal power error and I'm unable to run this system in safe mode.
      My ComputerSystem Spec


  8. Posts : 1,634
    W7 Pro x64 | W10 IP x64 | Linux Mint VM
       30 Jul 2015 #28

    For the time being I'd suggest disabling your AMD card in Device Manager. Plenty of people are getting this issue and while it's certainly not a permanent fix it should stop the BSODs until a fix is found.
      My ComputerSystem Spec

  9.    30 Jul 2015 #29

    Antilope said: View Post
    I found that the Windows 8 or 8.1 drivers work in Windows 10. When I had some yellow flags in the device manager, I loaded some Dell Windows 8 drivers and that did the trick.
    Not the best though..
    Intel updated all their drivers for Windows 10 (Graphics, thermal, Management Engine, Wifi, Bluetooth...).
      My ComputerSystem Spec

  10.    30 Jul 2015 #30

    How can I disable it.?
    I'm unable to run it in safe mode and other than that as soon as I logged in it restarts.
    Totally stuck with nowhere. 😕😠😕
      My ComputerSystem Spec


 
Page 3 of 5 FirstFirst 12345 LastLast

Related Threads
Okay decided to do a fresh install on the wife's Dell Inspiron 1525.Which had Windows 7 x64 on it,But was released with XP and Vista only on it. The only drivers I had to install after the fresh install of Windows 10 Build:10162. Were SigmaTel HD...
Duplicate thread, sorry.
Upgraded my Dell Inspiron 15R laptop from 10041 to 10049. Went well though it took a long, long, time. Anyway, I have drivers for all devices except these two and can't actually figure out what they are. 16384 16383 16382
I'm running Windows 10 build 9926 on an Inspiron 3135 from 2013. I made a clean installation from the Microsoft ISO on a 120GB Kingston SSDNow V300 SSD. Prior to that it was running the original HDD with its 8.0 distribution upgraded to 8.1 via the...
Solved Dell Inspiron in BSOD Crashes and Debugging
Hi I have been having trouble starting my dell Inspiron 6400 it was last running Windows 10 Build 9841. it was working fine with no problems at all until one morning when I tried to turn it on it was not showing Dell Logo just turning on and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:29.
Find Us