Page 3 of 3 FirstFirst 123
  1.    24 Sep 2017 #21
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,002
    Win 10 Pro (1703)
    Thread Starter

    Some progress- and some things learnt.
    reagentc /enable wouldn't work at all as shown above. I have succeeded in getting that to work.

    Recall my 'build' was a clean install (when all worked) with 'C:' replaced with my current system partition. Having done that, I had no Advanced recovery options.

    Having 'fixed' reagentc /enable, I now have those back.

    reagentc /info now gives what it should:
    C:\windows\system32>reagentc /info
    Windows Recovery Environment (Windows RE) and system reset configuration
    Information:

    Windows RE status: Enabled
    Windows RE location: \\?\GLOBALROOT\device\harddisk1\partition1\Recovery\WindowsRE
    Boot Configuration Data (BCD) identifier: ea28bca3-a098-11e7-8bcb-a434d962e85a
    Recovery image location:
    Recovery image index: 0
    Custom image location:
    Custom image index: 0

    REAGENTC.EXE: Operation Successful.


    How? Two things.
    To get reagentc /enable to work:

    1. Copy winre.wim to C:\Recovery\WindowsRE
    2. Following

    [SOLVED] How Do I Prepare Windows Recovery Environment on Windows 10. Taking Backup Measures on Your Windows Using ReagentC Tool and PowerShell


    zero entries in
    C:\Windows\System32\Recovery\reagent.xml

    It may be necessary to create winre.wim using the appropriate Win 10 install iso; if the iso contains install.esd, this needs to be converted to install.wim using the appropriate DISM command.

    Then run
    reagentc /enable


    Alas - I'm now back in the same state I was in quite some time back, where attempting to use the boot to Safe Mode option => just a PC logo, nothing more, and booting to a command prompt takes me to a PC logo with Please Wait at the bottom of the screen.

    I.e. I have all the Advanced Recovery Options - but they don't work.
      My ComputerSystem Spec
  2.    4 Weeks Ago #22
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,002
    Win 10 Pro (1703)
    Thread Starter

    Solved! by an unexpected means...

    Recall I had upgraded from the AU to the CU and could not boot e.g. to Safe Mode - on restarting to try to do so just the PC logo, no activity.

    This time I started by wiping all Windows partitions, then clean installing the CU, intending should all be well to restore my system partition from my Macrium partition image.

    I noted that trying to boot to Safe Mode via SHIFT + left click restart -> error 0xc0000454 - The boot configuration data for your PC is missing or contains errors. Shock, horror, jaw drops etc...

    Curiously, selecting Safe mode via msconfig worked.

    I tried again, and noticed this time when deleting partitions using the Win 10 installation sequence, that the disk numbers for my two disks (SSD, SSHD) were reversed compared to when shown by the partition manager. Thus now the SSD was shown as Disk 1. I deleted the partitions. During the installation process I also noted on the restarts there were a couple of short lines briefly shown on a black screen indicating no boot source had been found (not the exact text- it was brief and obscure).

    Now I hadn't been used to seeing that.

    Restart to safe mode again => 0xc0000454.

    ======================================
    Time to reinstall 1607 - the AU- which had worked.

    This time the disk numbers were 0 for the SSD, 1 for the SSHD.
    I deleted the Windows partitions on Disk 0, reinstalled. During the reinstallation process there was no message on restarting during the process.

    I tested restart to Safe Mode- fine.

    I then restored the image of the CU Windows partition and rebooted. All is now well.

    Now, that begs at least the following questions.
    a. Had I upgraded to the CU with only my SSD in, or clean installed it thus, would all have been well.
    b. What is the significance of the disk number reversal between the AU and the CU?
    c. Given I now have my recovery, system, EFI partitions created from the 1607 build and my Windows partition from the CU build, and all seems well- is there any discrepancy that is likely to catch me out?

    (Note: when I first rebooted this concoction, it (unsurprisingly) did an automatic repair- which succeeded).

    Has anyone else noted their system disk not being designated as Disk 0 by a CU build on installation?
      My ComputerSystem Spec

 
Page 3 of 3 FirstFirst 123


Similar Threads
Thread Forum
Unknown symbol has appeared after update to win10 creator edition
The symbol showing on the left of this image 135325 has started appearing on open windows since I updated to the creators edition. If I click it, the following is all that happens: 135326 Does anyone know what or why this is?:confused:
General Support
Windows 10 keep restarting! Recovery fail
So i have decided to restart my whole pc just to remove my old files after i do that and the windows startet to inistal i get an error about the inistalation so i had an option to restart my pc or to turn it of! so i turn it off and now its keep...
Installation and Upgrade
Will New Windows 10 upgrade reset all functions to defaults
I am still having problems with PC freezing up at various times. I did receive help from NavyLCDR and AndreTen, but I am wondering if that the Windows 10 upgrade coming at the end of July will reset things and fix my problem or will it save all the...
Windows Updates and Activation
Solved Recovery disk. What functions will it perform?
Hi, Just curious. I created a recovery disk on a 32 GB flash drive that included the system files and has 17.2 GB of used space. What functions can I perform with this disk? E. G., Clean install? Refresh/reset? I'm wondering if the USB stick that...
Installation and Upgrade
Upgrade to 10 from 8.1 64-bit basic functions no longer functional
Good Wednesday morning - The actual upgrade process went completely smooth, without a hitch. HOWEVER, after restarting the now upgraded Windows 10 environment does not allow for basic functions such as taskbar, web browsing, right-click desktop,...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:32.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums