Page 2 of 3 FirstFirst 123 LastLast
  1.    02 Sep 2017 #11
    Join Date : Jul 2015
    Posts : 9,336
    Windows 10 Pro

    And did that solve your original problem?
      My ComputerSystem Spec
  2.    02 Sep 2017 #12
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,943
    Win 10 Pro (1703)
    Thread Starter

    No.. still same symptoms as I said. If I run Macrium Fixboot it disassociates the recovery partition completely.

    I feel there's something indicated by the 0xc0000454 message in addition to the recovery partition, but I've no idea what.
      My ComputerSystem Spec
  3.    02 Sep 2017 #13
    Join Date : Jul 2015
    Posts : 9,336
    Windows 10 Pro

    It does sound like the BCD is messed up. You can rebuild the EFI System Partition. You would boot into Kyhi's Recovery Tools. Use MiniTool Partition Wizard to assign a drive letter to the EFI System Partition (on the second drive, it looks like). Let's say you give it T:. Reformat the EFI System Partition to FAT32. Then in a command prompt you would run:

    bcdboot C:\Windows /s T: /f UEFI

    Make sure the path in red is to your Windows installation as it appears in Kyhi's Recovery Tools - it might not get assigned C: so you might have to change the drive letter to match.

    I've seen it where there are multiple BCDs in the EFI System Partition and you are doing the repairs to one BCD, but then the computer is actually booting with another BCD in the same EFI System Partition and you wonder, What the heck, I know I changed that but the computer isn't recognizing the changes!
      My ComputerSystem Spec
  4.    02 Sep 2017 #14
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,943
    Win 10 Pro (1703)
    Thread Starter

    Thanks, I'll try that. (I have previously tried rebuilding the BCD but clearly that's not enough).

    Also found that, having run the reagentc command to reassociate the recovery partition, reagentc /info shows it's disabled.
    Attempting to enable it - reagentc /enable - in normal mode from an admin prompt says
    C:\WINDOWS\system32>reagentc /enable
    REAGENTC.EXE: Unable to update Boot Configuration Data.

    - and reagentc isn't recognised as a command at a command prompt when booted via the Windows installation disk.
    Last edited by dalchina; 02 Sep 2017 at 07:01.
      My ComputerSystem Spec
  5.    02 Sep 2017 #15
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,943
    Win 10 Pro (1703)
    Thread Starter

    So the result: I can still boot ok.
    Click image for larger version. 

Name:	MT Part Wiz.jpg 
Views:	2 
Size:	32.8 KB 
ID:	151562

    But
    Click image for larger version. 

Name:	reagent.jpg 
Views:	3 
Size:	64.0 KB 
ID:	151563

    EFI partition:
    Click image for larger version. 

Name:	efi.jpg 
Views:	2 
Size:	110.6 KB 
ID:	151568
    Last edited by dalchina; 02 Sep 2017 at 09:50.
      My ComputerSystem Spec
  6.    02 Sep 2017 #16
    Join Date : Jul 2015
    Posts : 9,336
    Windows 10 Pro

    At this point, I guess, if you really want the advanced boot menu, I would say the only alternative is to backup your current Windows partition with Macrium Reflect. Do a clean install of Windows 10 (delete every partition in front of your D: partition and install to the unallocated space). Then boot into Kyhi's Recovery Tools or Macrium Rescue and replace only the OS partition. You might have to run Macrium's utility to fix booting. Then try /setreimage to the recovery partition.

    I don't sweat the recovery menu too much. Everything on it can be executed from a Windows 10 bootable USB drive anyway.
      My ComputerSystem Spec
  7.    02 Sep 2017 #17
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,943
    Win 10 Pro (1703)
    Thread Starter

    Thanks, actually I already did that... one of the things I did before posting here...
    #2
    They fail on
    - my build upgraded from the Anniversary Edition (fully updated Creator's build)
    - after restoring my fully updated Creator's build C: partition in place of that of a clean install of the Creator's build
    - after an in-place upgrade repair install of that
    The advanced recovery menu worked after the clean install.. not after replacing the "C:" partition.

    However, I did have to run Macrium Fixboot (rather than Startup Repair which I tried first and had expected to work) to get that to boot.

    And as noted above, Fixboot seems to remove the link to the Recovery partition.

    Hmm. Maybe there's another way to get the system to boot after replacing the Windows partition... for example, repair the EFI partition?

    But as you say, maybe I just live with it. We've another upgrade coming...
      My ComputerSystem Spec
  8.    02 Sep 2017 #18
    Join Date : Jul 2015
    Posts : 9,336
    Windows 10 Pro

    For unrelated reasons, I just did a clean install. Here's my BCD, I think the issue has something to do with the recovery enabled setting:

    Code:
    C:\Windows\system32>bcdedit
    
    Windows Boot Manager
    --------------------
    identifier              {bootmgr}
    device                  partition=\Device\HarddiskVolume2
    path                    \EFI\MICROSOFT\BOOT\BOOTMGFW.EFI
    description             Windows Boot Manager
    locale                  en-us
    inherit                 {globalsettings}
    default                 {default}
    resumeobject            {faed968a-8fe5-11e7-b49b-d8cb8a71f683}
    displayorder            {default}
                            {current}
    toolsdisplayorder       {memdiag}
    timeout                 3
    
    Windows Boot Loader
    -------------------
    identifier              {default}
    device                  partition=\Device\HarddiskVolume5
    path                    \Windows\system32\winload.efi
    description             Windows 10
    locale                  en-us
    inherit                 {bootloadersettings}
    isolatedcontext         Yes
    allowedinmemorysettings 0x15000075
    osdevice                partition=\Device\HarddiskVolume5
    systemroot              \Windows
    resumeobject            {faed968a-8fe5-11e7-b49b-d8cb8a71f683}
    nx                      OptIn
    bootmenupolicy          Standard
    
    Windows Boot Loader
    -------------------
    identifier              {current}
    device                  partition=C:
    path                    \Windows\system32\winload.efi
    description             Windows 10 Office
    locale                  en-US
    inherit                 {bootloadersettings}
    recoverysequence        {faed9688-8fe5-11e7-b49b-d8cb8a71f683}
    displaymessageoverride  Recovery
    recoveryenabled         Yes
    isolatedcontext         Yes
    allowedinmemorysettings 0x15000075
    osdevice                partition=C:
    systemroot              \Windows
    resumeobject            {faed9685-8fe5-11e7-b49b-d8cb8a71f683}
    nx                      OptIn
    bootmenupolicy          Standard
    
    C:\Windows\system32>
      My ComputerSystem Spec
  9.    02 Sep 2017 #19
    Join Date : Jul 2015
    Posts : 9,336
    Windows 10 Pro

    So, interesting develop. Before I did the clean install, my recovery environment was broken too. So, I wiped my SSD with the exception of my old OS partition which was at the very end of the SSD (called Windows 10 in the BCD above). I then did a complete new install to the unallocated space, and named it Windows 10 Office in the above BCD.

    I got a brand new EFI System Partition and Recovery Partition. So then I added the Windows 10 entry to the BCD using the BCDBOOT command. My recovery environment works just fine in the new Windows 10 Office installation, but it is still completely broke in the Windows 10 previous installation. I think it has something to do with the extra entries you see above in the Windows 10 Office section of the BCD that are not present in the Windows 10 section of the BCD.

    I'm not that proficient with the workings of the BCD to fix it at this point :-(
      My ComputerSystem Spec
  10.    02 Sep 2017 #20
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,943
    Win 10 Pro (1703)
    Thread Starter

    What you're seeing is not dissimilar to my experience - when I clean installed recovery options were fine- overwriting C: partition and running Fixboot (to get the system to boot) => them not being present at all. Reselecting the Recovery partition gave the list of options, but non-functional.

    Your Boot manager has two entries in Displayorder - corresponding to two OS 10's presumably. Fine.
    My default is just {current}, presumably as you'd expect.
    So nothing to note under Boot manager (I think).

    Your 2nd Boot loader (.... Office) is the one with a working recovery environment, and has 3 extra entries as you noted (16 total).
    Mine has 15... different again. The one missing is displaymessageoverride

    I also now can't successfully set the recovery partition - the command completes, but the field is blank. (reagentc /info)

    reagentc /enable
    REAGENTC.EXE: Unable to update Boot Configuration Data.

    My Windows Boot loader shows recoveryenabled = yes but reagentc shows RE status as disabled.

    Quite a mess... I'm wondering about checking the id fields - the long strings.
      My ComputerSystem Spec

 
Page 2 of 3 FirstFirst 123 LastLast


Similar Threads
Thread Forum
Unknown symbol has appeared after update to win10 creator edition
The symbol showing on the left of this image 135325 has started appearing on open windows since I updated to the creators edition. If I click it, the following is all that happens: 135326 Does anyone know what or why this is?:confused:
General Support
Windows 10 keep restarting! Recovery fail
So i have decided to restart my whole pc just to remove my old files after i do that and the windows startet to inistal i get an error about the inistalation so i had an option to restart my pc or to turn it of! so i turn it off and now its keep...
Installation and Upgrade
Will New Windows 10 upgrade reset all functions to defaults
I am still having problems with PC freezing up at various times. I did receive help from NavyLCDR and AndreTen, but I am wondering if that the Windows 10 upgrade coming at the end of July will reset things and fix my problem or will it save all the...
Windows Updates and Activation
Solved Recovery disk. What functions will it perform?
Hi, Just curious. I created a recovery disk on a 32 GB flash drive that included the system files and has 17.2 GB of used space. What functions can I perform with this disk? E. G., Clean install? Refresh/reset? I'm wondering if the USB stick that...
Installation and Upgrade
Upgrade to 10 from 8.1 64-bit basic functions no longer functional
Good Wednesday morning - The actual upgrade process went completely smooth, without a hitch. HOWEVER, after restarting the now upgraded Windows 10 environment does not allow for basic functions such as taskbar, web browsing, right-click desktop,...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:02.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums