Windows 10: WinInet Broker and Cache servers issue at startup


  1. Posts : 71
    Win 10 Pro 64-bit [1803]
       17 Aug 2017 #1

    WinInet Broker and Cache servers issue at startup


    Since a couple of weeks I've been nagged by the error screens on the Distributed COM errors. After examining Even Viewer it's clear it refers to the WinInet Broker Server and WinInet Cache server instances. The errors are well-known 10010 errors saying: The server {xxxxx} did not register with DCOM within the required timeout.

    The problem is that the standard solution recommended on many forums (and which in fact I've already successfully used in the past) doesn't work. The solution involves granting additional permissions in the DCOM Configuration Editor. In my case I've added all recommended permissions and when it failed to have any effect I've added virtually any user/service I could find to have the right to launch those. Yet, I'm still obtaining those errors at the startup... It takes about 7-8 errors related to WinInet Broker and 1-2 related to WinInet Cache.

    Unfortunately I can't really identify the moment in time I've started to receive those issues, so I can't really bind them to any specific application I might have installed.

    Can anyone suggest any further tips on how to investigate the issues source and how to get rid of it? Since this is a work laptop I can't really reinstall the OS, but I'm having admin rights, so I can modify it.
      My ComputerSystem Spec

  2.    4 Weeks Ago #2

    I have had this problem. Do you McAfee Endpoint Security installed and required by organization?
      My ComputerSystem Spec


  3. Posts : 71
    Win 10 Pro 64-bit [1803]
    Thread Starter
       4 Weeks Ago #3

    Yes, this is very true! My company uses a full McAfee package, including disk encryption as well.
      My ComputerSystem Spec


 

Related Threads
I want to disable my hard drives write cache to protect my machine in the event of a power failure, ie me having to to a hard reboot when it has frozen up. However I notice it keeps being re-enable at start-up. Any idea on how to fix it? ...
WSReset purge cache issue in Software and Apps
Here's my setup. I have three accounts, a local admin, an MS account, and a local standard user. I can't run Windows Store properly on my MS account, while it runs fine on the local standard user. A window just briefly flashes before closing. I...
Hi folks If you have a domain hosted by a hosting service with their DNS servers how do you clear the cache after a DNS update on their server. DNS update has been registered, active and works with PING. After update etc - and the update has...
My computer just shut off on my, and once i turned it back on it said that i had a missing shell32.dll and WININET.dll file. I was never messing with any files, just playing a video game. I cant open anything besides documents. I tried looking stuff...
Hello, when I connect to VPN, I receive DNS servers, but windows primarily uses DNS servers configured on my LAN connection (checked with nslookup). This is problem when I am accessing same hostname, which has internal IP in VPN. I tried to...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:51.
Find Us