1.    13 Aug 2017 #1
    Join Date : Aug 2017
    Posts : 4
    Windows 10 Pro

    Exporting registry with regedit "hangs"


    I have recently noticed that exporting my registry "hangs" forever. I did a little investigation and found that there appears to be a looping entry into the exported registry keys:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{14654CA6-5711-491D-B89A-58E571679951}\KlifTmp02918B99\KlifTmp194DED95\KlifTmp1ECF62D3\KlifTmp792EFA24\KlifTmp2E0756F6\KlifTm p7E0D8DE7\KlifTmp3B927D69\KlifTmp70F1FB9A]@="Microsoft TBAuth Single-Sign On Protocol"[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{14654CA6-5711-491D-B89A-58E571679951}\KlifTmp02918B99\KlifTmp194DED95\KlifTmp1ECF62D3\KlifTmp792EFA24\KlifTmp2E0756F6\KlifTm p7E0D8DE7\KlifTmp3B927D69\KlifTmp70F1FB9A\InProcServer32]@="C:\\Windows\\System32\\tbauth.dll""ThreadingModel"="Apartment"

    This repeats over and over.

    Running Windows 10 Pro
      My ComputerSystem Spec
  2.    14 Aug 2017 #2
    Join Date : May 2015
    Central IL
    Posts : 4,247
    Mac OS Sierra

    Have you tried using Hiren's Boot Disc or the Reg.exe Command tool?
      My ComputerSystem Spec
  3.    14 Aug 2017 #3
    Join Date : Aug 2017
    Posts : 4
    Windows 10 Pro
    Thread Starter

    Good morning bro67. I did try the reg.exe command. HKEY_LOCAL_MACHINE hangs in that utility also. I will check out Hiren's boot disc.

    I have been reading that the most recent Windows 10 update broke the "find" and "export" regedit commands due to limiting registry keys to 255 bytes. I'm hoping a fix from Microsoft will come soon
      My ComputerSystem Spec
  4.    14 Aug 2017 #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,010
    Win 10 Pro (1703)

    Hi, which is your Windows build?
    (Windows key + R, winver).
    This used to be a problem in 1511 I think - that's very old.

    Note 'latest update' means quite different things to different people, given the different builds they are on and that updates are not delivered everywhere simultaneously.

    See the News section where there is a thread per update. You can check for experience with your particular update there.

    Otherwise:

    Try a different registry editor e.g.
    https://www.oo-software.com/en/ooregeditor
    (freeware)
    Click image for larger version. 

Name:	1.jpg 
Views:	1 
Size:	114.6 KB 
ID:	148803
      My ComputerSystem Spec
  5.    14 Aug 2017 #5
    Join Date : Aug 2017
    Posts : 4
    Windows 10 Pro
    Thread Starter

    Hello dalcina,

    My Windows 10 Pro version is 1703 (OS Build 15063.540).

    I did try the OOReg Editor. It hangs in the same way (i.e. keeps re-writing the same pair of registry keys into the export file - over and over).

    I am trying to determine if I have a Windows-related issue or if a virus or rogue program wrote things in the registry causing this.

    Thanks
      My ComputerSystem Spec
  6.    14 Aug 2017 #6
    Join Date : Oct 2014
    Arnold, MD
    Posts : 29,025
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)

    Try some clean-up first. Then re-boot and see if it still hangs on you. Copy and paste the following code into an Admin Command prompt. It will run about 20 minutes or so. Re-boot when it finishes, the try your export.

    fsutil resource setautoreset true c:\&fsutil usn deletejournal /d /n c:&Dism.exe /online /Cleanup-Image /StartComponentCleanup&sfc /scannow&Dism.exe /Online /Cleanup-Image /RestoreHealth&sfc /scannow&Dism.exe /Online /Cleanup-Image /StartComponentCleanup /ResetBase&pause
      My ComputersSystem Spec
  7.    17 Aug 2017 #7
    Join Date : Aug 2017
    Posts : 4
    Windows 10 Pro
    Thread Starter

    f14tomcat, I tried as you prescribed. No Joy. But on the bright side, I did learn a lot about some advanced Windows commands :-)
      My ComputerSystem Spec
  8.    17 Aug 2017 #8
    Join Date : Oct 2014
    Arnold, MD
    Posts : 29,025
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)

    Quote Originally Posted by deepprpl View Post
    f14tomcat, I tried as you prescribed. No Joy. But on the bright side, I did learn a lot about some advanced Windows commands :-)
    Did you ever run a chkdsk (check for disk errors) to see if maybe there is a funky block or sector that you're hitting, causing Windows to loop? Just to rule it out. At admin command, run this. It will ask to reboot and will run for a while, so go do something else. It's a deep boot-time check-disk with repairs if needed.

    chkdsk C: /f /r /x

    Click image for larger version. 

Name:	image.png 
Views:	1 
Size:	27.1 KB 
ID:	149348
      My ComputersSystem Spec

 


Similar Threads
Thread Forum
Excel 2016 hangs at "Starting" randomly
Hello, I'm facing a weird and unexplained issue with Excel 2016 (part of Office 365). When I am opening a certain XLSX file (which is very simple and only contains a few date-based formulas), Excel simply hangs at "Starting. . .". After...
Software and Apps
Laptop hangs when "Microsoft Account Notification" appeared
Hello, I'm using Windows 10 and when I start up my laptop today, I've noticed that the Microsoft Account notification came out. After that I can't click anything but the mouse is able to move. This is what it says: "Microsoft Account You...
User Accounts and Family Safety
Revo Uninstaller - hangs at "scanning for leftover files"
I'm using Windows 10 on a Lenovo IdeaPad laptop, with Revo Uninstaller installed. I've been using this for a long time and it always hangs for a while on "scanning for leftover files". Tonight I tried using it to uninstall Avira (want to reinstall...
Software and Apps
Computer Occasionally "Hangs" on "Sign Out"
This is a question regarding a computer that intermittently “hangs” at “sign out”. When it hangs, the screen goes black and no commands are possible. The only recovery is to depress and hold the power button. The computer is a laptop Toshiba...
Performance & Maintenance
Workstation hangs at "Applying User Settings"
Hello! My name is Peter, and I'm IT Administrator at Junior High School. One month ago I installed Windows 10 Education on all computers. Everything was fine until today. Today users changed his passwords. Now, when user try to login to the...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 06:00.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums