Page 1 of 2 12 LastLast
  1.    20 Jul 2017 #1
    Join Date : Aug 2016
    Posts : 34
    Windows 10 Pro x64

    Start Menu programs broken (clicking on them doesn't do anything)


    Hello,

    Here's the situation:

    1. I start my PC, and get to the desktop.
    2. I press the Win key, which opens up the Start menu, then type in (to search), say, Discord. It finds "Discord" for "Best match", and it's a "Desktop app". That's normal so far.
    3. I click on Discord, nothing happens.
    4. I type in Settings instead, and it finds "Settings" as a "Trusted Windows store app". However, the thumbnail looks broken and again, it doesn't open if I click on it. This is the case with many entries in Start menu. Something like Apps & Features, if I search for that, it runs just fine.

    Now, here's the odd part: creating another user account fixes this. I can run Settings just fine,
    I think this is what I did before that borked it: used CCleaner, deleted iconcache.db files, and deleted TileDataLayer folder. One of these must have broken it, don't know which one specifically though. I routinely use CCleaner, and what I noticed is that at some point I couldn't run CCleaner like I couldn't run the programs above, by searching for it. It just did nothing.
    So, what I ended up doing is deleting the files and folder mentioned above, which is probably what made it worse and now I can't even run Settings, Discord, Chrome, etc, off the start menu and I have to either go to where the programs are or launch them off my desktop.
    I've tried a few solutions but none worked (incidentally that's what borked it even further: I did the iconcache and TileDataLayer thing because I found that as a solution online, and it's probably what broke the other apps).
    Please assist me if you can, this issue is bugging me and the only workaround I have is to create another user account but if I can just fix this user account I would much prefer it, as I did so much on it and it would take me a very long time to change the other user as well.

    Thank you!
      My ComputerSystem Spec
  2.    20 Jul 2017 #2
    Join Date : Apr 2017
    Posts : 8,884
    windows 10 professional version 1607 build 14393.969 64 bit

    The most efficient way to fix most of the problems is an in place upgrade repair:
    Repair Install Windows 10 with an In-place Upgrade Windows 10 Installation Upgrade Tutorials

    1) find a flash drive that you can format
    2) create a bootable windows 10 iso: Download Windows 10
    3) power on the computer and boot to the desktop
    4) open file explorer
    5) insert the windows 10 iso into any USB drive
    6) click on the usb drive > locate setup or setup.exe > launch it
    7) choose language, time, currency, keyboard
    8) do not click install
    9) look in the lower left and click on repair your computer
    10) follow the text and images to preform an in place upgrade repair and keep files and applications.

    If you prefer to troubleshoot you already know that you have a corrupted user account by your success with the new user:
    Open administrative command prompt and type or copy and paste these commands:
    1) sfc /scannow
    2) dism /online /cleanup-image /restorehealth
    3) chkdsk /scan
    4) run through the troubleshooting steps in these links if the above steps did not fix the start menu problems:

    Troubleshoot problems opening the Start menu or Cortana

    https://support.microsoft.com/en-in/...t-menu-cortana
    [How To] Re-register Start Menu In Windows 10 [How To] Re-register Start Menu In Windows 10

    5) if you are comfortable using the registry there are methods to repair a corrupted user. In most cases it is easier to use a new user.
      My ComputerSystem Spec
  3.    20 Jul 2017 #3
    Join Date : Aug 2016
    Posts : 34
    Windows 10 Pro x64
    Thread Starter

    As per instructions, I have attempted to do:

    1. sfc /scannow - no errors.
    2. dism /online /cleanup-image /restorehealth - worked fine.
    3.
    chkdsk /scan - again no issues apparently.
    4. The re-register start menu in Windows 10 command for admin PowerShell from the link provided:
    Get-appxpackage -all *shellexperience* -packagetype bundle |% {add-appxpackage -register -disabledevelopmentmode ($_.installlocation + “\appxmetadata\appxbundlemanifest.xml”)} - does not do anything whatsoever it seems. It doesn't say that it's an invalid command or whatever, but it's instantly done and nothing pops up in PowerShell (other than it waiting for me to put in another command).

    For the "in place upgrade repair and keep files and applications", what exactly do I lose? I'm definitely losing some settings and other stuff, right? I'm just wondering what beforehand.

    In addition to that, when I attempted to create a new user account again, for that one I couldn't even open the Start Menu at all anymore, I don't know why. Also with a new administrator account. So it's even worse for new accounts, I don't know what I did (if I did anything) that broke it there.

    At least for my main account I can open the start menu and a few of the entries there actually work (like Apps & Features, or Device Manager, but not something like Control Panel, my usual programs, etc). I mean when I search for them in the start menu and try to click on them there, not when I look through the list and click on them, that one works fine.

    Also, thanks for your help!
      My ComputerSystem Spec
  4.    20 Jul 2017 #4
    Join Date : Apr 2017
    Posts : 8,884
    windows 10 professional version 1607 build 14393.969 64 bit

    In the link: Repair Install Windows 10 with an In-place Upgrade Windows 10 Installation Upgrade Tutorials
    see the pink section for warning so that you will know what is lost.
    The corrupted user I do not think it will fix. If it does please report that in the thread. It should fix the file problems that your have. Running Ccleaner is something that many of us do on a regular basis. However many of us only use it for the windows and application tabs. So often the registry cleaner works in the short run but over time many people encounter unexpected problems using the registry cleaner. So most suggest only using Ccleaner for windows and applications. And for windows and application there are some boxes that should be unchecked.
      My ComputerSystem Spec
  5.    20 Jul 2017 #5
    Join Date : Aug 2016
    Posts : 34
    Windows 10 Pro x64
    Thread Starter

    Ok, sounds good! I will try it in a bit.
      My ComputerSystem Spec
  6.    20 Jul 2017 #6
    Join Date : Aug 2016
    Posts : 34
    Windows 10 Pro x64
    Thread Starter

    Unfortunately that step also didn't work. Also, what I got was very, very different compared to what was in the guide.

    From step 14, it's already different. It sent me straight to the Windows desktop, no welcome back screen, no personalization settings, etc.

    EDIT: I've caved in and reinstalled Windows, but there still seem to be some Start Menu issues (like some of the installed apps don't show up when I'm searching for them).
    Last edited by RaduAvr; 20 Jul 2017 at 09:21.
      My ComputerSystem Spec
  7.    20 Jul 2017 #7
    Join Date : Apr 2017
    Posts : 8,884
    windows 10 professional version 1607 build 14393.969 64 bit

    What was performed a repair install followed by a clean install?
    Did you delete partitions, format the drive, create an un-allocated driver, install windows 10 version 1703?

    -
      My ComputerSystem Spec
  8.    20 Jul 2017 #8
    Join Date : Aug 2016
    Posts : 34
    Windows 10 Pro x64
    Thread Starter

    Yes, repair followed by clean install.

    Formatted drives, deleted the partitions and put Windows 10 on the USB via the media creation tool.
      My ComputerSystem Spec
  9.    20 Jul 2017 #9
    Join Date : Apr 2017
    Posts : 8,884
    windows 10 professional version 1607 build 14393.969 64 bit

    Quote Originally Posted by RaduAvr View Post
    there still seem to be some Start Menu issues (like some of the installed apps don't show up when I'm searching for them).
    See this link:
    installed program not showing in start menu Solved - Windows 10 Forums

    If there are any more problems after a clean install consider a repeat clean install.

    These are some additional links for start menu problems:

    Fix problems that block programs from being installed or removed: https://support.microsoft.com/en-au/...led-or-removed


    [How To] Re-register Start Menu In Windows 10: [How To] Re-register Start Menu In Windows 10




    Troubleshoot problems opening the Start menu or Cortana: https://support.microsoft.com/en-us/...t-menu-cortana




    http://www.thewindowsclub.com/start-...pen-windows-10
      My ComputerSystem Spec
  10.    21 Jul 2017 #10
    Join Date : Aug 2016
    Posts : 34
    Windows 10 Pro x64
    Thread Starter

    After some troubleshooting, I discovered the culprit.

    It's a program I use that makes Windows less annoying, disables telemetry, etc. It's called O&O ShutUp10.

    I don't know exactly which optimization it does that breaks the start menu search, but something does. After clicking the "reset to factory settings" button in the program and restarting, the installed apps that wouldn't show when searching now appear. I'd love to know which of the options causes those issues so I can disable it.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved How can I remove programs from start menu Programs?
I have a lot of programs installed and have my own toolbars to access them. Seeing all those programs on the Programs list of the start menu is distracting. All I really want is the folders that house subprograms. The only option offered is to...
Software and Apps
Start menu broken - how to recover?
Something happened, I thought perhaps it was a consequence of installing an update. but I did a system restore and the start menu still won't open. I can right click the windows icon 105998 but left-click does nothing. What can I do to...
General Support
A couple of q's - startup programs automatically and broken start menu
Hello, I'm trying to run programs upon boot in W10 but it doesn't work. I have put them in Start folder and if I go to Task manager I can see the programs are there as well in Startup tab and enabled...but they will not start. I have to manually...
Software and Apps
Windows 10 Start-Menu Icons broken ?
Hello community, I just installed Windows 10 and its nice and all, just that the icons in the start menu and the system settings for programs are broken. You dont know what I mean? This is a screenshot: http://prntscr.com/7ygrd5 Hope you can...
General Support
Broken tile images in start menu. How to fix?
Upgraded the home computer this morning (win10 home). All was looking well until all of a sudden Paint.net starting showing half the image and shortly after, the Photos app as well. It only happens if I set the size of the tiles as small. Any idea...
Customization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:45.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums