1.    27 Jun 2017 #1
    Join Date : Jun 2017
    Posts : 3
    Windows 10 Pro 64-bit

    Taskbar locks on startup, unrecognised warning message


    Lenovo V110 laptop, Windows 10 Pro 64-bit
    Intel i5 6200U @ 2.30GHz
    Lenovo motherboard V110-15ISK (U3E1)
    Intel HD Graphics 520

    Hello, I have a laptop problem and I have been unable to find any information online about the situation.

    After a normal startup, the taskbar is live for a few seconds, but then hangs, with the wait circle running continuously. Using the keyboard I can start some functions, eg run the Task Manager. However, using my network I can access the laptop from my desktop and it appears to be running normally. For example, I can backup or transfer files. The problem is access using the taskbar.

    After about 10 minutes, a warning message appears. The label is "NLib" and the message is "Failed Splash LoadFromResource : ResName: IMG_SPLASH, ResType: IMAGE". There is an OK button to close the message. I have not been able to find this message discussed anywhere online. I cannot find any files or register entries on the laptop that refer to "NLib".

    As soon as this message appears, the taskbar comes live and everything appears to be available. Applications try to open but in most cases I get warnings that they cannot start. For example I can open Word but it cannot open any documents. Some applications do run normally, for example my uninstaller has allowed me to remove some recently installed applications that I thought might have been causing the problem. Their removal did not help however.

    I have not been able to restore using a restore point. Sadly, although I have System Restore set to routinely create restore points, I found that the maximum usage was set to 0 GB! (An interesting lesson for the future.)

    Any suggestions please?
      My ComputerSystem Spec
  2.    27 Jun 2017 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,055
    Win 10 Pro (1703)

    Hi, what happens
    a. if you do a clean boot?
    Perform a Clean Boot in Windows 10 to Troubleshoot Software Conflicts Windows 10 Performance Maintenance Tutorials
    part 1

    b. If you still have the same problem, then what happens if you boot to Safe Mode

    c. If the same problem in both, what happens if you create a new user for test purposes and log in as that user?

    Do these references mean anything to you?
    NLib - Home
    NLib - Solid Modeling Solutions

    History: what happened that might have led to this problem? For example:
    I switched my laptop on this morning and saw... it was fine yesterday...
      My ComputerSystem Spec
  3.    28 Jun 2017 #3
    Join Date : Jun 2017
    Posts : 3
    Windows 10 Pro 64-bit
    Thread Starter

    Thank you very much for your suggestions.

    I have made some progress with this but my problem is still ongoing.

    I tried both the clean boot and the safe boot. I was unable to draw any conclusions as the problem persisted. After the clean boot, the warning message did not appear and the taskbar was even less responsive. After the safe boot, the task bar did not appear and some programs would not run at all.

    I also ran full Malwarebytes and Kaspersky scans, but no errors were found.

    I have not been able to create another user - trying to open Settings locks the taskbar again, and in Control Panel/User Accounts, it just hangs if I try to create a new user.

    I contacted the support desks of both developers with products using the name Nlib or NLib. The first, SMLib, said it could not be their product as it does not output such a message and it has nothing to do with images. The second, CodePlex, does appear to be the product that gives the warning message. Some of their projects involve the production of splash pages, so there appeared to be a connection.

    The first application to install automatically when I start the laptop is Ashampoo Snap. It usually opens with a small splash page, so I thought it was suspect. When I tried to start the application, I got another warning message, again with the label "NLib". So this seems to be the application that gave the original warning message.

    To see if the application was actually causing the problem, I uninstalled it, and restarted the laptop. The result was the same, an inactive taskbar, but without the message. Again, after a while, the taskbar became active, but with limited access to applications. The problem is just the same, so the Ashampoo Snap message is a symptom, not the cause.

    It seems to me, therefore, that the problem arises before the computer tries to open applications. Based on the error message that I got when I tried to reinstall Ashampoo Snap, "Setup was unable to create the directory ... Error 5: Access is denied", I think the problem may have to do with permissions. I am the only user and my account is an admin account.

    Just to summarise what the laptop is doing on startup: I log in to my account, the background appears accross my two screens, the taskbar appears, the battery/network/volume icons appear, also the clock (although it doesn't increment). I can open the Task Manager - there are no applications running but the background and Windows processes are listed. (I can provide a list of the running processes if they would help.) I have Classic Start Menu and True Launch Bar installed on my taskbar and they are both inactive initially. After a period of at least 15 minutes, the taskbar becomes active, but many of the applications will either not run at all, or have limited functionality.

    Does all of this give you any further ideas? I am loathe to spend too much time on this - it might be quicker to reinstall Windows 10 and my applications from scratch (although it would take me full day to do it!)
      My ComputerSystem Spec
  4.    28 Jun 2017 #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,055
    Win 10 Pro (1703)

    After the safe boot, the task bar did not appear
    I would say that there's a clue- there's something more fundamental if this doesn't happen in Safe Mode. That makes playing with the much more complicated situation after a clean or normal boot rather a waste of time.

    If you had been in the habit of using disk imaging, as we continually and strongly recommend, you could have restored a disk image of an earlier working state - without technical help- and been up and running again quite quickly (e.g. Macrium Reflect (free) + its boot medium + external storage for image sets). That's a very good way to avoid the time spent on a clean install.

    I suggest your only other option is to use a restore point- if you turned System Restore on, and have any useful restore points.

    As you are getting that very peculiar error message, I am doubtful that doing an in-place repair install would help.

    So if System Restore (which can be started if necessary by booting your PC from a Win 10 bootable disk, for example, via 'Repair your computer' or by SHIFT left click Restart and navigating to S. Restore) doesn't help, I believe you're left with a clean install.

    Once you have your system running again, please consider starting using disk imaging routinely.
      My ComputerSystem Spec
  5.    29 Jun 2017 #5
    Join Date : Jun 2017
    Posts : 3
    Windows 10 Pro 64-bit
    Thread Starter

    Dalchina, thank you for your comments and suggestions. As I mentioned in my original post, I don't have any restore points because the storage was set to nil! I've recently started creating images for my desktop but not yet for the laptop. So, I've got to get on with that.

    Many thanks.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Unusual Message at Startup
Since creators update was installed a couple of days ago, I've been seeing this message on the screen during boot up, "Scanning and repairing drive , (followed by a bunch of things in parentheses), then ending with 100%" Then the machine finishes...
General Support
How do I get rid of popup warning at Firefox startup
Every time I start Firefox (latest edition) to my homepage (Yahoo Mail) I get the attached popup warning window. Have tried abd tried but can't figure out how to get rid of this ? Is there a setting and/or option somewhere that I am missing to...
Browsers and Email
Audio device unrecognised after waking from sleep
From time to time I wake my laptop from sleep and find that the audio driver (Conexant Venice) is no longer loaded. The audio hardware is listed in the Device Manager as just "base system device" (or two base system devices, to be precise)....
Graphic Cards
how to fix warning message on dism log?
hi , to be quick. here some sample: 2015-09-25 05:10:49, Warning DISM DISM Provider Store: PID=2096 TID=4700 Failed to Load the provider: C:\Users\BAYUST~1\AppData\Local\Temp\9F7181ED-2803-42FA-A84C-DF0C2B40864F\PEProvider.dll. -...
General Support
Solved Unrecognised folders under 'user' how to safely delete?
Hello My account is 'Lenovo' all the others i never use, they're all empty. I noticed the folders 'default.migrated' and 'UpdatusUser', i've never seen them before how do i remove them? I'd also like to remove public and the hidden...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:44.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums