1.    26 Jun 2017 #1
    Join Date : Jun 2017
    Posts : 1
    Windows 10 Pro/64 [Version:1607 Build: 14393.1358]

    StartUp folder entries self-delete at each boot


    I have been going nuts all evening (and all night!) trying to create entries in my StartUp folder. This is something that was trivially easy in prior versions (up through Win7), Then, I picked up a new computer at a decent price (cheaper than I could build the equiv.), but, sadly, it arrived with Windows 10 Pro/64 installed. There are a few things that are admittedly nice (such as the ability to have multiple desktops I can easily select), but are in practice, useless (such as the multiple desktops - when are not restored when I reboot, causing several desktops' worth of material to pile up in one desktop).

    Today I hit the mother of all PITA experiences. I struggled to add some items to the StartUp folder. First thing I noticed was that I did not notice the StartUp folder. So, much searching online, and I discovered that there are three of them, all nicely hidden.

    Nice work, MS! The easier they make things, the harder they get. They never heard thtat, "If it works, don't fix it."

    I tried these three locations, two of which can be accessed either via a shell command, or, directly:
    For "my" StartUp folder:

    shell:startup
    or,
    %appdata%\Microsoft\Windows\Start Menu\Programs\Startup
    or,
    C:\Users\[my acct name]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup


    And, for all-users StartUp folder:

    shell:common startup
    or,
    %programdata%\Microsoft\Windows\Start Menu\Programs\Startup

    What happens is that batch files I copy there disappear at boot time -- with one exception!

    That's an entry for VLC -- this is what's in the batch file:

    start /HIGH C:"\Program Files\VideoLAN\VLC\vlc.exe" %1

    That was one of the first "test" entries, possibly the first, I can't recall (burnout sucks).

    I tried copying the files, moving the files, no difference. Although, possibly unrelated, very frequently I would get a strange roadblock of an error when trying to copy a second file. The first time, I'd get a warning that I needed to give it Administrator permission (even though I'm using an Administrative account), but trying to copy another file, I'd first get that notice -- and after I'd OK'd it, I'd get another warning, this time saying I needed "permission" -- that was it, just "permission" with no hint as to what permission. It would allow me to retry, or cancel, and it stayed in that strange state until I'd reboot the machine.

    I spelunked the Registry, the only thing I found that made me go "Hmm..." were the entries in:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\StartupApproved\StartupFolder

    There were two entries: one for the "Start - VLC.bat" file, and another for "Start - VLC2.bat" which I manually created (copying the binary data for the entry).

    That copy did persist from boot to boot -- but, if I edited the batch file to run a different program, it would self-delete at runtime.

    Also strange: before any of these entries would self-delete, they would run the programs (or load the folders or text files as they were expected to load) -- but, they would then terminate the programs, files, and folders before self-deleting the batch files!

    I've never seen anything like this, and from all the searching I've done, scant few others have too. And, it "should" work as it had up through Win7, i.e., put it in the StartUp folder and it'll start at boot time -- each boot time. A glorious GUI-matic "autoexec.bat" surrogate. Well, even autoexec.bat was easier than this nightmare!

    I ran Windows Update, I ran SFC/SCANNOW, I bashed my head against the wall -- nothing helped (except that it felt good when I stopped bashing my head against the wall).

    So, after "the above" I am now officially at my wits end. Does anyone know what I'm doing wrong -- or, what MS has done wrong, but how I can work around it?

    I hate begging, but... I'm begging!
      My ComputerSystem Spec
  2.    26 Jun 2017 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,934
    Win 10 Pro (1703)

    Hi, there is a really easy way to deal with this: install Classic Shell start menu (free).

    This
    a. exposes the Startup folder so you can deal with it by drag 'n drop
    b. properly handles deep nested start menus (several levels of folders) - the Win 10 menu strips away all folders below about the 3rd level down and lists the shortcuts from them (think
    Help
    Help
    Help
    .... )

    - all from different programs.
    c. allows you to manipulate the menu easily in a familiar and intuitive way
    d. provides better and flexible search options (you can't turn web search off and takes more clicks to do a partial search of files and folders in Win 10's)
    e. you can still launch Win 10's with a hot key.

    Now, you can use Classic shell just to manipulate the start menu, then close it, then continue using Win 10's.

    Or you might just decide you prefer its flexibility and ease of use.
      My ComputerSystem Spec
  3.    26 Jun 2017 #3
    Join Date : Jul 2015
    Posts : 3,694
    10 Pro

    Quote Originally Posted by eutectic View Post
    So, much searching online, and I discovered that there are three of them, all nicely hidden.
    There are more than 3 - there is this lot as well
    Code:
    HKCU\Software\Microsoft\Windows\CurrentVersion\Run
    
    HKCU\Software\Microsoft\Windows\CurrentVersion\RunOnce
    
    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\StartupApproved\Run
    
    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\StartupApproved\Run32
    
    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\StartupApproved\StartupFolder
    It depends which users and when in the boot process you want them no run. I stick with shell:common startup or shell:startup generally.

    Quote Originally Posted by eutectic View Post
    I'd get another warning, this time saying I needed "permission" -- that was it, just "permission" with no hint as to what permission.
    I have these permissions - basically Administrators full control and everyone read/execute. I doubt it is your problem if they are running once though.
    Code:
    PS C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup> icacls '.\Divinity - Original Sin Enhanced Edition.lnk'
    .\Divinity - Original Sin Enhanced Edition.lnk S-1-5-21-2885466168-1308911243-2206185695-1000:(I)(DE,DC)
                                                   MACBOOK\Hali:(I)(DE,DC)
                                                   MACBOOK\Administrator:(I)(DE,DC)
                                                   NT AUTHORITY\SYSTEM:(I)(F)
                                                   BUILTIN\Administrators:(I)(F)
                                                   BUILTIN\Users:(I)(RX)
                                                   Everyone:(I)(RX)
    
    Successfully processed 1 files; Failed processing 0 files
    PS C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup>
    I've only tried putting shortcuts in startup folder. Does it delete shortcuts to you bat files if you do that?
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
I need to delete some WinSXS folder entries
I need to delete some WinSXS folder entries, no questions asked. How do I do that? Taking ownership and rights isn't enough it seems. The last won't work on all folders inside WinSXS. I keep getting errors when applying rights for my username...
Performance & Maintenance
Unable to delete a folder - Invalid folder name
Unable to delete a folder on an external USB HDD. Tried with take ownership. Tried Takedown, and some options on Owner of Files and Folders - Change in Windows 10 - Windows 10 Forums I booted from USB (WinPE/Paragon) and accessed command...
Performance & Maintenance
How to remove entries from current boot menu
I have the following entries in my system start up: Windows 10 Windows 10 Windows 7 How do I remove the last two entries so startup just shows one Windows 10 only or just boots right into Windows 10 without a start screen ? ...
Installation and Upgrade
Windows 10 opens folder at boot; msconfig stuck at selective startup
1. If I try to select normal startup in msconfig.exe, it doesn't stick; always reverts to selective startup. 2. When I boot to the Windows 10 desktop, it always opens a Windows Explorer window at /windows/system/ which shows only a Speech folder...
General Support
Solved Cannot restore startup entries after Windows 10 upgrade
I did two upgrades - one 10 home x86 and the other 10 home x64 - and they completed without error. The only issue I'm seeing on both of them is I can't re-enable a number of auto-starting items that I disabled before running the upgrade. I used...
Backup and Restore
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 03:37.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums