Windows 10: I have met my match "file name is not valid" and "no more files"

Page 1 of 3 123 LastLast

  1. Posts : 11
    Windows 10 Pro x64
       22 Jun 2017 #1

    I have met my match "file name is not valid" and "no more files"


    I'm generally pretty self sufficient on Windows, and have gone 9 years on the same laptop (an Asus M50VM-A1) without issue. Until now.

    I am receiving "the file name is not valid" and/or "there are no more files" errors any time I try to Save As any document type from any program: a TXT from Notepad, a PNG from Edge, a PDF from Chrome. You name it. So I cannot save any new files. However, resaving old files still works.

    Here's what has me stumped:
    -Full scans of Malwarebytes and Norton 360 (with all updates) show no issues.
    -Windows is fully updated.
    -SFC /scannow always shows that "there are some files that could not be repaired", even when run in all 3 safe modes. However my laptop has ALWAYS reported this with SFC, with no issues till now.
    -A full system restore to a date before I was still able to Save As, had no effect.
    -Neither did disabling internet connectivity, defragmenting, cleaning the C: drive, etc. Of course, I didn't expect them to.
    -In the safe modes, I am able to Save As. I cannot in normal mode, or with a clean boot. This seems to indicate to me an MS problem.
    -Shutting off Norton's antivirus and firewall has no effect. Neither does Norton Autofix, stopping the Asus Security Data Manager (ASDM) service, or moving the ASDM program folder so it cannot be executed. (Other forums suggested this program could be the culprit.)
    -I've even tried going through Task Manager and shutting down as many programs and services as possible. No effect.
    -I have no other security software other than the aforementioned, and have not installed anything new recently. However, C++ Runtime 2015 shows a recent installation.

    The only possible culprits I can think of:
    (1) I ran CCleaner's registry cleaner recently. But I have done that for years and have never had a problem before, and none of the keys it removed appeared to be Windows-related.
    (2) I think this started happening right after MS released the major security updates across all recent platforms, even XP. But wouldn't the System Restore have rolled those back?

    Help? - and thanks in advance.
    Last edited by jtrevor99; 22 Jun 2017 at 00:54. Reason: Adding a few more things I've tried
      My ComputerSystem Spec

  2.    22 Jun 2017 #2

    Hi, please see:
    Save as .....There are no more files - Windows 10 Forums

    Asus related- you have an ASUS laptop.

    9 years- wow. My Asus lasted 2.5, and I had a MBO failure in warranty, and the same symptom when it died.

    SFC /scannow always shows that "there are some files that could not be repaired"
    In build 1511 (November update) there was a long-standing bug where an Nvidia file Opencl.dll was always flagged. But hopefully your build is more recent than that. You can gain more by examining the CBS.LOG of course.
      My ComputerSystem Spec


  3. Posts : 11
    Windows 10 Pro x64
    Thread Starter
       22 Jun 2017 #3

    I'll be darned, I did a search and that thread didn't come up. But I'm on my phone right now so probably just didn't see it. Thanks.

    I'll read through and try the suggestions in the morning!

    And yeah, 9 years - it's been through a LOT too. Dropped 4+ feet onto hard surfaces 3 times, dropped into a puddle of water while running, at least one power surge, a defective replacement battery, and the touchpad keys and parts of the case have physically broken. Really amazing it's still going - they have my business again when it finally dies.
      My ComputerSystem Spec

  4.    22 Jun 2017 #4

    I had the slight advantage I recalled having seen the problem listed briefly- I just searched by "there are no more files". But you just can't always rely on searching with exactly matching text. (My current laptop - by a good company- does happen to have an ASUS MBO I discovered...but unusually these days most of the back comes off, + good ventilation, and 3 year warranty).
      My ComputerSystem Spec


  5. Posts : 11
    Windows 10 Pro x64
    Thread Starter
       22 Jun 2017 #5

    Now that I've had a chance to read that thread: I'm sorry to say I had already seen it.

    Stopping the ADSM service on my machine, switching it to manual start, and then rebooting had no effect. I do not have the option to uninstall (uninstall is grayed out in the application list, even when in Safe Mode, and CCleaner etc. do not see it); and moving the ADSM program folder to another location - which ought to keep it from starting - also had no effect. And I cannot download and run Revo Uninstaller, because it is not possible to "save", "save as" or "save and run" the application.

    Any other ideas?
      My ComputerSystem Spec


  6. Posts : 4,509
    10 Home x64 (1709) (10 Pro on 2nd pc)
       22 Jun 2017 #6

    jtrevor99 said: View Post
    Stopping the ADSM service on my machine, switching it to manual start, and then rebooting had no effect...
    Any other ideas?
    Set the service to 'Disabled' instead.
      My ComputersSystem Spec


  7. Posts : 11
    Windows 10 Pro x64
    Thread Starter
       22 Jun 2017 #7

    Just tried it...no effect after reboot...
      My ComputerSystem Spec

  8.    22 Jun 2017 #8

    If you read that thread through it goes on to uninstalling the thing.

    See e.g. #20.
      My ComputerSystem Spec


  9. Posts : 11
    Windows 10 Pro x64
    Thread Starter
       22 Jun 2017 #9

    Yes, but as I stated above I am currently unable to uninstall. The option is grayed out for me in the app list, and I cannot download Revo or any other program.

    May try downloading Revo on a work computer then running from an SD or USB.
      My ComputerSystem Spec

  10.    22 Jun 2017 #10

    Revo Uninstaller Portable Download

    Here's a portable version- no installation. Never tried the portable version myself..

    But reading your post again after your comment suggests you have more and deeper issues. Anyway, start by trying to uninstall that program.

    What is your Windows version?
    Windows key + R, winver
      My ComputerSystem Spec


 
Page 1 of 3 123 LastLast

Related Threads
I've got an error at the moment that whenever I try and use the file dialog (e.g. save a new file, open a file, attach file to email etc), whatever application I'm using will crash. This seems to have started ever since the Windows 10 Creator...
One of our Win10 laptops has a context menu with "Properties" that uses shortcut key "r". The other uses key "o" which conflicts with "open". I have no idea how it got corrupted. Suggested locations in the registry for context menu doesn't list it....
So, there's a location in File Explorer on Windows 10 you can go to called "Network." In this place, you can go to your router properties, and change some settings. Originally, a "General" tab was appearing in these router properties, and you could...
Hi all, I have been searching the web for an answer to this question since first getting Windows 10 last year. I would like my File Explorer to open using the "List" view rather than the current default of "Details". I have seen many responses...
Hi, as with many I have upgraded to Windows 10 today and it is going well except for the fact I am unable to save any files or create new ones in the Documents and Pictures folders or any sub-folders within these folders, and I have no idea why it...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:16.
Find Us