1.    18 Jun 2017 #1
    Join Date : Jun 2017
    Posts : 2
    Windows 10 Creators

    Internal file transfer issue within MTP device connected to PC


    Hi

    I hope you may be able to help with this issue.

    I have had a Sansa Clip Zip 8GB mp3 player for several years now and it has always worked well for me. I prefer to manage and listen to my music with the player in MTP mode, which gives me the capacity to jump between playlists as I wish.

    To add new music to the player, I connect the player to the PC, where it is recognised as an MTP device, transfer the new music file or folder into the 'Music' folder, right click on the new file or folder to 'Create Playlist' and then cut and paste the resultant .pla file into the 'Playlist folder. The device does not recognise the .pla file unless it is inside the Playlist folder. This has worked well for as long as I have had the player, the last 3-4 years.

    Just recently though, a problem has arisen. My PC continues to recognise the player as an MTP device when I connect it, no issue there. And there is still no issue in copying any file from my PC into the Music folder within the player's folder structure. Or copying any file on the player back to my PC. But it is no longer possible to copy a file from one folder to another within the Player's structure - e.g. copy a playlist file from the Music folder to the Playlist folder. In fact, after experimenting further, it is not an issue of file type. It is no longer possible to transfer any file type between any folder - Music, Playlist, Podcast etc. - within the mp3 player's file structure.

    So I can transfer files from an external source and to an external source, but not within the player itself. This removes the easy facility to create a playlist file within the Music folder and move it into the Playlist folder.

    There is a somewhat ponderous workaround. I can, for example, create a .pla Playlist file within the Music folder, cut and paste the .pla file onto the PC Desktop, then cut it paste it back again into the Playlist folder. This restores the functionality that I want and need to use the player as I wish, but it's frustrating to suddenly have to add two extra steps to the process when everything worked perfectly before.

    A couple of other points, which I think are a pointer to what may be going on. It may be a co-incidence, but the problem arose just around the time I updated the PC to the new Windows 10 Creators. Things worked fine previously in all earlier versions of Windows 10. And I just tested the mp3 Player on my old Windows 7 set-up, and everything works as it always did there. There is something going on within the latest version of Windows 10 which is no longer allowing internal files transfers within the MTP device.

    Just to be sure that I have covered all the bases, I have formatted the mp3 player and reinstalled the latest firmware - no effect. I have restored the player to default settings - no effect. And I have confirmed that I am running the up-to-date driver for the player. I have established that everything works fine within Windows 7, and did so within Windows 8 and earlier versions of Windows 10 as well.

    I am running a HP Pavilion Notebook PC, with 8GB of RAM. The System Summary on the PC tells me that I am running Windows Version 10.0.15063 Build 15063.

    Appreciate any thoughts on how I might get around this issue.

    Cheers
      My ComputerSystem Spec
  2.    18 Jun 2017 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,113
    Windows 10 Pro Build 1703

    Hi peterprog. Welcome to the Tenforums @peterprog

    If you hold the Windows key down + R, type Winver, enter

    you will get the Version and build #. Your version is 1703 and you will get a build number 15063.xxx. 413 or 414 are the latest build.

    https://support.microsoft.com/en-us/help/4018124

    Are you getting any kind of error message? Is any thing being recorded in the event viewer in any of the logs either as Information or warning item?

    When you google MTP issues seems lots of people are having issues but the issues listed are more along the lines "it doesn't work". Yours works apart from the lack of functionality around moving files on device.

    There is this thread on our forum

    Media Transfer Protocol Device (MTP Device) support for Windows 10 N

    Which talks to Media Transfer Protocol and solution 7 in this link. (Please don't run ReImagePlus in this link.)

    http://windowsreport.com/media-trans...l-not-working/

    Again these were for MTP not working. By chance is the Windows Media player installed in your build?


    Ken
      My ComputerSystem Spec
  3.    19 Jun 2017 #3
    Join Date : Jun 2017
    Posts : 2
    Windows 10 Creators
    Thread Starter

    Many thanks for getting back to me Ken.

    I followed your suggestions - I'm running Build 413. There are no error messages appearing in Event Viewer either.

    I found that I had Windows Media Player installed (though I don't use it). So I uninstalled it, but the problem persisted.

    I then looked at Solution 7 in the link. I didn't install the Media Feature Pack as I had just removed Windows Media Player, but I did download and install the Media Transfer Protocol Porting Kit. But again, it didn't resolve the issue unfortunately.

    Fortunately, I do have a workaround, even if it adds a couple of steps to the process. And if, as I suspect, it is a Creators Update issue, it might be resolved in a future update.

    In the meantime, grateful if you think there are any other solutions I might try.

    Thanks again for your response.
      My ComputerSystem Spec
  4.    19 Jun 2017 #4
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,113
    Windows 10 Pro Build 1703

    Thought we might have been on to something. Good luck and I will post back if I find something.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
0xc000000f a required device is not connected
Hey Everyone, Unfortunately I do have to start by saying I am unable to provide the stuff from logs and everything, as I can't even boot up at the moment. I'm attempting to use my original Windows 7 installation disk to downgrade from 10 to 7...
BSOD Crashes and Debugging
Solved Media Transfer Protocol Device (MTP Device) support for Windows 10 N
Hey everyone, I'm using Windows 10 N Anniversary Update, the one with no media bloatware like WMP. However I wish my iPhone was accessible with File Explorer to copy photos. It turns out you have to install Media Feature Pack for Windows 10 N...
Drivers and Hardware
Solved VERY Slow transfer rates between separate internal HDD's
I've got a 2Tb disk which is almost full. I'm trying to copy the contents to a 3Tb disk, however, i'm getting ridiculously slow transfer rates. I've tried cloning, and it gives me estimated completion of cloning of over 30 days. I've tried...
Performance & Maintenance
Wifi turns off automatically when a device is connected to my hotspot
Whenever a device is connected to my hotspot the wifi is turning off automatically thereby stopping the hotspot. To turn the Windows 10 hotspot on, in first step I have turned on the Wireless Network Connection as shown in the below image. ...
Network and Sharing
I connected an external display to my laptop now no internal
Hey guys, so i'm running B10074 on my laptop , and I connected my external display to it as well as my external keyboard and mouse at my desk so I could sit there and do the setup etc without moving all of that out of the way. I had the laptop lid...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:21.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums