Windows 10: MSCOMCTL.OCX Not Registered Solved

  1.    15 Jun 2017 #1

    MSCOMCTL.OCX Not Registered


    Ive been trying to install my copy of DVD-RB something ive not used on this Win10 pc since i upgraded from WIN 7

    But when i try to run it i get this message(image attached)

    Ive tried this method from Microsoft but still no joy.
    Look for MSCOMNCTL.OCX in the following: C:\Windows\SysWOW64 directory

    Right click on Command Prompt and select Run As Administrator
    Type the following

    CD C:\Windows\SysWOW64 directory

    Press Enter
    Next Type
    Regsvr32 MSCOMCTL.OCX
    Press Enter
    You should get a message "DllRegisterServer in mscomctl.ocx succeeded"
    Proceed with the installation
    Any help greatly appreciated
    Attached Thumbnails Attached Thumbnails dvd.JPG  
      My ComputerSystem Spec

  2.    15 Jun 2017 #2

    Is the file actually in that folder?
      My ComputerSystem Spec

  3. pepanee's Avatar
    Posts : 1,052
    Windows 10 Professional
       15 Jun 2017 #3

    Did you install "DVD-RB" from Windows 10 or Windows 7?

    If you installed it when you had Windows 7, uninstall it, restart the computer, and re-install it.
    Or did you just try to install it right now, with Windows 10?
      My ComputerSystem Spec

  4.    16 Jun 2017 #4

    @Samuria No the file is not there

    @pepanee This was a fresh install of DVD-RB onto WIN10
      My ComputerSystem Spec

  5.    16 Jun 2017 #5

    If the file isn't there it won't work you need to put the file in that folder it won't work in any other folder
      My ComputerSystem Spec

  6.    16 Jun 2017 #6

    Where do i find that file in order to put it in there?


    Have found it online and all registered and working many thanks
      My ComputerSystem Spec


 

Related Threads
Class Not Registered Error in General Support
Every time I try to open my steam game a get this error http://imgur.com/a/X5QZH. I have a newly installed version of windows 10.
Windows Search stopped working. The event log shows the entry: The Windows Search service terminated with the following service-specific error: Class not registered If I attempt to start the service manually, a MessageBox pops up and tells...
I have an HP Pavilion laptop that came with Win 8.1 installed. Last year, I upgraded it to Win 10, and the upgrade went smoothly, but the HDMI out didn't work any more. Since I use that a lot, and I couldn't find an easy solution for it, I used...
Says Windows 10 is not registered in Installation and Upgrade
Basically I upgraded from 8.1 to Windows 10, and kept everything. Windows 10 registered. I did a clean install through a USB and skipped all the product key requesting screens and now it says that Windows is not registered. A Google search...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:14.
Find Us