1.    30 May 2017 #1

    Cannot add system ENV variable build 1703 - even as admin


    Hi there
    Need to add jdk (Java) into path system ENV variable. (Note needs to be in system path not user one).
    Logged on as admin

    System will allow enter env screen but doesn't save it W10 x-64 pro build 1703..

    Any way round this -- I need jdk to use Eclipse IDE.

    Cheers
    jimbo
      My ComputerSystem Spec
  2.    30 May 2017 #2
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,451
    windows 10

    What's path length have you exceeded it?
      My ComputerSystem Spec
  3.    30 May 2017 #3

    Hi there
    fixed it by using setx in command mode -- seems the GUI doesn't work

    here's what I did in elevated command mode

    setx PATH "C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\ ;C:\Users\jim\AppData\Local\Microsoft\WindowsApps;C:\Program Files\Java\jdk1.8.0_131\bin"

    Working fine now -- run javac command and the java options come up

    Cheers
    jimbo
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved System environment variable won't stick
Running Win10 Home on an Acer Spin 3, 64bit, i7cpu. I try to add a path to the system environment variables by: 1. Control Panel > System > Advanced system settings > Advanced tab > Environment variables 2. The "Environment Variables" window...
General Support
System Path variable length problem
I was having a problem with Apple's SyncServer.exe (part of iTunes). It was choking on the length of my system PATH environment variable (2388 bytes), so I temporarily hacked it below 2047 bytes, and it worked OK. BUT I couldn't use Control...
General Support
i accidently deleted system environment variable path
i accidently deleted the system environment variable path value now i cant run my java or while typing javac in CMD itit shows javac is not recognized as an internal or external command, operable program or batch file." please tell how do i get...
General Support
Programs asking me for system admin and user admin passwords
I'm having some issues with my upgrade to win 10. Programs that need elevated access are now asking me for both the Sys Admin and my local admin password. Of course, the sys admin has no password and my local admin does. So no matter what I...
User Accounts and Family Safety
System error 5 | No admin rights | Lost admin password | can't reset
Hi Yet again, Windows is frustratingly taking up all of my time and I have tried everything google has to offer to try and fix it but it seems like no one has screwed up as much as I have on whatever forum. Let me explain the problem: I'm...
User Accounts and Family Safety
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:04.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums