1.    28 May 2017 #1
    Join Date : Jul 2015
    Posts : 1,596
    Windows 10 Pro (64 bit)

    Cortana search, these results may be incomplete


    So I noticed cortana search is often showing a text at the top saying these results may be incomplete please try in a few minutes. But it never goes away. It didn't used to do this. I reckon only in last week or so. There have been no significant changes. I checked indexing and it is all correct and complete. I have given the pc ample idle time whilst logged in. The thing is it doesn't display this text on every search and as far as is can tell search works properly. It seeks and finds all the files apps documents I need quick as a flash. So it's bizarre really. It only appears if there are options for folders or something like that on the search result which I need to click on to reveal the result. Anyone else get the same? This is an anniversary update pc latest version that hasn't yet been offered creators update. It only seems prevalent on my user account and not the others. However, we don't really use the other user accounts much. All the documents, pics are under mine.

    i have noted that this is not an uncommon issue but most people reporting this don't actually get search results working properly. Mine works, if it wasn't for this text I wouldn't know anything was up
      My ComputerSystem Spec
  2.    29 May 2017 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,017
    Win 10 Pro (1703)

    Hi: example of 1 possible cause/solution:
    Simple solution that worked for me:

    1. Open File Explorer
    2. Go to: "C:\Users\USERNAME\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState \Ind exed\Settings" (change USERNAME in path to whatever your USERNAME is)

    %AppData%\..\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState\Indexed\Settings\

    1. There will most likely be a folder called "en-US", rename it appropriately according to your computer’s language (I renamed it to en-GB) and everything works!

    Settings: (UK - US ok) Solved - Page 2 - Windows 10 Forums
      My ComputerSystem Spec
  3.    29 May 2017 #3
    Join Date : Jul 2015
    Posts : 1,596
    Windows 10 Pro (64 bit)
    Thread Starter

    Thank you. I was encouraged by a possible solution but alas the folder was already en-GB. I guess I'll just grin and bear the issue. Maybe at some point it'll sort itself out. Search actually works fine and that text only manifests itself if I click on folders or music to expand them/drill down into them and even then the results are correct (and it doesn't do it for every search). The initial search never shows the message, always looks fine, it's just if one has to expand a sectionime folders, documents or music by clicking on one.

    I search for reliability history all the time, I always just type 'rel' and that gives me best match but also has 'folders' unexpanded as part of the search hit. In this case I click folders for in depth results and 100% of the time it will show the spinny wheel and text about results being incomplete on that particular search. I wonder how long it has been there as a problem, maybe the last cumulative update for v1607 is the culprit back on may patch tuesday. I have only noticed it in the last week or so because I never used search loads but it could of been there longer. Of course now I test it all the time since noticing. It could even be a server side issue at MS getting itself into the mix.
      My ComputerSystem Spec
  4.    29 May 2017 #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,017
    Win 10 Pro (1703)

    Ok, now you mention folders and music- a bit more detail- I've just tried searching for music - my large music folder is indexed, but I get exactly the same message in Cortana's dialogue box.

    (I use the AU).

    I also note the Music folder is specified as This PC, One Drive - and I don't have One Drive running.
    Just wondering if that might account for it.

    (Way back, this message was usually related to incompletely installing a language pack)
      My ComputerSystem Spec
  5.    29 May 2017 #5
    Join Date : Jul 2015
    Posts : 1,596
    Windows 10 Pro (64 bit)
    Thread Starter

    Ah. So you see it too. I have one drive enabled on mine. The more I think about it I believe MS server side issue might be causing this glitch. It's frustrating !
      My ComputerSystem Spec
  6.    29 May 2017 #6
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,017
    Win 10 Pro (1703)

    No, it's not Onedrive - and it's not the equivalent of a green progress bar (which would have meant Cortana search had been extended to non-indexed locations). There's no disk activity...

    In the CU, a few are seeing an as yet unresolved message *Some settings are managed.... (with a *) - yet no functional problem.

    I'm beginning to think we should no longer expect Windows to be reliable in such matters, and only deal with thing that clearly impinge on us functionally.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Broken search, possibly language related? Cortana incomplete results.
Little help required, because I feel like i've done my fair share of searching what I thought I could fix origianlly.... My search is broken, saying the results may be incomplete, cortana isnt particularly helpful! I've tried rebuilding the...
General Support
Win10 search: “These results may be incomplete”, won't find files
Hello. Windows 10 bugs are driving me insane, I hope some of you can help me. I'm using a 3 months old hp Spectre x360 (early 2016 model) which came preinstalled with Windows 10. It currently has the Anniversary Edition installed. When I try to...
General Support
Cortana using IE not Edge for web search results
Ever since Build 14385 and now in 14388, Cortana has been using and opening IE as the browser for showing search web results instead of Edge. Edge is set as the default browser and has been for a long time. Have checked all the settings in both Edge...
Browsers and Email
W10 Search Broken - These results may be incomplete
Hi. I recently performed a clean upgrade from a clean 8.1 Install of Windows Pro. It's connected to a domain and uses Folder Redirection. The search function finds NO programs or start menu shortcuts, desktop etc. When I click the start...
General Support
Search can't find some files, says "These results may be incomplete"
When I "search my stuff" from the start menu, some files that I know to be indexed never show up in the results. And at the top of the search window, it reads: "These results may be incomplete, search is still indexing your stuff." I've rebuilt...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:56.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums