Page 1 of 2 12 LastLast
  1.    19 May 2017 #1
    Join Date : Apr 2017
    Posts : 30
    Windows 10

    System Drive Hidden - Unable to Unhide - Can't Boot PC - Help Please?


    Hello,

    Using diskpart and list vol my hard drives display and under status they all state healthy. Volume 1 is my boot drive. Under info the boot drive is listed as hidden not system.

    I tried this:

    http://www.justreadout.com/2014/12/h...rive-from.html


    And was unable to unhide the system drive though I could change the letter. I am currently unable to boot this system as the hidden system drive is not appearing under UEFI and if I choose legacy it does appear but doesn't boot.

    How can I unhide the drive and make Windows recognize it as the system drive? I am able to get to a command prompt no problem, as you can see. Thank you!

    Frank
      My ComputerSystem Spec
  2.    21 May 2017 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,035
    Win 10 Pro (1703)

    I suggest you use Macrium Reflect (free)'s boot disk and use their Fix boot utility, assuming your PC was previously booting ok and your disk drive is ok.

    If that doesn't work you could try using a 3rd party partition manager boot disk and boot your PC from that. You may be able to see what's going on more easily.

    What led to this state of affairs? Did your PC suddenly fail to boot? Were you making some partitioning changes? Was your PC booting correctly previously, then stopped after some event or action?

    If all else fails and
    - your disk is ok
    - you have a valid Windows partition

    Create a disk image of your system partitions
    Clean install Win 10
    Replace the Windows partition with that from your image
    Run startup repair
      My ComputerSystem Spec
  3.    21 May 2017 #3
    Join Date : Apr 2017
    Posts : 30
    Windows 10
    Thread Starter

    This is driving me crazy. I'd appreciate any help. I'm new to WIndows 10. I jumped right from Windows 7 (which I knew very well) from an old PC to Windows 10 with a new (to me) pc.

    The Windows 10 pc that I have came with a conventional 1 tb WD drive with no OS installed. The first thing I did was take it out and put in a Samsung 850 EVO SATA M.2 1 TB.

    I never had a need to go to the bios at the time as I just installed Windows 10 right to it from the install DVD I created and all went well without a need to do anything else. Therefore I don't know if the bios was set to legacy or UEFI though I suspect it was set to legacy because at the moment if I set it to UEFI the SSD drive isn't listed as a choice. Right? Wrong?

    If I set the bios to legacy the SSD is listed as a choice but I'm getting the reboot and select proper boot device error, which is also part of the problem here. I'd like to address that issue if possible for that matter.

    If you can help me out at all I'd appreciate it.

    Ideally, what I would like to have occur, is to somehow "fix" this SSD without losing the data even if I have to go through a Rube Goldberg like experience.

    For example, I'd be fine with plugging in that WD drive I mentioned, temp installing Windows 10 to it, and with a full working OS installed attempting to fix whatever is wrong with the SSD drive.

    Would that be an option? I haven't tried yet, but if I pick legacy or UEFI to do that and the original SSD drive that I want to fix had Windows 10 installed the other way would Windows still see it?

    If that is an option can you suggest any programs or anything else that might help fix the SSD drive if I got Windows running temporarily from an alternate drive?

    I also am perfectly willing to try your suggestion but don't quite understand. I get to back up the SSD drive. Clean install Win 10. I'm with you up to that point.

    When you say replace the Windows partition with that from your image are you saying once I clean install Win 10 and get it up and running directly "overlay" the disk image over it (meaning erasing the clean install completely) and then run startup repair once I do that?

    If not can you try and be a little more specific? As I said I'm relatively new to the WIndows 10 environment but greatly appreciate your assistance and would welcome it further. Thank you.
      My ComputerSystem Spec
  4.    21 May 2017 #4
    Join Date : Apr 2017
    Posts : 30
    Windows 10
    Thread Starter

    For about two days I kept getting the blue screen bad pool caller error and instead of seeking help here I decided to fix it myself. This is where the problems started.

    I made a Windows 10 Repair disc not knowing that the original Windows 10 install DVD I had would have worked. I booted it up and tried start up repair and it told me it wasn't successful. Before I did this within Windows 10 I selected the booting from the DVD drive option so it would happen automatically.

    Once I tried to get back into Windows for some reason now the BIOS won't recognize my boot SSD, which is a Samsung 850 EVO 1 TB. It "sees" it in the legacy area, but not in UEFI.

    If I try to boot from it in the legacy area that's when I get the reboot and select proper boot device error.

    The only HD listed for me to choose in the UEFI area is another internal HD that isn't the boot drive. If I select that one all that happens is the repair screen comes up eventually. I don't get the select proper boot device error.

    As I said, when I originally installed Windows 10 to this system I don't know for certain if the bios was set to legacy or UEFI as I didn't look and didn't see a need to at the time. I wasn't even aware of UEFI in general at the time being used to Windows 7.

    All I know is right now under UEFI the SSD isn't listed as an option whether it would have been listed at one time or not and under legacy if I select it I get the reboot and select proper boot device error.

    This is the entire situation. What would you suggest if the objective is to somehow get the SSD working again without losing any data. Again, I am willing to do just about anything.

    Thanks for your help, I greatly appreciate it.
      My ComputerSystem Spec
  5.    21 May 2017 #5
    Join Date : Apr 2017
    Posts : 30
    Windows 10
    Thread Starter

    Update so far.

    I tried this, How to Fix Reboot and Select Proper Boot Device - Appuals.com

    and in diskpart, at the last step, when I typed in active I got the selected disk is not a fixed MBR disk. The active command can only be used on fixed MBR disks.

    Just wondering if that helps to pinpoint my issue any better. Thanks. Trying to give you as much info as possible. I value your time and help.
      My ComputerSystem Spec
  6.    21 May 2017 #6
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,035
    Win 10 Pro (1703)

    Hi, the easiest approach in this somewhat complicated scenario would be to reinstall Win 10 to your SSD, with no other disks connected.

    Now, before you posted here, was your PC running ok with the SSD?

    What would you need to recover from your SSD? Just data? Do you have many programs installed on it? What would you lose by reinstalling?

    What is missing from the story (forgive me if I'm wrong) is - if your PC was running with the SSD, what went wrong to stop it doing so?

    (Leave my suggestion at the end of #2 aside for the moment - we can come back to that).

    diskpart, at the last step, when I typed in active I got the selected disk is not a fixed MBR disk. The active command can only be used on fixed MBR disks.
    - suggests your SSD may be formatted as UEFI/GPT

    Partition layout of your SSD
    So, boot from your Macrium Reflect disk, and we're looking for sthg like this:
    Click image for larger version. 

Name:	Snap 2017-05-21 at 18.20.06.jpg 
Views:	4 
Size:	155.6 KB 
ID:	136036

    Please take a photo of that and post it like a screenshot.

    (As you're unsure whether you created your SSD with legacy or UEFI set, the partition layout should tell me which).
    Last edited by dalchina; 21 May 2017 at 12:22.
      My ComputerSystem Spec
  7.    21 May 2017 #7
    Join Date : Apr 2017
    Posts : 30
    Windows 10
    Thread Starter

    Hi,

    By some miracle I was able to load the Macrium Reboot Disk successfully on the PC. I say that because based on all that's transpired so far the pessimist in me assumed it wouldn't work.

    However it did. For technical reasons I am unable to generate a picture for you but I can accurately describe what I see using your screen shot as a model.

    First I tried the boot repair in Macrium and it didn't work.

    On the Samsung SSD 850 EVO mSata 1 TB there are three partitions where you have five. It is labeled as GPT Disk 1 with a bunch of letters and numbers after it just as in your example, though of course mine are different.

    They are labeled 1 is none, unformatted primary. 128.0MB used and free

    2 is Boot Drive (None) <--- is that significant....the none? , NTFS Primary, 930.95 total, 848.02 used. The graphical bar is RED, not blue. Is that a signal to what the issue might be?

    3 is labeled as none, NTFS primary, 348.9MB used and 450.0 mb total.

    As well, where in your example there are no checks in the boxes in the lower right corner on mine each of the three partitions 1, 2, 3, has a check in the box in the lower right corner.

    Since I was able to get into this program and can, can I possibly get this drive going somehow? I looked very carefully and the only differences I see between your example and what I can see is the number of partitions and that the Boot Drive Primary graphic bar is RED, not blue. The other two, as well as the other HD's present, are all blue.

    Is that a clue? Blue's Clues??

    Lastly, under details for the Boot Drive Partition 2 that has everything on it it states File System NTFS, Free Space 89.92 GB total size 930.95 GB, start sector 264,192 end sector 1,952,600,063
      My ComputerSystem Spec
  8.    21 May 2017 #8
    Join Date : May 2017
    Posts : 4
    Windows 10

    I didn't read the other posts as I'm in quick it mode, but I know gparted is free, x86 and x64 compatible and can unhide stuff. There is something potentially better tho. are you UEFI or BIOS? If you can boot into a PE windows (you can download them - probably better to get Hiren's Boot CD though) then you can run EasyUEFI or EasyBCD - or​ this dude has killer ill wit it type dank memes (no not really) n jazz shizz -- Everyone and there mother should check out this dude, specially dual booters.. literally automatic BCDedit repair click of button, dual boot repair, opps i deleted BCD fixes and all boyans

    EDIT: inclusion of 'or'
      My ComputerSystem Spec
  9.    21 May 2017 #9
    Join Date : Apr 2017
    Posts : 30
    Windows 10
    Thread Starter

    What??
      My ComputerSystem Spec
  10.    21 May 2017 #10
    Join Date : Apr 2017
    Posts : 30
    Windows 10
    Thread Starter

    Hello. Ok update I'm in the process of backing up the current Windows installation that won't boot because I figure I will have to or at least should do that anyway. I'm using EaseUS to do so (made the boot disk ok) because I have a previous EaseUS backup from about 2 months ago, which was my last backup unfortunately...ouch.

    My first choice, obviously, would be to get the current Windows install that won't boot working somehow.

    Any chance of doing that?

    Would it be possible to that using one of your suggestions from earlier somehow:

    If all else fails and
    - your disk is ok
    - you have a valid Windows partition

    Create a disk image of your system partitions
    Clean install Win 10
    Replace the Windows partition with that from your image
    Run startup repair

    Right now I'm doing the disk image thing and downloading the latest Win 10 media create.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Unable to boot to Windows not even from USB drive
Hi, the other day I was greeted with blue screen that "a required device is not connected" and the PC wont boot. I tried EasyBCD but it did not work and stuck on some ATA error loop. But after that I got a new blue screen and this time "The Boot...
General Support
Clean install of W10 - Unable to boot from USB drive?
Hi all, first post, so hoping I'm in the right place :/ ... I'm literally pulling what hair I have left out with this, normally this is a routine task for me, but I'm well and truly stumped, so thought I'd ask a Windows 10 community ... I have...
Installation and Upgrade
Solved wrong drive letter in msconfig / boot in dual boot system
https://www.tenforums.com/attachment.php?attachmentid=61079&stc=1Hi guys in my desktop I have two hard disks ( disk 0 and disk 1 ) . Disk 1 is a clone of disk 0 created by Macrium Reflect Disk 0 : ( C: ) windows 10 pro , upgrade from windows 7 ...
Installation and Upgrade
Unable to merge or expand my system drive
Hello, On my laptop I have a 1 TB HDD and on that drive the usable space was formatted into 2 separate partitions. This doesn't work well for me and I would prefer to have just one partition with all of the usable space. So I've tried everything...
Drivers and Hardware
Unable to boot from Win 10 from hard drive
I recently obtained an HP pavilion desktop pc loaded with Windows 7 which I upgraded to 10. All was going well and everything loaded ok but was having problems with Edge so I decided to do a complete restore from the settings which it didn't...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:02.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums